Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: помогите обновить wine проблема зависимостей held broken packages  (Прочитано 636 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн natanik

  • Автор темы
  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
Добрый день!
Подскажите, что делать, если выдает такую ошибку при установке winehq

custom@custom-VPC:~$ sudo apt-get install wine-devel-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-devel-i386:i386 : Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
custom@custom-VPC:~$ sudo apt-get install  libgstreamer-plugins-base1.0-0:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 indicator-bluetooth : Depends: unity-control-center but it is not going to be installed or
                                gnome-control-center but it is not going to be installed or
                                ubuntu-system-settings but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
« Последнее редактирование: 14 Декабрь 2016, 13:35:38 от natanik »

r-senator@ukr.net

  • Гость
natanik, Попробуй поставить wine-staging,  https://linuxmint.com.ru/viewtopic.php?f=35&t=95, или в Синаптике посмотри, что там есть.
« Последнее редактирование: 13 Декабрь 2016, 05:55:37 от Faeton »

Оффлайн natanik

  • Автор темы
  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
пробовала :)

Цитировать
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
custom@custom-VPC:~$ sudo apt-get install --install-recommends wine-staging-compat
[sudo] password for custom:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging-compat : Depends: winehq-staging but it is not going to be installed
                       Depends: wine-staging
E: Unable to correct problems, you have held broken packages.

r-senator@ukr.net

  • Гость
natanik, вот ссылка это последняя версия wine http://linux.2baranga.org/2016/06/ustanovka-stabilnoj-versii-wine-1-8-2-ubuntu-16-04/

Оффлайн natanik

  • Автор темы
  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
https://www.winehq.org/ - 1.8.5 точно последняя стабильная

Проблема в том, что не могу установить photoshop cc 2015 :(

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 1842
    • Просмотр профиля
- что касается WineHQ, ставь согласно инструкции на этой странице

- а вот что касается проблем с установкой конкретного ПО, то причина скорее всего в отсутствии каких-то библиотек windows, так что потребуется творческий подход... вот тут описан процесс, ПО устанавливается конечно другое, но сам подход заслуживает внимания ::)

Оффлайн natanik

  • Автор темы
  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
F12,
Спасибо за совет :)

Действовала еще по инструкции здесь: https://codereviewvideos.com/blog/wine-1-9-11-on-ubuntu-16-04/

custom@custom-VPC:~$ sudo apt-get install gcc-multilib libasound2-dev:i386 libgsm1-dev:i386 libjpeg8-dev:i386 liblcms2-dev:i386 libldap2-dev:i386 libmpg123-dev:i386 libopenal-dev:i386 libv4l-dev:i386 libx11-dev:i386 libxinerama-dev:i386 libxml2-dev:i386 zlib1g-dev:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libldap2-dev:i386 : Depends: libldap-2.4-2:i386 (= 2.4.31-1+nmu2ubuntu8.2) but 2.4.31-1+nmu2ubuntu8.3 is to be installed
E: Unable to correct problems, you have held broken packages.

А после офиц инструкции такая ошибка:

custom@custom-VPC:~$ sudo apt-get install --install-recommends winehq-devel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-devel : Depends: wine-devel
E: Unable to correct problems, you have held broken packages.

Я такая поняла какие пакеты или зависимости нарушены,а еще какие-то заблокированы :( что делать не очень ясно :)

r-senator@ukr.net

  • Гость
natanik, sudo apt-get install -f

Оффлайн natanik

  • Автор темы
  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
Faeton,
делала уже :) и upgrade тоже :)

custom@custom-VPC:~$ sudo apt-get install -f
[sudo] password for custom:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.

вот корень проблемы:
The following packages have unmet dependencies:
 winehq-devel : Depends: wine-devel
E: Unable to correct problems, you have held broken packages.

что делать с ним не могу понять :)

r-senator@ukr.net

  • Гость
natanik, Wine любит покапризничать :), но постараюсь тебе помочь, а именно перед установкой новой версии wine, например 1.9.8,https://freshnotes.ru/ustanovka-wine-1-9-8-v-ubuntu-16-04/, сначала открой "Synaptic", и удали все старые версии wine, я всегда так делаю! :)  :)
« Последнее редактирование: 14 Декабрь 2016, 14:04:01 от Faeton »

 

Страница сгенерирована за 0.057 секунд. Запросов: 24.