Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Установка Ubuntu 16.10 ( или biolinux 8) на HDD, с Windows 10 на SSD и UEFI.  (Прочитано 1088 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн birdhouse

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Добрый день, форумчане.
Перед тем как писать мольбу о помощи, я попробовал покурить мануалы, факи и прочее, и после череды неудач обратиться к вам - ГУРУ.
У меня есть ноутбук с платой на EUFI, на SSD стоит Windows 10, так же есть HDD на 1ТБ без ОС, используется как свалка.
Хочу поставить на HDD Ubuntu или биолинукс (последний на 14.04) ( т.к. нужно по рабочим потребностям, а виртуалка не выезжает). Как мне это сделать?
Размечал как написано в мануалах на swap, / , /home, выбирал разные диски для установки там загрузчика, но все равно после установки грузится Windows без каких либо признаков установки GRUB. ЧЯДНТ?
Без проблем ставил на старый комп и ноут с BIOS и одним HDD, а тут, похоже, руки-крюки.
Уточняйте, что я не досказал, но у меня уже горит от всего этого.
Больше спасибо всем, кто откликнется.

Оффлайн Vector_2

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Попробуй изменить приоритет загрузки в BIOS c windows на gub-efi в разделе boot, подраздел uefi hard disk drive bbs priorities. (P.S. так приоритет меняется в ноутбуках msi, в других возможно также)

Оффлайн birdhouse

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Переставлял приоритеты загрузки.
Такое ощущение, будто GRUB вообще не существует у меня на ПК.
Интересное наблюдение, Windows boot manager стоит на HDD, когда сама винда на SSD.

Расскажу свой порядок действий, возможно тут ошибка.
Делаю через rufus загрузочную флешку с biolinux 8, выбираю там тип системного интерфейса GPT для EUFI.
Запускаю флешку с бубном, захожу в gprated, режу диск на своп, корень и хоум.
Включаю установку, выбираю там для корня и хоума, выбираю диск для установки загрузчика ( пробовал и на HDD, и на Windows boot manager, и на SSD).
Проходит установка.
Вуаля, ничего нет.
« Последнее редактирование: 23 Декабрь 2016, 11:47:53 от birdhouse »

Оффлайн DimanBG

  • Старожил
  • *
  • Сообщений: 1033
    • Просмотр профиля
birdhouse, точку монтирования для ESP раздела /boot/efi устанавливаешь?

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
birdhouse,
1) нужно указать установщику, где ESP раздел (но не форматировать его)
2) После установки поменять приоритет загрузки на Ubuntu в UEFI
3) Отключить в Win Fast Boot
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн birdhouse

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
1) нужно указать установщику, где ESP раздел (но не форматировать его)
2) После установки поменять приоритет загрузки на Ubuntu в UEFI
3) Отключить в Win Fast Boot
Выключил фастбут у винды, такие настройки в UEFI, такая разметка.
Может я что-то не так размечаю?
Фото настроек при установке и самого UEFI.
https://pp.vk.me/c836424/v836424579/18c26/BJrAhFRrb9g.jpg
https://pp.vk.me/c836424/v836424579/18c1c/cfpfCDS7hAc.jpg

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
birdhouse, что-то вы накосячили с разметкой. Так как в списке загрузки нет Ubuntu У меня вот так


1) Размер ESP раздела не должен превышать 300МиБ (зачастую хватает и 100МиБ)
2) Отступа от начала диска к ESP разделу вроди как не должно быть (в этом не уверен)
3) Показывайте разметку второго харда

UPD. Понял, где вы накосячили. Вы на резервную область винды ставите флаг EFI, но это не верно. Реальный ESP раздел у вас в другом месте
« Последнее редактирование: 23 Декабрь 2016, 23:04:19 от EvangelionDeath »
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн birdhouse

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
UPD. Понял, где вы накосячили. Вы на резервную область винды ставите флаг EFI, но это не верно. Реальный ESP раздел у вас в другом месте
Я не выбирал сам, это по дефолту шло так. Иного ЕСП раздела у меня нет. С флешки загрузился, систему установил, но она не грузится, просто нет граба. Вот как после разметки выглядят диски. Резервная область винды стоит на другом диске, вроде как.
Может мне в ручную создать ЕСП раздел?
https://pp.vk.me/c836424/v836424579/18c46/NSNIxnjM-ek.jpg
https://pp.vk.me/c836424/v836424579/18c50/B1Is4RFpRmQ.jpg
UPD.
КСТАТИ.
Брал ноутбук с линпусом, но я, вроде, форматировал при установке винды все диски. Может из-за этого? Асер_линукс это, наверное, от линпуса. Но как тогда быть?
« Последнее редактирование: 23 Декабрь 2016, 23:33:43 от birdhouse »

Оффлайн DimanBG

  • Старожил
  • *
  • Сообщений: 1033
    • Просмотр профиля
birdhouse, Для sda1 Точка подключения должна быть /boot/efi
Как у EvangelionDeath.
Может мне в ручную создать ЕСП раздел?
Он у тебя уже есть - sda1 - с твоей картинки.

Оффлайн birdhouse

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Для sda1 Точка подключения должна быть /boot/efi
Как у EvangelionDeath.
Почему-то не могу смонтировать /boot/efi na sda1. При установке не выбрать и в gparted'e.
https://pp.vk.me/c836424/v836424579/18c78/Rlpnbc3bQFI.jpg

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
birdhouse, так, вам надо медаль. У вас на одном диске 2 ESP раздела с флагами boot. Уберите флаги c последнего в списке с помощью GParted и загрузчик ставьте на /dev/sda
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн birdhouse

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
, так, вам надо медаль. У вас на одном диске 2 ESP раздела с флагами boot. Уберите флаги c последнего в списке с помощью GParted и загрузчик ставьте на /dev/sda
Это случайно получилось, когда уже тыкал все подряд. Конечно же убрал. Сейчас попробую еще раз переставить с монтированием другим, но вроде и так делал.
https://pp.vk.me/c836424/v836424579/18c8e/PadW-bzfRaw.jpg

UPD. Ничего и этот раз не происходит, но я еще немного погуглил и нашел такую команду, как efibootmgr
Вот лог.
ubuntu@ubuntu:~$ efibootmgr
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0003,0001,2001,2002,2003
Boot0000* ubuntu
Boot0001* Linpus lite
Boot0002* Unknown Device:
Boot0003* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
« Последнее редактирование: 24 Декабрь 2016, 01:02:45 от birdhouse »

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
birdhouse, ну вот, теперь зайдите в UEFI и поставьте Ubuntu первой
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн Петрович

  • Любитель
  • *
  • Сообщений: 91
  • Проблема - когда нет проблем
    • Просмотр профиля
birdhouse, кто устанавливал win 10, какой размер RAM и SSD? Почему установка ubuntu 16.10 на "HDD на 1ТБ без ОС, используется как свалка".
А это читал?
« Последнее редактирование: 24 Декабрь 2016, 11:10:07 от Петрович »
Asus H170M-PLUS; Core i5-6500 3.2GHz; 16GB DDR4-2133; Intel HD Graphics 530 1536MB; InteI i219-V + TL-WDN4800; 2xSSD + HDD; VX2453 23,5"
OS x64: Runtu XFCE 16.04.3; Win 10 Ent; OS X El Capitan 10.11.6

Оффлайн birdhouse

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
birdhouse, кто устанавливал win 10, какой размер RAM и SSD? Почему установка ubuntu 16.10 на "HDD на 1ТБ без ОС, используется как свалка".
А это читал?
Решил проблему вручную прописав в UEFI grub.

 

Страница сгенерирована за 0.061 секунд. Запросов: 24.