Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: clang-3.9  (Прочитано 809 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gena95

  • Автор темы
  • Участник
  • *
  • Сообщений: 193
    • Просмотр профиля
clang-3.9
« : 05 Январь 2017, 22:27:21 »
Всем доброго времени суток! Хочу поиграться с Unreal Engine. Но для него нужен пакет clang-3.9. Но вот проблема, его не в офф репах xenial, там только clang-3.8.
clang-3.9 есть только в yakkety (16.10) http://packages.ubuntu.com/search?keywords=clang-3.9.
Пробовал загрузить вручную .deb - там тянутся другие зависимости, которые тоже надо качать отдельно, для которых есть свои зависимости...
Еще пробовал с сайта http://apt.llvm.org ставить:
wget -O - http://apt.llvm.org/llvm-snapshot.gpg.key | sudo apt-key add -
sudo apt-add-repository "deb http://apt.llvm.org/xenial/ llvm-toolchain-xenial main"
sudo apt-get install clang-3.9
И вот что получаю:
sudo apt-get install clang-3.9
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Заметьте, выбирается «python-clang-3.9» для regex «clang-3.9»
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.

Ну и, есстественно, не могу собрать уже сам Unreal Engine из-за этого, получаю вот такую ошибку:
UnrealBuildTool Exception: ERROR: This version of the engine can only be compiled by clang - refusing to register the Linux toolchain.
Подскажите, пожалуйста, что делать:)

Оффлайн 100tisteg

  • Любитель
  • *
  • Сообщений: 55
    • Просмотр профиля
Re: clang-3.9
« Ответ #1 : 05 Январь 2017, 22:37:30 »
Не знаю, насколько оно поможет, но побуду немножко Кэпом - тут вроде бы исходники есть...

Оффлайн gena95

  • Автор темы
  • Участник
  • *
  • Сообщений: 193
    • Просмотр профиля
Re: clang-3.9
« Ответ #2 : 05 Январь 2017, 23:59:51 »
100tisteg, о, вот, наверное, тоже неплохая идея. Не подскажешь как это сделать? А то я совсем новичок в таком:)

Оффлайн 100tisteg

  • Любитель
  • *
  • Сообщений: 55
    • Просмотр профиля
Re: clang-3.9
« Ответ #3 : 06 Январь 2017, 00:08:12 »
Увы. Найти информацию и понять, что с ней делать - разные навыки, на второй я как раз не богат :(

Оффлайн gena95

  • Автор темы
  • Участник
  • *
  • Сообщений: 193
    • Просмотр профиля
Re: clang-3.9
« Ответ #4 : 06 Январь 2017, 00:47:38 »
100tisteg, вот что я действительно не понимаю, так это почему они не выложили уже собранный бинарник) Или они думают, что если собираешься делать игры, то собирать из исходников ты точно умеешь и имеешь очень мощный компьютер.
Есть еще такая идея. Взять скачать образ yakkety, загрузиться с него, собрать, а потом юзать уже в установленном LTS :)
Но я пока что подожду, может кто-то предложит что-то более адекватное.


Нашел решение!
Опишу, вдруг кому пригодится собирать UE4 под 16.04 LTS.
Скрипт Setup.sh требует для установки наличие именно версии 3.9 и не принимает никакую другую. Но если проделать вот это:
wget -O - http://apt.llvm.org/llvm-snapshot.gpg.key | sudo apt-key add -
sudo apt-add-repository "deb http://apt.llvm.org/xenial/ llvm-toolchain-xenial main"
sudo apt-get install clang-3.9
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Заметьте, выбирается «python-clang-3.9» для regex «clang-3.9»
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.
То скрипт пройдет дальше, т.к. посчитает, что выполнение команды sudo apt-get install clang-3.9 был успешным, не смотря на то, что самого clang-3.9 в системе нет.
Дальше для сборки использует скрипт GenerateProjectFiles.sh и ему нужен clang для сборки. И без него, естесственно он выдаст ошибку. Но суть в том, что ему не обязательна версия 3.9! Я удалил репозиторий, который добавлял до этого и проинсталлировал clang-3.8. И все, теперь собирает. Мб часов через 12 соберет, если успешно - отпишу.
P.S. Проще, кстати, отредактировать сам скрипт и сказать ему, чтобы он ставил clang-3.8, но посколько я уже выполнил этот скрипт, используя способ выше, то править ничего уже не стал, просто удалил репу и вручную доставил версию 3.8.
« Последнее редактирование: 06 Январь 2017, 01:58:54 от gena95 »

 

Страница сгенерирована за 0.136 секунд. Запросов: 22.