Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Запуск бенча Valley  (Прочитано 584 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Mishkinmax

  • Автор темы
  • Участник
  • *
  • Сообщений: 112
    • Просмотр профиля
Запуск бенча Valley
« : 09 Январь 2017, 00:06:03 »
Давно как бы мучаюсь с этой маленькой проблемкой,от релиза к релизу нового дистра. В одном стартует при клике на значёк,в другом не стартует даже через консоль.
Вот ссылка на бенч http://unigine.com/products/benchmarks/valley/

Вот так ругается,если запускаешь через консоль
mishkinmax@UbuntuStation:~$ cd '/home/Установочные пакеты/Для Linux/Unigine_Valley-1.0'
mishkinmax@UbuntuStation:/home/Установочные пакеты/Для Linux/Unigine_Valley-1.0$ sh 'valley'
valley: 5: [: x86_64: unexpected operator
./browser_x86: error while loading shared libraries: libfontconfig.so.1: cannot open shared object file: No such file or directory
mishkinmax@UbuntuStation:/home/Установочные пакеты/Для Linux/Unigine_Valley-1.0$

Прошу помощи ибо интересно сравнивать производительность у новых и старых релизов Убунты.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13501
  • Xubuntu 18.04
    • Просмотр профиля
Re: Запуск бенча Valley
« Ответ #1 : 09 Январь 2017, 00:07:43 »
Mishkinmax,
Попробуйте положить скрипт в менее кудряво названную директорию без пробелов и русского языка.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Mishkinmax

  • Автор темы
  • Участник
  • *
  • Сообщений: 112
    • Просмотр профиля
Re: Запуск бенча Valley
« Ответ #2 : 09 Январь 2017, 00:31:15 »
Пробовал. Всё то же самое один в один.
mishkinmax@UbuntuStation:~$ cd '/home/mishkinmax/Unigine_Valley-1.0'
mishkinmax@UbuntuStation:~/Unigine_Valley-1.0$ sh 'valley'
valley: 5: [: x86_64: unexpected operator
./browser_x86: error while loading shared libraries: libfontconfig.so.1: cannot open shared object file: No such file or directory
mishkinmax@UbuntuStation:~/Unigine_Valley-1.0$

Если он работал в других дистрах,то работал из какой директории не запусти.

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Re: Запуск бенча Valley
« Ответ #3 : 09 Январь 2017, 00:44:42 »
а libfontconfig  установлено?

Оффлайн Mishkinmax

  • Автор темы
  • Участник
  • *
  • Сообщений: 112
    • Просмотр профиля
Re: Запуск бенча Valley
« Ответ #4 : 09 Январь 2017, 00:52:23 »
libfontconfig установлено,только в конце ещё "1" - libfontconfig1

Оффлайн Morisson

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 4588
    • Просмотр профиля
Re: Запуск бенча Valley
« Ответ #5 : 09 Январь 2017, 07:58:03 »
Mishkinmax, надо с i386 на конце. Тебя ж система просит
./browser_x86: error while loading shared libraries: libfontconfig.so.1


Пользователь добавил сообщение 09 Январь 2017, 08:03:41:
sudo dpkg --add-architecture i386 && sudo apt update && sudo apt install libfontconfig:i386
Как-то так. Название пакета может поменяться. Посмотрите, как он точно называется apt search libfontconfig
« Последнее редактирование: 09 Январь 2017, 08:03:41 от Morisson »

Оффлайн Mishkinmax

  • Автор темы
  • Участник
  • *
  • Сообщений: 112
    • Просмотр профиля
Re: Запуск бенча Valley
« Ответ #6 : 09 Январь 2017, 15:03:46 »
Не находит пакет с i386 архитектурой (sudo dpkg --add-architecture i386 && sudo apt update сделал)

mishkinmax@UbuntuStation:~$ apt search libfontconfig
Sorting… Готово
Full Text Search… Готово
libfontconfig1/trusty-updates,trusty-security,now 2.11.0-0ubuntu4.2 amd64 [installed]
  Основная библиотека конфигурации шрифтов - динамическая

libfontconfig1-dbg/trusty-updates,trusty-security 2.11.0-0ubuntu4.2 amd64
  generic font configuration library - debugging symbols

libfontconfig1-dev/trusty-updates,trusty-security 2.11.0-0ubuntu4.2 amd64
  generic font configuration library - development

mishkinmax@UbuntuStation:~$

Пользователь добавил сообщение 09 Январь 2017, 15:11:22:
Но блин парадокс - пакет установил )).
mishkinmax@UbuntuStation:~$ sudo apt install libfontconfig:i386
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Заметьте, вместо «libfontconfig:i386» выбирается «libfontconfig1:i386»
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-headers-3.13.0-32 linux-headers-3.13.0-32-generic
  linux-image-3.13.0-32-generic linux-image-extra-3.13.0-32-generic
Для их удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
  libfreetype6:i386 libpng12-0:i386
НОВЫЕ пакеты, которые будут установлены:
  libfontconfig1:i386 libfreetype6:i386 libpng12-0:i386
обновлено 0, установлено 3 новых пакетов, для удаления отмечено 0 пакетов, и 9 пакетов не обновлено.
Необходимо скачать 543 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 1 721 kB.
Хотите продолжить? [Д/н] д

Только результат всё тот же
mishkinmax@UbuntuStation:~$ cd '/home/Установочные пакеты/Для Linux/Unigine_Valley-1.0'
mishkinmax@UbuntuStation:/home/Установочные пакеты/Для Linux/Unigine_Valley-1.0$ sh 'valley'
valley: 5: [: x86_64: unexpected operator
./browser_x86: error while loading shared libraries: libXrender.so.1: cannot open shared object file: No such file or directory

Пользователь добавил сообщение 09 Январь 2017, 15:12:04:
Ага,теперь другой пакет нужен ?

Пользователь добавил сообщение 09 Январь 2017, 15:25:34:
Всё,спасибо всем огроменное. Бенч работает.
« Последнее редактирование: 09 Январь 2017, 15:25:34 от Mishkinmax »

 

Страница сгенерирована за 0.442 секунд. Запросов: 22.