Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Установка 16.04 на ноут. Не удалось установить пакет grub-efi-amd64-signed  (Прочитано 9512 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Burger444

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Приветствую. Новичок в Ubuntu. Имею некоторые проблемы с установкой 16.04 на ноутбук. Похожие темы на форуме находил, но есть опаска сделать ещё хуже ввиду неопытности.

Присказка:
Купил ноутбук Dell Insiron с предустановленной Ubuntu 14.04. Всенепременно захотелось обновиться до 16.04. Две попытки обычного обновления с помощью "Обновление приложений" (а точнее последовательное обновление самой 14.04 + обновление до 16.04) провалились с автоматическим откатом системы на заводское состояние. Думал попытаться в третий раз, фиксируя все ошибки. В итоге после очередного подвисания обновлятора на как раз таки "grub-efi-amd64-signed", если не ошибаюсь, и аварийного завершения задачи, попытался сначала перезагрузить ноутбук (надеялся на волшебную перезагрузку). В итоге теперь ноут стал загружаться в gnu grub, а пытаясь выйти из него командой exit, ноут подгружал какую-то делловскую компоненту, пытавшуюся безуспешно загрузить Ubuntu с последующим выкидыванием на командную строку (и сообщением что-то в духе "не может найти живую файловую систему").

В итоге решил устанавливать уж тогда 16.04 с внешнего носителя, а точнее говоря с флешки. Установка с флешки, к сожалению, также не дала положительного результата, объявив следующее "Не удалось установить grub-efi-amd64-signed в /target/. Без системного загрузчика GRUB установленная система не будет загружаться".

Основная часть:
После поиска решения проблемы в гугле и на форуме, например, тут: https://forum.ubuntu.ru/index.php?topic=232433.0 выяснилось, что, видимо, надо создать некий раздел на диске. Так вот вопрос: Так ли это, и как именно лучше это сделать. К сообщению прилагаю скриншот с этим самым GParted.

http://pixs.ru/showimage/Screenshot_8823246_24776233.png

P.S. Я вроде не тупой, но новичок полный, так что чем подробнее ответ, тем лучше. Если с подробным объяснением чего куда жать, куда смотреть, чего вводить - то вообще идеально.
« Последнее редактирование: 18 Январь 2017, 16:28:29 от mahinist »

Оффлайн [ COSMIC FIELDS ]

  • Активист
  • *
  • Сообщений: 320
  • Arch Linux | 5.8.arch1-1
    • Просмотр профиля
Тебе надо запустить флешку из под BIOS и выбрать "Стереть диск" при установке.
i7-6700 | ASUS ROG-STRIX-GTX1660TI-O6G-GAMING | DDR4 16GB 2800mHz Kingston HyperX Savage Black
MSI Z170A XPOWER GAMING TITANIUM EDITION | Corsair RM750

Оффлайн viktor ne perestukin

  • Активист
  • *
  • Сообщений: 436
    • Просмотр профиля
Burger444, Имел такую же буду. Решил сменой писАлки. Например, Unetbootin для 16.04 некорректно готовит флешку.
« Последнее редактирование: 15 Январь 2017, 17:31:35 от viktor ne perestukin »

Оффлайн DimanBG

  • Старожил
  • *
  • Сообщений: 1298
    • Просмотр профиля
Burger444, только не жалуйся потом, что что-нибудь не работает, и как всё вернуть как было.

Оффлайн Burger444

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Ах если бы раньше было нормально   :-\
В общем, попробовал действительно установить 16.04 с флешки, "Стерев"-таки диск, но теперь после казалось бы успешной установки подгружается только флешка.

В биосе в Boot sequence стоит единственная галка напротив неё, при попытке добавления туда же жёсткого диска и перезагрузки всё вновь по старому, будто я ничего не добавил.

Если просто убрать загрузку флешки, или не запускать с неё Ubuntu, то, разумеется, всё плохо, ноут начинает сканировать на наличие проблем и выдаёт "Hardware scan complete with no issues... No bootable devices are found! Possible causes could be a corrupt OS image or a boot device is not enabled in BIOS setup."


Оффлайн Burger444

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Ага, спасибо за интересную ссылку. Я всё прочитал, всё опробовал. А точнее говоря сначала опробовал boot-repair, как и указано через командную строку...
http://pixs.ru/showimage/Screenshot_5514806_24813018.png
Как видно, получилось не очень.
Тогда я забил вторую флешку под отдельно скачанный boot-repair cd. Запустил, всё прошло успешно, перезагрузил - толку ноль. После ещё нескольких попыток загрузки так и сяк, в конце концов, при второй попытке подгрузить boot-repair, всё стало зависать. А в последствии ноут перестал запускать и эту флешку, как и жёсткий диск. Думал ради просто проверки установить Windows XP с той же флешки - всё, не видит флешку, не запускает точнее. И попробовал вместо Unetbootin использовать Rufus для этой флешки и винды, всё мимо и мимо.

Так что я совсем закопался и представить себе не могу как это дело починить. Вроде бы проблема должна быть в переносе boot из раздела в раздел (глупые предположения необразованного мозга), но и тут я не могу сообразить. Вроде бы при установки (с первой флешки), Ubuntu всё создал как надо. И на EFI выделил достаточно места, и под swap, остальное оставил под моё усмотрение.
====================================================================================

Уважаемый Burger444 настоятельно рекомендую прочитать и в дальнейшем выполнять  - Руководство по добавлению изображений на форум

Отредактировал
-mahinist
« Последнее редактирование: 18 Январь 2017, 16:33:40 от mahinist »

Оффлайн Алексиус

  • Участник
  • *
  • Сообщений: 155
    • Просмотр профиля
Burger444, картинку которую вы выложили в соседней теме вы взяли из джпартед? Значит с флешки вы загрузиться можете?
Плз, не нужно пихать такие здоровенные скриншоты в тему, используйте превьюшки. В правилах рписан способ вставки картинок
ну, уже ответили в соседней теме (:
« Последнее редактирование: 18 Январь 2017, 15:15:40 от Алексиус »
Ubuntu 16.04

Оффлайн Дюшик

  • Активист
  • *
  • Сообщений: 801
    • Просмотр профиля
Думал ради просто проверки установить Windows XP с той же флешки - всё, не видит флешку, не запускает точнее.

Она и не должна запускаться. ХР нельзя установить в UEFI режиме (насколько я понял Ubuntu вы устанавливали в UEFI). На мой взгляд, вам нужно разобраться с настройками UEFI-BIOS (сделать правильные настройки), затем правильно подготовить установочный носитель, диск или флешку. Прочитать/изучить, как устанавливать ОС на платы с UEFI (ссылка была выше) и после этого пробовать устанавливать систему.

Оффлайн Burger444

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Прочитать/изучить, как устанавливать ОС на платы с UEFI (ссылка была выше) и после этого пробовать устанавливать систему

Вышележащую ссылку прочитал и более менее осонал, а также парочку свяанных с нею также. Всё вроде бы соответствует указаниям.

По порядку:
Установочная флешка записана с помощью Unetbootin (опять же по инструкции всё). На отформатированный в фат32 сосуд помещается дистрибутив Ubuntu 16.04. Далее загрузка флешки в ноут через UEFI. Далее установка по порядку, с затиранием всего прошлого, единственная разница, что диск не сам разбивал, а установщик постарался, на три части, как и сказано выше. EFI, подкачка, остальное. Что вроде бы описанному соответствует. Графа "Возможные проблемы" также не смогла помочь. На первую команду для терминала система никак не реагирует (на последущие тем более никакого толка). Упомянутый "спасательный CD" также не дал результатов, хотя и отработал по плану, без ошибок.
В биосе подключается только флешка (остальное не попадает в очередь загрузки). Если добавляю вручную (сам ЖД отражён в списке добавляемых загрузочных устройств), то после перезагруки всё по старому. Что там ещё правильней поставить можно - ума не приложу, там не так много настроек. Команда из соседнего топика откликается следующим
Цитировать
Installing for i386-pc platform.
grub-install: error: failed to get canonical path of `/cow'.
Насчёт скриншотов исправлюсь, если ещё понадобятся.

Пользователь добавил сообщение 19 Январь 2017, 04:50:03:
Ну всё, сейчас-то я вообще всё вплоть до мелочей сделал как по инструкции, всё заново провернул. Вручную поделил на разделы как и сказано, отметил точки монтирования эти. Перезагрузил - по-старому. Boot-repair - по-старому: http://paste.ubuntu.com/23825232/ . Говорит, мол, "Please do not forget to make your BIOS boot on sda1/EFI/ubuntu/shimx64.efi file!" Думаю, оу, интересно а как это, может всё-таки в биосе я что-то сделал не так... Дошло, что добавлял "boot option" неверно, там всё спокойно выбирается и всё такое. Казалось бы тут всё должно заработать наконец - неа, вновь тупо пропадает "boot option", вручную добавленная. Вот фотографии, собственно, выбора последовательности загрузки (фотик у меня не очень, но, надеюсь, прочитать можно): https://yadi.sk/d/1nHdj0r339jyfM . Есть ещё какие-либо идеи где ещё можно было накосячить, чего-либо недоделать? Уж неделю где-то парюсь с этим, получается.

Пользователь добавил сообщение 19 Январь 2017, 06:29:01:
Не, ладно. На легаси попробовал установить - всё установилось. А с UEFI - фиг с ним с UEFI. Не хочет работать - не больно-то и хотелось (хотя хотелось). За сим можно завершить тему, всем спасибо за подскаки, много нового осознал.
« Последнее редактирование: 19 Январь 2017, 06:29:01 от Burger444 »

Оффлайн [ COSMIC FIELDS ]

  • Активист
  • *
  • Сообщений: 320
  • Arch Linux | 5.8.arch1-1
    • Просмотр профиля
Да всё там работает в UEFI. У меня вообще BIOS сброшен по стандарту, и вроде как включен Secure Boot.
Ubuntu идеально ставится и работает в UEFI режиме без проблем.
i7-6700 | ASUS ROG-STRIX-GTX1660TI-O6G-GAMING | DDR4 16GB 2800mHz Kingston HyperX Savage Black
MSI Z170A XPOWER GAMING TITANIUM EDITION | Corsair RM750

Оффлайн BaaTLT

  • Заслуженный пользователь
  • Локальный модератор
  • Активист
  • *
  • Сообщений: 567
  • Выключи компьютер и ЖИВИ !!!
    • Просмотр профиля
Столкнулся с такой же проблемой. Диск размечал и вручную, и автоматом результат один и тот же - "Не удалось установить grub-efi-amd64-signed в /target/. Без системного загрузчика GRUB установленная система не будет загружаться".

[Решение]
Во время установки размечаем диск либо автоматом либо вручную по инструкции.
После получения этой ошибки не выходим из системы.
1.НЕ закрываем установщик.
2.Открываем терминал и пишем:
sudo chroot /target
apt update
apt install grub-efi-amd64-signed

3.Ждем когда установиться.

4.Выходим из chroot
exit
5.Перегружаем систему.
« Последнее редактирование: 03 Апрель 2017, 15:24:36 от BaaTLT »

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Из примечаний к одному из дистров.
Цитировать
Known issues Grub fails to install grub-efi-amd64-signed In EFI mode, if the installer fails with the following error message: "The 'grub-efi-amd64-signed' package failed to install into /target/." Reboot the live medium and disconnect the computer from the Internet before launching the installation. The installation should then proceed in offline mode and prevent this issue from happening.

Оффлайн BaaTLT

  • Заслуженный пользователь
  • Локальный модератор
  • Активист
  • *
  • Сообщений: 567
  • Выключи компьютер и ЖИВИ !!!
    • Просмотр профиля
Перевод
Цитировать
Известные проблемы Grub не удается установить grub-efi-amd64-signed В режиме EFI, если установщик выходит из строя со следующим сообщением об ошибке: «Не удалось установить пакет« grub-efi-amd64-signed »в / target /.» Перезагрузите живой носитель и отключите компьютер от Интернета перед запуском установки. Затем установка должна перейти в автономный режим и предотвратить эту проблему.

Проверю в понедельник. Отпишусь.

UPD.
Проверил. Этот способ не работает.
« Последнее редактирование: 03 Апрель 2017, 15:26:04 от BaaTLT »

 

Страница сгенерирована за 0.244 секунд. Запросов: 24.