Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Обновился до php 7.1  (Прочитано 1958 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн hznovich

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Обновился до php 7.1
« : 15 Январь 2017, 11:18:30 »
Доброго времени суток. Имеется ubuntu 16.04 server. Обновился с php 7.0 до php 7.1 перестал работать один из сайтов:

Warning: mysqli_real_connect(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /www/sban/includes/adodb/drivers/adodb-mysqli.inc.php on line 124

Warning: mysqli_real_connect(): (HY000/2002): php_network_getaddresses: getaddrinfo failed: Name or service not known in /www/sban/includes/adodb/drivers/adodb-mysqli.inc.php on line 124

Fatal error: mysqli error: [2002: php_network_getaddresses: getaddrinfo failed: Name or service not known] in CONNECT(sbanuser, '****', '****', ) in /www/sban/includes/adodb/adodb-errorhandler.inc.php on line 79

Помогите, пожалуйста, с решением проблемы.

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: Обновился до php 7.1
« Ответ #1 : 15 Январь 2017, 13:21:35 »
Видимо нужно смотреть, что там используется в строке 124 файла /www/sban/includes/adodb/drivers/adodb-mysqli.inc.php
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн hznovich

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Обновился до php 7.1
« Ответ #2 : 15 Январь 2017, 15:18:16 »
Вот файлик

Пользователь добавил сообщение 15 Январь 2017, 15:50:09:
До этого стояла ubuntu 14.04 с php 5.6. Перешел на 7.0, получилась такая же ерунда. Написал разработчику, он ответил что нет доступа к mysql. Я не стал заморачиваться, переустановил на 16.04 и все заработало на php 7. Сейчас нужно php 7.1 и опять беда ((( переустанавливать опять не очень хочется (((

Пользователь добавил сообщение 15 Январь 2017, 16:47:53:
Сейчас удалил php7.1 со всеми модулями, ситуация не изменилась. Похоже дело не в сайте.
« Последнее редактирование: 15 Январь 2017, 16:47:53 от hznovich »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27414
    • Просмотр профиля
Re: Обновился до php 7.1
« Ответ #3 : 16 Январь 2017, 10:09:11 »
Вы вообще текст ошибки читали?…
Очевидно же, что PHP тут не при чём. У вас DNS не работает.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн hznovich

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Обновился до php 7.1
« Ответ #4 : 16 Январь 2017, 10:34:42 »
Подскажите в какую сторону смотреть?

Пользователь добавил сообщение 16 Январь 2017, 10:38:12:
И почему мог сломаться после обновления php?

ping -c 2 localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.011 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.014 ms
« Последнее редактирование: 16 Январь 2017, 15:43:47 от hznovich »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27414
    • Просмотр профиля
Re: Обновился до php 7.1
« Ответ #5 : 17 Январь 2017, 15:41:49 »
Подскажите в какую сторону смотреть?
В сторону настроек БД сайта и разрешения имён.
ping -c 2 localhost
А при чём тут пинг и локалхост?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн hznovich

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Обновился до php 7.1
« Ответ #6 : 17 Январь 2017, 17:36:27 »
Вы мне написали, что: Очевидно же, что PHP тут не при чём. У вас DNS не работает.
ping localhost-а работает.
mysql на localhost-е, другие сайты на этом же компе работают нормально.

Пользователь добавил сообщение 17 Январь 2017, 17:47:58:
Переписка с разработчиком сайта:
Hello. After update to php 7.1 sourceban breaks:
`Warning: mysqli_real_connect(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /www/sban/includes/adodb/drivers/adodb-mysqli.inc.php on line 124
Warning: mysqli_real_connect(): (HY000/2002): php_network_getaddresses: getaddrinfo failed: Name or service not known in /www/sban/includes/adodb/drivers/adodb-mysqli.inc.php on line 124
Fatal error: mysqli error: [2002: php_network_getaddresses: getaddrinfo failed: Name or service not known] in CONNECT(sbanuser, '', '', ) in /www/sban/includes/adodb/adodb-errorhandler.inc.php on line 79`
Whats wrong, help please...
PS: Ubuntu 16.04

[b]@galexrt[/b]

What address are you using to connect to the database server?
The issue is that the hostname you are using is invalid and can't be resolved to an IP address.

[b]hznovich[/b]
Localhost. I tried 127.0.0.1 and etc, doesn't work. Other websites work at the same system normally now.

[b]galexrt[/b]
Run the following command on the webserver and post the output:

cat /etc/hosts
     
[b]hznovich[/b]
127.0.0.1       localhost
127.0.1.1       gs-vlv-02

[b]galexrt[/b]
Do the "other websites" also use PHP 7.1?
     
[b]hznovich[/b]
yes. Now i remove php7.1 and all modules, but doesn't work (((

$ php -v
PHP 7.0.14-2+deb.sury.org~xenial+1 (cli) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.0.6, Copyright (c) 2002-2016, by ionCube Ltd.
    with Zend OPcache v7.0.14-2+deb.sury.org~xenial+1, Copyright (c) 1999-2016, by Zend Technologies

[b]galexrt[/b]
Post the content of the /etc/resolv.conf.
     
[b]hznovich[/b]
nameserver 95.154.113.10
nameserver 95.154.112.75
nameserver 172.17.0.79
search inetvl.ru vladlink.ru

[b]galexrt[/b]
Please post your sourceBans config (without password).
     
[b]hznovich[/b]
<?php
/**
 * config.php
 *
 * This file contains all of the configuration for the db
 * that will
 * @author SteamFriends Development Team
 * @version 1.0.0
 * @copyright SteamFriends (www.SteamFriends.com)
 * @package SourceBans
 */
if(!defined('IN_SB')){echo 'You should not be here. Only follow links!';die();}

define('DB_HOST''localhost');                         // The host/ip to your SQL server
define('DB_USER''sbanuser');                                  // The username to connect with
define('DB_PASS''');                                              // The password
define('DB_NAME''sbans');                                             // Database name
define('DB_PREFIX''sb');                                      // The table prefix for SourceBans
define('DB_PORT','3306');                                                       // The SQL port (Default: 3306)
define('SB_WP_URL','http://sban.example.com');

//define('DEVELOPER_MODE', true);                       // Use if you want to show debugmessages
define('SB_MEM''128M');                               // Override php memory limit, if isn't enough (Banlist is just a blank page)
?>

     
[b]galexrt[/b]
Add this to the config.php. before the ?>, go to your sourcebans page and post the output:

print_r('mysqli://'.DB_USER.':'.DB_PASS.'@'.DB_HOST.':'.DB_PORT.'/'.DB_NAME);
Replace your password with the word PASSWORD in the output.
     
[b]hznovich[/b]
mysqli://sbanuser:PASSWORD@localhost:3306/sbans

[b]galexrt[/b]
Are the following commands working on the webserver?

ping -c 2 localhost
ping -c 2 127.0.0.1
     
[b]hznovich[/b]
$ ping -c 2 localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.011 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.014 ms

[b]galexrt[/b]
Can you reinstall SourceBans++ and check if the issue continues to exist?
(Please note: This is not an issue of SourceBans or SourceBans++! This seems to an issue on with your server configuration.)
« Последнее редактирование: 17 Январь 2017, 17:47:58 от hznovich »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27414
    • Просмотр профиля
Re: Обновился до php 7.1
« Ответ #7 : 17 Январь 2017, 20:46:28 »
Ну вот разработчик пишет тебе то же самое. Ибо ошибка возникает в момент подключения к серверу по указанному тобой адресу, причём текст ошибки недвусмысленно намекает на сетевую её природу.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн hznovich

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Обновился до php 7.1
« Ответ #8 : 18 Январь 2017, 07:19:58 »
Понятно. Спасибо за "помощь". Придется самому разбиратья. Просто уже была такая проблема после перехода с php 5.6 на 7, не смог разобраться. Переустановил ubuntu и все норм стало. А сейчас нет желания переустанавливать,  написал на форуме в надежде на помощь... Тему можно закрыть.

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Re: Обновился до php 7.1
« Ответ #9 : 18 Январь 2017, 08:41:52 »
написал на форуме в надежде на помощь...
Вам и предоставили помощь. Вектор поиска решения проблемы дали. А разбираться в любом случае придётся самому. Иначе это получится сделать за Вас, а не помочь Вам. Вы ответственное лицо за работоспособность сайта - отрабатывайте свои обязанности. За деньги Вы это делаете или за бонусы в карму - это уже Ваше дело.
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27414
    • Просмотр профиля
Re: Обновился до php 7.1
« Ответ #10 : 21 Январь 2017, 00:12:15 »
Спасибо за "помощь". Придется самому разбиратья.
Если вам нужно, чтобы разобрались за вас - озвучивайте сумму. Но уже не на этом форуме.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.481 секунд. Запросов: 24.