Форум русскоязычного сообщества Ubuntu


Автор Тема: Не могу корректно установить Ubuntu 16.04 через флешку  (Прочитано 1521 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн XFAI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
День добрый.

Изначально имелся ноутбук ACER Aspire V5-552PG с установленной Windows 10.
Значит, есть флешка, на которую через UNetbootin (предварительно отформатировав по FAT32)
поставил ubuntu-16.04.1-desktop-amd64.
Теперь два сценария работы, при каждом из которых приоритет загрузки с флешки стоит на первом месте:
1. UEFI, Secure Boot: Disabled - С интервалами раз в полторы секунды мигает логотип ACER и больше ничего не происходит.
1.1. UEFI, Secure Boot: Enabled - Тоже самое что и в пункте 1.
2. Legacy - Всё нормально загружается, Ubuntu ставится. Однако, во время разбиения на диски система попросила выделить маленький раздел (~1mb) с точкой монтирования под какие-то собственные "BIOS-нужды". Я выполнил это и всё заработало.

Однако я недоволен этим, потому что для того, чтобы загрузить Ubuntu мне нужно лезть и ставить Legacy или UEFI для загрузи Windows соответственно. Есть ли какой-нибудь более комфортный способ реализации загрузки? В идеале это должно выглядит так:
1. Запускаю ноутбук
2. Предлагает выбрать что загрузить (Windows или Ubuntu)
3. Если в течение 3-х секунд сам ничего не нажал, то загружается Windows

На текущий момент Ubuntu на ноутбуке не установлена.
« Последнее редактирование: 08 Февраль 2017, 11:34:45 от XFAI »

Оффлайн XFAI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13498
  • Xubuntu 18.04
    • Просмотр профиля
XFAI,
Так и должно быть примерно. Но обе системы должны быть поставлены либо в legacy, либо в UEFI. Надо разбираться почему у вас Ubuntu В UEFI не грузится. При загрузке в UEFI режиме выбирать надо не "загрузку с флешки", а Ubuntu в приоритете загрузки.
В биосе вообще отключите возможность загрузки в legacy, чтобы не путаться.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн [ COSMIC FIELDS ]

  • Активист
  • *
  • Сообщений: 320
  • Arch Linux | 5.8.arch1-1
    • Просмотр профиля
Скажу больше. У меня и без UEFI и с UEFI с включенным Secure Boot всё идеально работает.
И в ДуалБуте с Win10 с поставленным GRUB на первое место приоритета.
BIOS обновил несколько дней назад, в 2017 вышла обнова. BIOS сброшен по умолчанию.
Ну это так, дополнил. До этого всё так же было и всегда работало без проблем.
И установка, и работа системы, всё по стандарту.
i7-6700 | ASUS ROG-STRIX-GTX1660TI-O6G-GAMING | DDR4 16GB 2800mHz Kingston HyperX Savage Black
MSI Z170A XPOWER GAMING TITANIUM EDITION | Corsair RM750

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13498
  • Xubuntu 18.04
    • Просмотр профиля
С включенным Secure Boot работает. Только неподписанные модули не грузятся, ну и гибернация не работает. Но не всем это нужно.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Sly_tom_cat

  • Don't worry, be happy!
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 12073
  • Xubuntu 20.04 (64bit)
    • Просмотр профиля
флешка, на которую через UNetbootin
UNetbootin - уже не торт - он как-то фигово делает флешки - в UEFI они не грузятся.

Делайте через rufus из винды или просто копируйте образ на устройство из Ubuntu командой:
sudo cp <путь и имя образа.iso> /dev/sd<буква под которой у вас флешка видна среди устройств: определите из вывода sudo fdisk -l>
Индикатор для Yandex-Disk: https://forum.ubuntu.ru/index.php?topic=241992
UEFI-Boot - грузимся без загрузчика: http://help.ubuntu.ru/wiki/uefiboot

Оффлайн [ COSMIC FIELDS ]

  • Активист
  • *
  • Сообщений: 320
  • Arch Linux | 5.8.arch1-1
    • Просмотр профиля
С Винды теперь пишу Руфусом.
А с Ubuntu пробовал UNETBOOTIN писать Win10 и Ubuntu на флешку, всё идеально работает в UEFI.
На Линухе только UNET буду юзать. UEFI пишет отлично.
На новом Mint KDE записывал Ubuntu встроенной прогой, в итоге получилась дичь, флешка не очистилась, и как то получилось 2-4 раздела.
После установки нажал "Перезагрузить", и был бесконечный чёрный экран.

P.S. Думал типо Mint 18.1 KDE красивый, а оказался мега убогим. Баги в DE, нереально перегруженный интерфейс абсолютно идиотскими и ненужными фичами, перегруженные непонятные настройки системы. Например переключение устройств вывода звука делается в трёх разных местах, в одной вкладке приоритет устройств, в другой ещё что то подобное, в третьей устройство по умолчанию.
Запущенная прога в трее вообще бред. Клик правой кнопкой, вылезает огромный список, свернуть, развернуть, настроить виджеты и ещё несколько ненужных строчек. Хотя виджеты вообще относятся к модулю рабочего стола.
Значок Steam в трее вообще не нажимается. Не создаются ярлыки на рабочий стол.
« Последнее редактирование: 08 Февраль 2017, 17:28:54 от [ COSMIC FIELDS ] »
i7-6700 | ASUS ROG-STRIX-GTX1660TI-O6G-GAMING | DDR4 16GB 2800mHz Kingston HyperX Savage Black
MSI Z170A XPOWER GAMING TITANIUM EDITION | Corsair RM750

 

Страница сгенерирована за 0.151 секунд. Запросов: 24.