Форум русскоязычного сообщества Ubuntu


Автор Тема: Плагин MathMap и Гимп 2.8  (Прочитано 1585 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн robinzoid

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Плагин MathMap и Гимп 2.8
« : 30 Январь 2017, 12:05:54 »
Доброго времени суток всем присутствующим.
Проблема, к которой я не очень понимаю как подступиться, нарисовалась такая. В Убунте 12.04 на Гимпе 2.6 был у меня плагин MathMap. Плагин довольно интересный.



(Картинки это превьюшки, по ним можно щёлкнуть).
Но Ubuntu поменялась, новая LTS стала 14.04, Гимп в ней тоже поменялся на 2.8 и прежние .deb-пакеты плагина срабатывать перестали. На всякий, они лежат в этой папке на яндекс-диске. https://yadi.sk/d/4VFnCXER3Bndgy  Однако на Альтлинуксе 6 в репозитории лежал .rpm-пакет именно для Гимпа 2.8. Матмап и в Альте 7 с него работает нормально.



Для Убунты мне .deb пакета с плагином так найти и не удалось. Прежние не работали, решил програшкой Алиенс из работающего rpm сделать deb. Всё получилось, пакет установился, установшик сказал что всё нормально.
Одна проблема. Плагина нет как нет...
Кстати эти пакеты лежат на https://yadi.sk/d/jDsNZEv93BndbN если кого заинтересует что да как.



То есть в Гимпе его нет. Распаковав оба пакета стал смотреть что в них водится. А потом куда это, что водится, встало. Встало нормально, согласно заявленным директориям аналогично как и в Альте.

 

Но в Альте работает, В Ubuntu нет...
А вот почему??? Есть у кого идеи почему это может происходить?

Оффлайн robinzoid

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: Плагин MathMap и Гимп 2.8
« Ответ #1 : 01 Февраль 2017, 20:29:14 »
По какому-то наитию щёлкнул по исполняемому файлу правой кнопкой, получил "запустить в консоли". Запустил... Получил:

/usr/bin/mathmap: /usr/lib/libgtksourceview-2.0.so.0: no version information available (required by /usr/bin/mathmap)
/usr/bin/mathmap: /lib/i386-linux-gnu/libpng12.so.0: version `PNG_12' not found (required by /usr/bin/mathmap)


Проверил в Синаптике. Обе эти библиотеки стоят... Но понять что происходит всё-таки не удаётся...

Оффлайн Igor_ubuntu

  • Участник
  • *
  • Сообщений: 100
    • Просмотр профиля
Re: Плагин MathMap и Гимп 2.8
« Ответ #2 : 01 Февраль 2017, 21:11:35 »
Но понять что происходит всё-таки не удаётся...
Но конвертация rpm в deb - это ведь не универсальный способ. Оно было собрано под альт и имеет параметры соответственно альту, а запускаете на Ubuntu..
Посмотрите это how-to - http://gimpchat.com/viewtopic.php?f=9&t=4550   о компиляции этого плагина.


Оффлайн robinzoid

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: Плагин MathMap и Гимп 2.8
« Ответ #3 : 02 Февраль 2017, 10:38:07 »
Спасибо....
Хотя пока эффект превосходит ожидания...


Оффлайн бамбук

  • Активист
  • *
  • Сообщений: 541
  • Kubuntu 20.04 LTS x86_64
    • Просмотр профиля
Re: Плагин MathMap и Гимп 2.8
« Ответ #4 : 02 Февраль 2017, 11:53:53 »
robinzoid

ты хоть бы написал ....здесь  инструкцию что ли . (по установке плагина)

для всех.
Chuwi LapBook 14.1   ревизия ноутбука-3.0

Оффлайн robinzoid

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: Плагин MathMap и Гимп 2.8
« Ответ #5 : 02 Февраль 2017, 11:55:26 »
Всё. Решено.
Работавший деб-пакет у меня был на ноуте, закопанным в тамошних файлах, я про него не сразу вспомнил. Сначала установил самодельный, с Альта, потом поверх него поставил нормальный. Оба работать отказались, почему я и расчирикался здесь. Но когда в Синаптике полностью удалил самоделку и на чистое место поставил деб-пакет многолетней давности, всё заработало.
Если кто тоже захочет повозиться с этим плагином, пакет лежит тут: https://yadi.sk/d/JuiPPwQv3BncVj


Оффлайн бамбук

  • Активист
  • *
  • Сообщений: 541
  • Kubuntu 20.04 LTS x86_64
    • Просмотр профиля
Re: Плагин MathMap и Гимп 2.8
« Ответ #6 : 02 Февраль 2017, 15:06:15 »
при установке данного пакета

 


uname -a
Linux linux 4.4.0-53-generic #74-Ubuntu SMP Fri Dec 2 15:58:04 UTC 2016 i686 i686 i686 GNU/Linux
« Последнее редактирование: 02 Февраль 2017, 15:08:18 от бамбук »
Chuwi LapBook 14.1   ревизия ноутбука-3.0

Оффлайн robinzoid

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: Плагин MathMap и Гимп 2.8
« Ответ #7 : 07 Февраль 2017, 13:26:41 »
Вот тут ничего не скажу. Вживую у меня этот пакет устанавливается в ролике в третьей части. Первая часть для винды, вторая Альт (ну на Альте у меня виртуалка) а третья Ubuntu 14.04.  https://youtu.be/sRvTVoPtkno

Собственно я это для форума по Гимпу делал, а там многие на виндовс, потому с неё и начал. А так всё работает. Почему - не знаю...




Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2679
    • Просмотр профиля
Re: Плагин MathMap и Гимп 2.8
« Ответ #8 : 07 Февраль 2017, 15:01:13 »
robinzoid, у вас 32х битная система?
У меня не ставится на 64х битную систему, ваш deb пакет.
Неразрешенная зависимость: libfftw3-3:i386.
Intel Core i3-3240 3.40GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, KINGSTON SV300S37A240G, Kubuntu 20.04

 

Страница сгенерирована за 0.359 секунд. Запросов: 24.