Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Не запускается Ubuntu и проблема с отображением HDD в биос. Спасите!!  (Прочитано 2379 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн WRAI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
    • bestfleur.ru
Помогите пожалуйста новичку!

Проблемы и симптомы следующие -

не запускается Ubuntu на ноутбуке Asus X540Y
при запуске пишет -

Warning: fsck not present, so skipping file system

потом еще несколько строк, а в конце :
no init found. Try passing init= bootarg.

Попутно в биосе в boot не могу выбрать HDD, он там не отображается, хотя в другом разделе его вижу.
Настройки биоса сбрасывал.
Интернет второй день рою.

Пожалуйста помогите, знатоки!  :-\

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1443
    • Просмотр профиля
Отключить "Secure Boot", попробовать загрузиться с LiveCD/Flash и проверить диск.

Онлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13459
  • Xubuntu 18.04
    • Просмотр профиля
WRAI,
Ну что-то накрылось. Ничего тут не скажешь. Secure Boot тут ни при чем.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн WRAI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
    • bestfleur.ru
Спасибо за советы!

Про Secure boot читал, он отключен.
Проверку диска делал, ошибок не выявлено.

Ноутбук новый, только вчера купил.
Принес домой, когда начал устанавливать, все в биосе нормально отображалось, а теперь нет.

Сам  hdd как я понимаю в порядке, но не видится в boot. Нашел даже решение такой проблемы в инете, но для моего биоса оно не подходит(

Что самое смешное, даже линукс установился, но не могу загрузить его( Ошибки выше написал.

Оффлайн Heider

  • Старожил
  • *
  • Сообщений: 1250
    • Просмотр профиля
Что самое смешное, даже линукс установился, но не могу загрузить его
Вставь пока что флешку в картридер, а на ней установи grub, пропиши загрузку линукса.

А вообще, если
Ноутбук новый, только вчера купил.
то самое время, отнести его назад.

Оффлайн WRAI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
    • bestfleur.ru
Что самое смешное, даже линукс установился, но не могу загрузить его
Вставь пока что флешку в картридер, а на ней установи grub, пропиши загрузку линукса.

Понял. Буду искать в интернете, как это сделать)) Я не специалист этих дел. Спасибо за совет!

А вообще, если
Ноутбук новый, только вчера купил.
то самое время, отнести его назад.

Не думаю, что с другим будет лучше. Но спасибо за предложение.

Оффлайн vasyl

  • Старожил
  • *
  • Сообщений: 1724
    • Просмотр профиля
WRAI, с флешки Ubuntu загружается ?
Какая версия Ubuntu ?
Устанавливал вместо виндовс или рядом или ноут без ос был ?
« Последнее редактирование: 30 Январь 2017, 21:08:15 от vasyl »
Ubuntu Mate 16.04 + Windows 10

Оффлайн Heider

  • Старожил
  • *
  • Сообщений: 1250
    • Просмотр профиля
Если удастся как-то загрузиться в основной линукс, то прямо оттуда сделай:
sudo grub-install /dev/sdXГде /dev/sdX это загрузочная флешка, вместо X должна быть цифра. Если будешь грузиться с LiveUSB, то нужно примонтировать раздел, где стоит основной линукс куда-нибудь в /mnt и тогда
sudo grub-install  --boot-directory=/mnt/boot /dev/sdXТак должно загрузиться без настроек.
« Последнее редактирование: 30 Январь 2017, 21:12:09 от Heider »

Оффлайн WRAI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
    • bestfleur.ru
WRAI, с флешки Ubuntu загружается ?
Какая версия Ubuntu ?
Устанавливал вместо виндовс или рядом или ноут без ос был ?

C флешки загружается. Ubuntu 16.04.1 32bit


Переразметил заново hdd, установил. Но та же ситуация. Не могу запустить hdd.
И запустить установленную Ubuntu тоже не могу((

toZen

  • Гость
WRAI, загрузитесь ещё раз в лайф и покажите скрин по:
sudo gparted
« Последнее редактирование: 04 Февраль 2017, 09:36:58 от τοΖεη »

Онлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13459
  • Xubuntu 18.04
    • Просмотр профиля
Случаем не GPT разметка, а загрузка в эмуляции БИОС? Так можно намудрить, если постараться. Результат будет именно таким.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6780
    • Просмотр профиля
WRAI, а чего-это Ubuntu 32-разрядная? Этот комп. вполне потянет 64. И как раз в 32-разрядной системе, насколько помню, были какие-то непонятки с UEFI-GRUB, а в 64-разрядной всё должно работать.
« Последнее редактирование: 06 Февраль 2017, 06:37:42 от maks05 »

Оффлайн virusoft

  • Активист
  • *
  • Сообщений: 320
    • Просмотр профиля
    • Virusoft
Переразметил заново hdd, установил. Но та же ситуация. Не могу запустить hdd.
И запустить установленную Ubuntu тоже не могу((
Загрузчик куда устанавливал? На диск или на раздел? Это важно.
Диск это sda(без указания каких-либо цифр), а раздел sda1(2,3 и т.д., цифры могут быть любые).
Про настройки загрузки тут уже говорили. Если у тебя комп 64-битный, то и версию системы ставь такую же. На размер памяти пока смотреть не следует.
Если работает - не трогай. Linux - гибкая система, но один раз прогнувшись может обратным ходом распрямиться и ударить по самому (…) месту. Думай о будущем и все будет хорошо.

Онлайн DimanBG

  • Старожил
  • *
  • Сообщений: 1292
    • Просмотр профиля
Случаем не GPT разметка, а загрузка в эмуляции БИОС? Так можно намудрить, если постараться. Результат будет именно таким.
100 пудов. Ноут модели 2016 г.
WRAI, читай сначала инструкции по установке на машины с УЕФИ. Если что-то не понятно, тогда спрашивай. Вообщем - сначала думай, а только потом делай. А не наоборот. 

Оффлайн WRAI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
    • bestfleur.ru
τοΖεη, Вот сделал. https://pp.vk.me/c638122/v638122897/21e55/24bW-It-I8w.jpg

maks05, 64 битная вообще не устанавливалась. Ошибку установки GRUB выдавала в самом конце.

virusoft, вот насчет куда устанавливал уже не помню(

DimanBG, уже читаю. Спасибо.

Пользователь добавил сообщение 04 Февраль 2017, 13:35:32:
А теперь порывшись в интернете, я подумал, что удалил какой-то раздел на hdd при установке. Раздел, который отвечает за загрузку hdd в Uefi
 :-\

Пользователь добавил сообщение 04 Февраль 2017, 14:59:52:
На сайте Asus нашел - "Будь то U диск или CD-ROM , Вам нужно производить установку системы в формате 64bit. Если системный диск в формате 32bit ,  загрузочное устройство не отобразится в меню UEFI."

Попробую установить-таки 64 бита)))

Пользователь добавил сообщение 04 Февраль 2017, 19:29:03:
Все установилось! :-)

Спасибо всем большое! :D Вы очень участливые ребята. С такой безвозмездной помощью в реальной жизни редко можно столкнуться))


Постараюсь здесь описать, как удалось решить проблему, а также почему она в принципе возникла - вдруг кому-то будет полезно. Прошу прощения, если что-то опишу неверными терминами. Я не спец)

1. При первой установке Ubuntu 64 bit удалил все разделы, а в процессе установки возникла ошибка. В результате, с жесткого диска видимо(!) удалились файлы отвечающие за определение устройства, как загрузочного.
2. В UEFI Aptio Setup Utility перестал отображаться жесткий диск в разделе Boot.
3. Прочитал на форуме, а также на сайте Asus рекомендацию устанавливать все же 64 битную систему.
4. Создал загрузочную флешку через другую программу, чем изначально. Использовал WinSetupFromUS.
5. Установил систему. В процессе установки выбрал пункт - удалить все с жесткого диска и разметить автоматически с использованием LMV. (возможно это не лучший вариант, но мне помогло).
6. Все прошло успешно.

Еще раз спасибо откликнувшимся на пост! :-)
« Последнее редактирование: 04 Февраль 2017, 19:29:03 от WRAI »

 

Страница сгенерирована за 0.161 секунд. Запросов: 22.