Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: очень долго не стартует SSH-Server или не дает подключиться после ребута  (Прочитано 1526 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн pl84

  • Автор темы
  • Любитель
  • *
  • Сообщений: 68
    • Просмотр профиля
установил дополнительные 2 карты, одну лан, вторую usb-wifi, чтобы превратить комп в роутер и после этого ребутнул сервак, несколько минут (3-4 точно) не было возможности подключиться по ssh, откидывал, хотя пинги от сервака шли... потом раз и подключился, все летает... решил повторить этот фокус с перезагрузкой и снова несколько минут не могу цепануться....

до установки дополнительных сет. карт подключение было доступно мгновенно, как только появляются пинги. почему так?

Пользователь добавил сообщение 01 Февраль 2017, 20:33:56:
/usr/sbin/sshd -d -d -d
(Нажмите, чтобы показать/скрыть)


Пользователь добавил сообщение 01 Февраль 2017, 20:37:48:
подключение идет по IP, никаких DNS у меня пока нет.

Пользователь добавил сообщение 01 Февраль 2017, 21:16:56:
sudo nano /etc/network/interfaces
(Нажмите, чтобы показать/скрыть)

sudo lshw -C network
(Нажмите, чтобы показать/скрыть)

может я что с сетью не так настроил?

Пользователь добавил сообщение 01 Февраль 2017, 21:32:38:
Ошибка: Network error: Connection refused

ТС не появлялся на Форуме более полугода по состоянию на 14/07/2019 (последняя явка: 13/03/2018). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 14 Июль 2019, 04:07:26 от zg_nico »

Оффлайн Andersen

  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Интересно,а другие порты сразу (одновременно с пингом) открываются или позже,с SSH?

Оффлайн pl84

  • Автор темы
  • Любитель
  • *
  • Сообщений: 68
    • Просмотр профиля
Интересно,а другие порты сразу (одновременно с пингом) открываются или позже,с SSH?

вечером гляну, пробовал через telnet "ломануться" на 8120 порт SSH, он не отвечает после перезагрузки примерно 5 минут... и сразу как получается "зайти тернетом" на порт 8120, после этого получается подключиться putty к серверу.
на пинг сервак отвечает почти мгновенно, после загрузки, т.е. после того как биос пропищал, через пару секунд пинги идти начинают.

на сервере сейчас настроен OpenSSH (с диска, при установке галочку поставил, но по-моему были обновления на этот пакет), miniDLNA, Plex Server (все хочу удалить, как-то не всегда стабильно работает), transmission, Samba.

косяк появился этот после того как: установил дополнительно 2 сетевые карты,
складывается ощущение, что сервис ssh меня "футболит" пытаясь что-то найти и сопоставить, а до этого не принимает подключения.

Пользователь добавил сообщение 02 Февраль 2017, 23:54:20:
Интересно,а другие порты сразу (одновременно с пингом) открываются или позже,с SSH?

самба и вебка трансмишена тоже не доступна, только спустя несколько минут все становится доступно... видать проблема в сети...
НО на пинг комп отвечает... ума не приложу, что не так... и куда копать...

Пользователь добавил сообщение 03 Февраль 2017, 08:25:24:
примерно 4-5 минут требуется после перезагрузки, "чтобы подключиться".
« Последнее редактирование: 03 Февраль 2017, 08:25:24 от pl84 »

Оффлайн Andersen

  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
самба и вебка трансмишена тоже не доступна, только спустя несколько минут все становится доступно... видать проблема в сети...
НО на пинг комп отвечает.
Вот и я про то же,80ый порт становится доступным через пару минут,а пинг сразу проходит.Iptables не трогали случаем?Тоже хочу до истины докопаться.Попробую правила файрвола покрутить,отпишусь что получилось.

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
/etc/ssh/sshd_config
добав
UseDNS no
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн pl84

  • Автор темы
  • Любитель
  • *
  • Сообщений: 68
    • Просмотр профиля
/etc/ssh/sshd_config
добав
UseDNS no

пробовал - толка нет,
+ я не использую ДНС, подключение по ip идет.

Пользователь добавил сообщение 03 Февраль 2017, 10:38:50:
самба и вебка трансмишена тоже не доступна, только спустя несколько минут все становится доступно... видать проблема в сети...
НО на пинг комп отвечает.
Вот и я про то же,80ый порт становится доступным через пару минут,а пинг сразу проходит.Iptables не трогали случаем?Тоже хочу до истины докопаться.Попробую правила файрвола покрутить,отпишусь что получилось.

iptables не трогал, т.е. сам его не настраивал, хотя знаю, что он работает, т.е. при настройке fail2ban и проверке его работы - все отлично блокируется)))
« Последнее редактирование: 03 Февраль 2017, 10:38:50 от pl84 »

Оффлайн Andersen

  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Попробовал те же правила iptables на другом сервере,все в порядке т.е. дело не в этом,тем более вы правила не трогали.
victor00000, Не только SSH сервис не доступен,не доступны все сетевые сервисы(у меня это 80 и 25 порты + SSH),кроме пинга.

Оффлайн pl84

  • Автор темы
  • Любитель
  • *
  • Сообщений: 68
    • Просмотр профиля
Попробовал те же правила iptables на другом сервере,все в порядке т.е. дело не в этом,тем более вы правила не трогали.
victor00000, Не только SSH сервис не доступен,не доступны все сетевые сервисы(у меня это 80 и 25 порты + SSH),кроме пинга.
у Вас подобная проблема?

Оффлайн Andersen

  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Цитировать
у Вас подобная проблема?
Похоже 1 в 1

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
pl84, нужно сервис рестарт.
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн pl84

  • Автор темы
  • Любитель
  • *
  • Сообщений: 68
    • Просмотр профиля
pl84, нужно сервис рестарт.
я перезагружался и ничего не изменилось, конечно и рестарт сервиса пробовал: "sudo service ssh restart"

Punko

  • Гость
pl84, смотри лог загрузки, там будет проблема.
Может пытается поднять интерфейсы другие, в которых ошибка и из-за этого загрузка долгая.
У меня похожий эффект создавал вифи.

Оффлайн pl84

  • Автор темы
  • Любитель
  • *
  • Сообщений: 68
    • Просмотр профиля
pl84, смотри лог загрузки, там будет проблема.
Может пытается поднять интерфейсы другие, в которых ошибка и из-за этого загрузка долгая.
У меня похожий эффект создавал вифи.

лог приличный, ошибки в самом конце:
(Нажмите, чтобы показать/скрыть)

Пользователь добавил сообщение 03 Февраль 2017, 19:40:34:
У меня похожий эффект создавал вифи.

да, одна из новых карт сетевых - как раз USB Wi-Fi карта
ДОБАВЛЮ: отключил USB Wi-Fi (TP-Link WN7200ND), как было примерно 5 минут ожидания, так и осталось...

Пользователь добавил сообщение 04 Февраль 2017, 10:46:58:
в общем это решилось как-то само...

сейчас все прекрасно и сразу же доступно.
поставил вместо dhcp на 2-х новых интерфейсах static и прописал ip+mask,
до этого точно так же пробовал сделать до dhcp статику и нифига не выходило, почему так.. до сих пор не приложу ума.

выходит: что на включенных (наверное это важное замечание для ubuntu server 16.04.1) сет. интерфейсах, если стоит динамика, то он пытается получить айпи и до этого момента все заблокировано
хотя!!! один из интерфейсов ведь статика!!! и если iptables работает и блокирует трафик, на этот ip он уже может применить правила
+ когда ставишь новый сет. интерфейс он выключен и его приходится руками включать или же в конфиге прописывать руками и рестартить службу.
почему он сам в конфиг не добавляется?, приходится wlxf81a6708f336 руками набирать или копипастить - очень неудобно!!!.

сейчас все отлично работает и sudo nano /etc/network/interfaces выглядит так:
(Нажмите, чтобы показать/скрыть)

а sudo lshw -C network вот так:
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 04 Февраль 2017, 10:48:12 от pl84 »

Оффлайн pl84

  • Автор темы
  • Любитель
  • *
  • Сообщений: 68
    • Просмотр профиля
можете прокомментировать мои вопросы? интересно же.. почему так было и почему само все заработало нормально? может я допустил какие-то ошибки?

Оффлайн pl84

  • Автор темы
  • Любитель
  • *
  • Сообщений: 68
    • Просмотр профиля
походу никто не знает ответов, плохо... так и не смог сам разобраться почему так вышло и в следующий раз опять значит столкнусь с этими граблями и не только я один...

 

Страница сгенерирована за 0.12 секунд. Запросов: 22.