Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: flash-player для chromium  (Прочитано 1697 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 78
    • Просмотр профиля
flash-player для chromium
« : 06 Февраль 2017, 19:18:23 »
Всем здрасти, недавно установил lubunu 16.04 32бит поставил браузер chromium, вроде всё было норм, но вот недавно зашёл на сайт и он потребовал flesh-player, установил, но теперь этот сайт требует более новую версию, пытался обновить flash-player, выдаёт что уже установлена самая новая версия, ковырялся по этому сайту выполнил несколько советов даваемых на подобные вопросы, типа установить flash-installer и тому подобные, в итоге, flash не только не заработал, но и сломался ещё и в firefox, теперь я вообще в шоке. Очень прошу, если не знаете как эта проблема решается, пожалуйста, лучше не отвечайте, не надо находить ответы из подобных тем на сайте (ибо уже воспользовался) не надо отвечать что проблема в flesh-pleyer е и тому подобные, нужны ответы от реально понимающих людей, ибо я уже потратил на это весь вчерашний день

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13508
  • Xubuntu 18.04
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #1 : 06 Февраль 2017, 19:27:23 »
А как вы флеш устанавливали? И каким советам вы следовали? Если не можете ответить, то лучше удалите тему и не замусоривайте форум ;-)

А то "я что-то как-то установил, потом следовал каким-то советам, от этого все сломалось...". Как такая проблема решается никто не знает. Поэтому никто по вашей настоятельной просьбе отвечать и не будет.

Флеш ставится стандартно

sudo apt install flashplugin-installer
Это устанавливает самый последний существующий флеш.
« Последнее редактирование: 06 Февраль 2017, 19:33:07 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 78
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #2 : 06 Февраль 2017, 19:59:30 »
sudo apt install flashplugin-installer
Самое первое что я сделал, я даже комп перезагрузил - именно после этого тот сайт перестал требовать установить flash-player, но стал требовать более новую версию.
Возможно, у вас система 64 бита, потому подобных проблем у вас не возникает...
Я там столько всего переделал, что там сам чёрт ногу сломит, это будет такая портянка, что вы сами же запаритесь её читать.
И вообще, я же просил не давать ответов типа я умный, а ты тупой, я просил дать ответ людей, которые сталкивались с подобной проблемой и как они её решали, а там я уже сам разберусь

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13508
  • Xubuntu 18.04
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #3 : 06 Февраль 2017, 20:02:41 »
С вашими запросами тяжело будет. Не хотите - как хотите. Вам надо же, не мне. Ну разбирайтесь...
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 2155
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #4 : 06 Февраль 2017, 20:51:31 »
Тут, наверное нужен browser-plugin-freshplayer-pepperflash
а ещё есть
browser-plugin-freshplayer-libpdf
browser-plugin-freshplayer-nacl
node-fresh


Пётр.

Оффлайн Виктop

  • Участник
  • *
  • Сообщений: 185
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #5 : 06 Февраль 2017, 22:15:35 »
Я там столько всего переделал, что там сам чёрт ногу сломит, это будет такая портянка, что вы сами же запаритесь её читать.

Жесть, что то мне подсказывает гемора теперь там будет немеренно.

Всем здрасти, недавно установил lubunu 16.04 32бит поставил браузер chromium, вроде всё было норм, но вот недавно зашёл на сайт и он потребовал flesh-player, нужны ответы от реально понимающих людей, ибо я уже потратил на это весь

Не вопрос, с этим сталкивался, при схожих условия, чуть позже поведаю как я это решил, но для начала давай наведём порядок в системе, ведь х.з что ты там вообще делал и что устанавливал, особенно пугает вот это:

flash не только не заработал, но и сломался ещё и в firefox
это явно указывает на полный беспредел твоих действий.

Где то вычитал что firefox имеет свой флеш-плагин, потому предлагаю для начала снести firefox (если он действительно имеет свой плагин, то при повторной установке флеш в нем снова будет работать, но пока ставить не стоит, это будет немного позже).
Затем нужно пройтись по истории терминала, за период когда ты пытался установить флэш-плеер, удали всё что ты установил, команды те же, только вместо "install", вставляй "purge", вспомни все файлы куда и что ты вписывал и какие строки изменял (думаю, ты это делал), конечно, сложно будет вспомнить что ты сделал за весь день, в помощь история браузера, смотри те указки, которые ты выполнял.
Далее выполни команду
sudo apt-get autoremove
Честно сказать не люблю эту команду, т.к пару раз благодаря ей наживал себе проблем в виде неудовлетворённых зависимостей, но в твоём случае это необходимо, она почистит оставленные после firefox пакеты и конфиги, которые могут при повторной установке вернуть те проблемы которые имеются сейчас, кроме того х.з какие зависимости притянули те пакеты которые ты устанавливал выполняя те указания...

В браузере хромиум пройди по ссылке (именно хромиум)
https://get.adobe.com/ru/flashplayer/?no_redirect
где в выпадающем меню выбери linux 32-бит tar.gz,
затем распакуй этот архив командой:
tar -xvzf /путь_до_сохранённого_архива/название_скачанного_архива.tar.gz
архив будет распакован в домашний каталог, там будет файл libpepflashplayer.so, скопируй его в /opt/pepperflash, папки "pepperflash" по идее быть не должно, но после твоего шаманства она вполне может быть, если есть, вычисти из неё всё, если нет, создай её, затем вставь туда тот файл и укажи для него пользователя и группу "root" с правами: просмотр - "все", изменение - "только владелец", исполнение - "никто".
Далее перейди /usr/share/applications, найди там ярлык "chromium", кликни правой кнопкой мыши, в выпавшем меню выбери "свойства файла"->ярлык программы, в строке команда, удали существующую команду и вставь вместо неё строку "chromium-browser --ppapi-flash-path=/opt/pepperflash/libpepflashplayer.so --ppapi-flash-version=21.0.0.182 %U".
Затем перезагрузи компьютер, запусти хромиум, перейди по "chrome://plugins", там будет список существующих плагинов, по идее должно быть два, но х.з как в твоём случае, отключи все флэш плагины (если они будут) и подключи плагин версии 21.0.0.182, затем поставь галочку напротив "запускать всегда". Не помню, нужно ли перезагружать комп, или достаточно только хромиум, на всякий случай перезагрузи комп, если я ни чего не забыл, то всё должно работать. Потом можешь установить firefox.
« Последнее редактирование: 06 Февраль 2017, 22:27:37 от Виктop »

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 78
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #6 : 06 Февраль 2017, 23:21:56 »
Peter_I, Спасибо, кое что из этого было опробовано, кое что нет, но пробовать уже боюсь )))

Пользователь добавил сообщение 06 Февраль 2017, 23:26:15:
Виктop, Вот это инструкция!!! Выглядит ужасающе!!! Хотя... после того что я делал... Буду пробовать, по завершении отпишусь, но при любом раскладе всё равно спасибо.
« Последнее редактирование: 06 Февраль 2017, 23:26:15 от vvn »

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 2155
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #7 : 06 Февраль 2017, 23:39:51 »
vvn, 1-й именно для Chromium. У меня они все установлены, а сам Chromium - нет.
Пётр.

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 78
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #8 : 07 Февраль 2017, 02:48:09 »
vvn, 1-й именно для Chromium. У меня они все установлены, а сам Chromium - нет.
Искал тот пакет, не нашёл ничего похожего, может этот пакет доступен только для 64бит? Но это уже не важно...

Пользователь добавил сообщение 07 Февраль 2017, 03:14:20:
Виктop, Отчёт о проделанной работе:
Некоторые пункты я не стал выполнять, потому что при неудачных попытках я сразу же удалял всё что ставил и возвращал все изменённые мной файлы в исходное состояние. Удалил FireFox и начиная с пункта sudo apt-get autoremove, выполнил всё в точности как вы описали.

Итог: в Chromium появился flash-player, а в FireFox flash всё-таки ожил, я даже не знаю как выразить свою благодарность...

Заметил, такой момент, в Chromium flash 21 версии, а в FireFox 11.2, нужно ли обновлять flash в FireFox, или может в нём какие то свои индивидуальные обозначения версий??? Если нужно, то как это сделать?
« Последнее редактирование: 07 Февраль 2017, 03:15:11 от vvn »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 4091
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #9 : 07 Февраль 2017, 07:51:39 »
Цитировать
Заметил, такой момент, в Chromium flash 21 версии, а в FireFox 11.2, нужно ли обновлять flash в FireFox, или может в нём какие то свои индивидуальные обозначения версий???
Единственный пакет, который нужно установить: adobe-flashplugin. В нем плагины для firefox и хромоподобных браузеров. На текущий момент версия 24.0.0.194.
В нем же /etc/chromium-browser - похоже настройки для хромиума.
Во всех хромоподобных браузерах флеш-плеер подключается одинаково:
vivaldi --ppapi-flash-path=/usr/local/lib/flashplugin/libpepflashplayer.so  --ppapi-flash-version=24.0.0.194где
--ppapi-flash-path - путь к файлу флеш-плеера
--ppapi-flash-version - версия флеш-плеера, можно не указывать, разные броузеры относятся к этому по разному, но работают.

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 78
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #10 : 07 Февраль 2017, 13:01:20 »
Единственный пакет, который нужно установить: adobe-flashplugin. В нем плагины для firefox и хромоподобных браузеров. На текущий момент версия 24.0.0.194.
На 16.04 такого пакета нет, его заменили на flashplugin-installer, это первое что я сделал, но у меня он не пошёл.
На счёт версии, то странно, я ведь вчера скачивал с оф. сайта adobe, архив, у меня стоит какая то 21 версия, сегодня перешёл и увидел что текущая версия  24.0.0.194. Возможно, версия так указывается из-за того что я где то в ручную это прописал, скорее всего, Виктор устанавливал свой плагин уже давно и дал мне параметры своих настроек, но пока его вариант решения моей проблемы единственный рабочий и он меня устраивает.

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1795
  • ubuntu 20.04
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #11 : 07 Февраль 2017, 13:16:20 »
На 16.04 такого пакета нет, его заменили на flashplugin-installer
Неверно.
https://forum.ubuntu.ru/index.php?topic=284609.msg2242570#msg2242570

Оффлайн dmitriy1487

  • Активист
  • *
  • Сообщений: 368
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #12 : 07 Февраль 2017, 13:17:07 »


Вот он.

Оффлайн vvn

  • Автор темы
  • Любитель
  • *
  • Сообщений: 78
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #13 : 07 Февраль 2017, 13:24:09 »
Странно конечно, глянул это пакет, оказывается он у меня установлен, теперь мне непонятно, если он был установлен раньше, то почему же flash не работал???

Оффлайн Виктop

  • Участник
  • *
  • Сообщений: 185
    • Просмотр профиля
Re: flash-player для chromium
« Ответ #14 : 07 Февраль 2017, 16:31:29 »
На счёт версии, то странно, я ведь вчера скачивал с оф. сайта adobe, архив, у меня стоит какая то 21 версия, сегодня перешёл и увидел что текущая версия  24.0.0.194. Возможно, версия так указывается из-за того что я где то в ручную это прописал

Да, это прописано в ярлыке, в команде
"chromium-browser --ppapi-flash-path=/opt/pepperflash/libpepflashplayer.so --ppapi-flash-version=21.0.0.182 %U", замени "21.0.0.182" на "24.0.0.194".

FireFox 11.2, может в нём какие то свои индивидуальные обозначения версий???

Возможно, но я не знаю.

нужно ли обновлять flash в FireFox, если нужно, то как это сделать?

Если у тебя всё нормально работает, то лучше туда не лезь, а как это сделать не знаю и даже не хочу в это вникать
« Последнее редактирование: 07 Февраль 2017, 16:33:46 от Виктop »

 

Страница сгенерирована за 0.208 секунд. Запросов: 24.