Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Вопрос по Snap пакетам  (Прочитано 324 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kisly

  • Автор темы
  • Любитель
  • *
  • Сообщений: 87
    • Просмотр профиля
    • Записки
Вопрос по Snap пакетам
« : 28 Февраль 2017, 00:54:45 »
Правильно ли я понимаю, что масштабное использование snap пакетов планируется только для проприоритарного коммерческого софта ? Или я не правильно понимаю?

ТС не появлялся на Форуме более полугода по состоянию на 14/07/2019 (последняя явка: 12/07/2018). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 14 Июль 2019, 04:20:23 от zg_nico »

Оффлайн www777

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2735
    • Просмотр профиля
Re: Вопрос по Snap пакетам
« Ответ #1 : 28 Февраль 2017, 00:58:56 »
kisly, Ни кто ни кому не запрещает использовать snap.

Оффлайн kisly

  • Автор темы
  • Любитель
  • *
  • Сообщений: 87
    • Просмотр профиля
    • Записки
Re: Вопрос по Snap пакетам
« Ответ #2 : 28 Февраль 2017, 01:27:23 »
да меня наоборот смущает концепция "всё в одном". Я до недавнего времени и не знал об этом ничего, а тут Бац! и monodevelop 6.x уже только в flatpak. Ее то понятное дело можно собрать из git. Я прост к чему веду: все статьи на эту тему такие восторженные-восторженные, и нигде не упоминается что введение такой системы дает определенный overhead из-за отсутствия переиспользуемых пакетов.. или теперь жесткие диски дешевы и доступны, как туалетная бумага и не стоит об этом беспокоится ?..

Оффлайн www777

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2735
    • Просмотр профиля
Re: Вопрос по Snap пакетам
« Ответ #3 : 28 Февраль 2017, 01:34:48 »
kisly, Ну допустим, представь, что это может быть удобно. Есть некоторая программа в репозитории, она не последней версии. Новая версия требует новых библиотек которые отсутствуют в репозитории твоём, и возможно от них зависит другой установленный софт, поэтому ты не хочешь их обновлять. В качестве альтернативы тебе предоставляют snap, так что ты можешь выбирать ,использовать штатную но не самую последнюю версию, и взять snap.
Это лишь один из примеров, конечно можно собрать аналогично и в deb, но когда ты последний раз видел, что бы так кто то заморачивался? В перспективе таких пакетов наверное будет больше, но ни кто не говорит, о полной замене, на данный момент. А как именно будет через несколько лет, покажет история.
Ну и если не нравится, не пользуйся snap. :)
Рекомендую почитать блог vasilisc.com Там много полезных мыслей на тему snap.
« Последнее редактирование: 28 Февраль 2017, 01:38:09 от www777 »

 

Страница сгенерирована за 0.326 секунд. Запросов: 22.