Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Пропал звук  (Прочитано 2547 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн miarle

  • Автор темы
  • Участник
  • *
  • Сообщений: 205
  • Ubuntu 18.04 + i3 window manager
    • Просмотр профиля
Пропал звук
« : 05 Март 2017, 13:22:08 »
Нетбук ASUS EEE PC 1015CX
Ситуация такая, не работал микрофон вэбки, начал играться с ASLA и Pulseaudio.(По инструкциям с форумов). Уровень в моих знаниях не велик. Дошло до того что пропал звук, решил не мучатся и переустановить систему, но это не дало результата. Выяснил что если в alsamixer выбрать нужную звуковую карту(по умолчанию стоить PulseAudio) и поставить все ползунки вверх то звук заработал. Обрадовавшись я попользовался, но понял что после ребута он всё забыл.
alsactl store выводит такое сообщение
alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists
если после ребута написать alsactl restore звук заработает но некачественно и выведет такое сообщение
alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists
alsactl: load_state:1683: Cannot open /var/lib/alsa/asound.state for reading: File exists
Found hardware: "HDA-Intel" "Realtek ALC269VB" "HDA:10ec0269,10438437,00100100 HDA:80862880,80860101,00100000" "0x1043" "0x8437"
Hardware is initialized using a generic method
Излазил весь гугл и форум ничего не помогло прошу помощи.
CPU: 8 core AMD FX-8300 Eight-Core
RAM: Kingston DDR3-1600 8192MB PC3-12800
GPU: NVIDIA GP107 [GeForce GTX 1050]

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2081
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Re: Пропал звук
« Ответ #1 : 05 Март 2017, 14:04:48 »
Если после перезагрузки запустить alsamixer, то в каком положении там ползунки и какая карта выбрана по умолчанию?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13474
  • Xubuntu 18.04
    • Просмотр профиля
Re: Пропал звук
« Ответ #2 : 05 Март 2017, 14:26:40 »
artem.mikhaylov,
Вы переустановили с форматированием домашнего раздела? Если нет, то все ваши конфиги, которые вы наворотили остались.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн miarle

  • Автор темы
  • Участник
  • *
  • Сообщений: 205
  • Ubuntu 18.04 + i3 window manager
    • Просмотр профиля
Re: Пропал звук
« Ответ #3 : 05 Март 2017, 15:04:07 »
Если после перезагрузки запустить alsamixer, то в каком положении там ползунки и какая карта выбрана по умолчанию?

После перезагрузки как я понял выключен звук в одном из ползунков и там где должно писать звуковую карту пишет PulseAudio

Пользователь добавил сообщение 05 Март 2017, 15:06:57:
artem.mikhaylov,
Вы переустановили с форматированием домашнего раздела? Если нет, то все ваши конфиги, которые вы наворотили остались.

Домашний каталог не форматировал. Что можно сделать в данном случае?
« Последнее редактирование: 05 Март 2017, 15:06:57 от artem.mikhaylov »
CPU: 8 core AMD FX-8300 Eight-Core
RAM: Kingston DDR3-1600 8192MB PC3-12800
GPU: NVIDIA GP107 [GeForce GTX 1050]

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2081
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Re: Пропал звук
« Ответ #4 : 05 Март 2017, 16:02:14 »
Попробуй после перезагрузки, когда нет звука, выполнить в терминале эту команду:

amixer -q sset Master "50%" on
Если звук появится, тогда нужно будет добавить эту команду в автозагрузку и всё.

Оффлайн miarle

  • Автор темы
  • Участник
  • *
  • Сообщений: 205
  • Ubuntu 18.04 + i3 window manager
    • Просмотр профиля
Re: Пропал звук
« Ответ #5 : 05 Март 2017, 16:53:46 »
Попробуй после перезагрузки, когда нет звука, выполнить в терминале эту команду:

amixer -q sset Master "50%" on
Если звук появится, тогда нужно будет добавить эту команду в автозагрузку и всё.

Не помогло.
Скрин alsamixer после reboot
« Последнее редактирование: 05 Март 2017, 17:00:26 от artem.mikhaylov »
CPU: 8 core AMD FX-8300 Eight-Core
RAM: Kingston DDR3-1600 8192MB PC3-12800
GPU: NVIDIA GP107 [GeForce GTX 1050]

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2081
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Re: Пропал звук
« Ответ #6 : 05 Март 2017, 17:44:33 »
Понятно. Я пульсаудио не использую вообще, не вижу необходимости. У меня только альса и всё настраивается легко и работает стабильно.

Оффлайн miarle

  • Автор темы
  • Участник
  • *
  • Сообщений: 205
  • Ubuntu 18.04 + i3 window manager
    • Просмотр профиля
Re: Пропал звук
« Ответ #7 : 05 Март 2017, 18:08:58 »
Понятно. Я пульсаудио не использую вообще, не вижу необходимости. У меня только альса и всё настраивается легко и работает стабильно.


Где-то читал что алса нельзя больше использовать без пульсы. Я то и не знаю нужно pulseaudio или нет
CPU: 8 core AMD FX-8300 Eight-Core
RAM: Kingston DDR3-1600 8192MB PC3-12800
GPU: NVIDIA GP107 [GeForce GTX 1050]

Оффлайн sergey109

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Пропал звук
« Ответ #8 : 05 Март 2017, 18:32:27 »
Цитировать
nano ~/.asoundrc
удалить там всё и вставить
Цитировать
pcm.!default {
    type pulse
 }

 ctl.!default {
     type pulse
 }
Звук будет выводиться через пульс по-умолчанию. В насторойках плееров выставить пульс.
 PS
 Пульс удалить можно, он с драйвером связан опосредственно и на его работу не влияет никак.
Раньше были с ним проблемы, сейчас вполне себе конфета, дажн музыку можно слушать. Хотя я ,
скорее уже по привычке, вывожу на прямую через alsa, хотя в этом уже нет необходимости.
ЗЗЫ
Цитировать
alsactl store выводит такое сообщение
alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists
если после ребута написать alsactl restore звук заработает но некачественно и выведет такое сообщение
alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists
alsactl: load_state:1683: Cannot open /var/lib/alsa/asound.state for reading: File exists
Found hardware: "HDA-Intel" "Realtek ALC269VB" "HDA:10ec0269,10438437,00100100 HDA:80862880,80860101,00100000" "0x1043" "0x8437"
Hardware is initialized using a generic method
Если набрать alsactl --help, то можно дочитаться до такого:
Цитировать
alsactl -f ~/.asoundconf store
- сохранит в файл текущую конфгурацию микшера
В автозагрузку:
Цитировать
alsactl -f ~/.asoundconf restore
-восстановит эту конфигурацию

« Последнее редактирование: 05 Март 2017, 18:46:39 от sergey109 »

Оффлайн miarle

  • Автор темы
  • Участник
  • *
  • Сообщений: 205
  • Ubuntu 18.04 + i3 window manager
    • Просмотр профиля
Re: Пропал звук
« Ответ #9 : 05 Март 2017, 18:56:55 »
Цитировать
nano ~/.asoundrc
удалить там всё и вставить
Цитировать
pcm.!default {
    type pulse
 }

 ctl.!default {
     type pulse
 }
Звук будет выводиться через пульс по-умолчанию. В насторойках плееров выставить пульс.
 PS
 Пульс удалить можно, он с драйвером связан опосредственно и на его работу не влияет никак.
Раньше были с ним проблемы, сейчас вполне себе конфета, дажн музыку можно слушать. Хотя я ,
скорее уже по привычке, вывожу на прямую через alsa, хотя в этом уже нет необходимости.
ЗЗЫ
Цитировать
alsactl store выводит такое сообщение
alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists
если после ребута написать alsactl restore звук заработает но некачественно и выведет такое сообщение
alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists
alsactl: load_state:1683: Cannot open /var/lib/alsa/asound.state for reading: File exists
Found hardware: "HDA-Intel" "Realtek ALC269VB" "HDA:10ec0269,10438437,00100100 HDA:80862880,80860101,00100000" "0x1043" "0x8437"
Hardware is initialized using a generic method
Если набрать alsactl --help, то можно дочитаться до такого:
Цитировать
alsactl -f ~/.asoundconf store
- сохранит в файл текущую конфгурацию микшера
В автозагрузку:
Цитировать
alsactl -f ~/.asoundconf restore
-восстановит эту конфигурацию

Если вы говорите, что без pulseaudio можно, то не лучше сразу без него настроить? Да и через пульсу не будет работать микрофон с вэбки и я вообще вернусь в начало истории
« Последнее редактирование: 05 Март 2017, 18:59:24 от artem.mikhaylov »
CPU: 8 core AMD FX-8300 Eight-Core
RAM: Kingston DDR3-1600 8192MB PC3-12800
GPU: NVIDIA GP107 [GeForce GTX 1050]

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2081
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Re: Пропал звук
« Ответ #10 : 05 Март 2017, 19:00:12 »
Где-то читал что алса нельзя больше использовать без пульсы.

Глупости какие то ты читаешь

Пользователь добавил сообщение 05 Март 2017, 19:01:43:
Да и через пульсу не будет работать микрофон с вэбки и я вообще вернусь в начало истории

Снова глупости... Где ты этого набрался?
Даже скайп будет работать, который не должен работать без пульсы.
« Последнее редактирование: 05 Март 2017, 19:01:43 от ecc83 »

Оффлайн miarle

  • Автор темы
  • Участник
  • *
  • Сообщений: 205
  • Ubuntu 18.04 + i3 window manager
    • Просмотр профиля
Re: Пропал звук
« Ответ #11 : 05 Март 2017, 19:09:45 »
Где-то читал что алса нельзя больше использовать без пульсы.

Глупости какие то ты читаешь

Пользователь добавил сообщение 05 Март 2017, 19:01:43:
Да и через пульсу не будет работать микрофон с вэбки и я вообще вернусь в начало истории

Снова глупости... Где ты этого набрался?
Даже скайп будет работать, который не должен работать без пульсы.


По микрофону с вебки, он у меня не работал на лUbuntu, подумал что иза драйверов.
Мне бы настроить чтоб вот такой конфиг alsamixer стартовал при запуске системы

CPU: 8 core AMD FX-8300 Eight-Core
RAM: Kingston DDR3-1600 8192MB PC3-12800
GPU: NVIDIA GP107 [GeForce GTX 1050]

Оффлайн sergey109

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
Re: Пропал звук
« Ответ #12 : 05 Март 2017, 20:10:43 »
 я тебе написал как это сделать ...
Настрой и сохрани такой конфиг, как было уже предложено

Оффлайн miarle

  • Автор темы
  • Участник
  • *
  • Сообщений: 205
  • Ubuntu 18.04 + i3 window manager
    • Просмотр профиля
Re: Пропал звук
« Ответ #13 : 05 Март 2017, 20:36:51 »
я тебе написал как это сделать ...
Настрой и сохрани такой конфиг, как было уже предложено

Ваша подсказка решает проблему, но теперь трудность с установкой команды в автозапуск.
CPU: 8 core AMD FX-8300 Eight-Core
RAM: Kingston DDR3-1600 8192MB PC3-12800
GPU: NVIDIA GP107 [GeForce GTX 1050]

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2081
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Re: Пропал звук
« Ответ #14 : 05 Март 2017, 22:20:20 »
теперь трудность с установкой команды в автозапуск.

А какие трудности? Не устанавливается или не запускается?

 

Страница сгенерирована за 0.175 секунд. Запросов: 23.