Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Устранить конфликты зависимостей  (Прочитано 5258 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн hound672

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Добрый день, ubuntu 12.04.3.
По глупости как-то добавил левых репозиториев для установки некоторых пакетов, теперь система ругается следующим образом:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 console-setup : Depends: console-setup-linux but it is not installable
                 Depends: keyboard-configuration (= 1.108ubuntu15.3) but 1.70ubuntu5 is installed
                 Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 dbus : Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 gvfs:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 gvfs-libs:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.2.1~) but 0.122ubuntu8.8 is installed
 klibc-utils : Depends: libklibc (= 1.5.25-1ubuntu2) but 2.0.4-8ubuntu1.16.04.3 is installed
 libdbus-glib-1-2:i386 : Depends: libdbus-1-3:i386 (>= 1.2.16) but it is not installed
 libgconf-2-4:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 libgnutls26:i386 : Depends: libgcrypt11:i386 (>= 1.5.1) but it is not installed
 libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.4.0) but it is not installed
 libpulse0:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 libqtdbus4:i386 : Depends: libdbus-1-3:i386 (>= 1.3.1) but it is not installed
 librtmp0:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
 libsane:i386 : Depends: libavahi-client3:i386 (>= 0.6.16) but it is not installed
 libxslt1.1:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
E: Unmet dependencies. Try using -f.

С ключом -f выдает:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 console-setup : Depends: console-setup-linux but it is not installable
                 Depends: keyboard-configuration (= 1.108ubuntu15.3) but 1.70ubuntu5 is installed
                 Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 dbus : Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 gvfs:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 gvfs-libs:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.2.1~) but 0.122ubuntu8.8 is installed
 klibc-utils : Depends: libklibc (= 1.5.25-1ubuntu2) but 2.0.4-8ubuntu1.16.04.3 is installed
 libdbus-glib-1-2:i386 : Depends: libdbus-1-3:i386 (>= 1.2.16) but it is not installed
 libgconf-2-4:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 libgnutls26:i386 : Depends: libgcrypt11:i386 (>= 1.5.1) but it is not installed
 libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.4.0) but it is not installed
 libpulse0:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 libqtdbus4:i386 : Depends: libdbus-1-3:i386 (>= 1.3.1) but it is not installed
 librtmp0:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
 libsane:i386 : Depends: libavahi-client3:i386 (>= 0.6.16) but it is not installed
 libxslt1.1:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

При попытке установить пакет, например, but 4.0-0ubuntu20.3(который есть в списке):
The following partially installed packages will be configured:
  console-setup{b} dbus{b}
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 217 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
The following packages have unmet dependencies:
 libdbus-glib-1-2:i386 : Depends: libdbus-1-3:i386 (>= 1.2.16) but it is not going to be installed.
 dbus : Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed.
 console-setup : Depends: console-setup-linux which is a virtual package.
                 Depends: keyboard-configuration (= 1.108ubuntu15.3) but 1.70ubuntu5 is installed.
                 Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed.
 klibc-utils : Depends: libklibc (= 1.5.25-1ubuntu2) but 2.0.4-8ubuntu1.16.04.3 is installed.
 librtmp0:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not going to be installed.
 initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.2.1~) but 0.122ubuntu8.8 is installed.
 gvfs:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not going to be installed.
 libsane:i386 : Depends: libavahi-client3:i386 (>= 0.6.16) but it is not going to be installed.
 libqtdbus4:i386 : Depends: libdbus-1-3:i386 (>= 1.3.1) but it is not going to be installed.
 libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.4.0) but it is not going to be installed.
 libgnutls26:i386 : Depends: libgcrypt11:i386 (>= 1.5.1) but it is not going to be installed.
 libgconf-2-4:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not going to be installed.
 libxslt1.1:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not going to be installed.
 gvfs-libs:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not going to be installed.
 libpulse0:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not going to be installed.
open: 6740; closed: 7188; defer: 139; conflict: 170                                                                                                                                            .No solution found within the allotted time.  Try harder? [Y/n]

Как можно исправить данную проблему?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27415
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #1 : 10 Апрель 2017, 17:34:59 »
1. Удалить левые репы.
2. Заменить базовые репы на trusty.
3. Обновить наконец систему.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн hound672

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #2 : 10 Апрель 2017, 17:36:32 »
Репы левые удалил:
cat /etc/apt/sources.list

#######################################################################################
# Hetzner APT-Mirror

deb http://mirror.hetzner.de/ubuntu/packages  precise           main restricted universe multiverse
deb http://mirror.hetzner.de/ubuntu/packages  precise-backports main restricted universe multiverse
deb http://mirror.hetzner.de/ubuntu/packages  precise-updates   main restricted universe multiverse
deb http://mirror.hetzner.de/ubuntu/security  precise-security  main restricted universe multiverse

apg-get update
сделал, но эффекта никакого. Можно без обновления системы решить это?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27415
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #3 : 10 Апрель 2017, 18:02:03 »
Ещё раз для непонятливых.
1. Заменяете "precise" на "trusty"
2. apt-get update
3. apt-get dist-upgrade
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн hound672

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #4 : 10 Апрель 2017, 18:04:44 »
Сделал:
cat /etc/apt/sources.list

#######################################################################################
# Hetzner APT-Mirror

deb http://mirror.hetzner.de/ubuntu/packages  trusty           main restricted universe multiverse
deb http://mirror.hetzner.de/ubuntu/packages  trusty-backports main restricted universe multiverse
deb http://mirror.hetzner.de/ubuntu/packages  trusty-updates   main restricted universe multiverse
deb http://mirror.hetzner.de/ubuntu/security  trusty-security  main restricted universe multiverse

Затем:
apt-get update
apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 console-setup : Depends: console-setup-linux but it is not installable
                 Depends: keyboard-configuration (= 1.108ubuntu15.3) but 1.70ubuntu5 is installed
                 Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 dbus : Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 gvfs:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 gvfs-libs:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.2.1~) but 0.122ubuntu8.8 is installed
 klibc-utils : Depends: libklibc (= 1.5.25-1ubuntu2) but 2.0.4-8ubuntu1.16.04.3 is installed
 libdbus-glib-1-2:i386 : Depends: libdbus-1-3:i386 (>= 1.2.16) but it is not installed
 libgconf-2-4:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 libgnutls26:i386 : Depends: libgcrypt11:i386 (>= 1.5.1) but it is not installed
 libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.4.0) but it is not installed
 libpulse0:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 libqtdbus4:i386 : Depends: libdbus-1-3:i386 (>= 1.3.1) but it is not installed
 librtmp0:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
 libsane:i386 : Depends: libavahi-client3:i386 (>= 0.6.16) but it is not installed
 libxslt1.1:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
E: Unmet dependencies. Try using -f.

Затем с флагом:
apt-get -f dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 console-setup : Depends: console-setup-linux but it is not installable
                 Depends: keyboard-configuration (= 1.108ubuntu15.3) but 1.70ubuntu5 is installed
                 Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 dbus : Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 gvfs:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 gvfs-libs:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.2.1~) but 0.122ubuntu8.8 is installed
 klibc-utils : Depends: libklibc (= 1.5.25-1ubuntu2) but 2.0.4-8ubuntu1.16.04.3 is installed
 libdbus-glib-1-2:i386 : Depends: libdbus-1-3:i386 (>= 1.2.16) but it is not installed
 libgconf-2-4:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 libgnutls26:i386 : Depends: libgcrypt11:i386 (>= 1.5.1) but it is not installed
 libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.4.0) but it is not installed
 libpulse0:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 libqtdbus4:i386 : Depends: libdbus-1-3:i386 (>= 1.3.1) but it is not installed
 librtmp0:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
 libsane:i386 : Depends: libavahi-client3:i386 (>= 0.6.16) but it is not installed
 libxslt1.1:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
« Последнее редактирование: 10 Апрель 2017, 18:41:57 от hound672 »

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #5 : 10 Апрель 2017, 19:51:17 »
hound672, http://mirror.hetzner.de/ubuntu/ а попробуйте туда просто заглянуть из любопытства.  :) Может адресок сменить?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27415
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #6 : 10 Апрель 2017, 20:34:09 »
(Нажмите, чтобы показать/скрыть)
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн hound672

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #7 : 11 Апрель 2017, 09:06:56 »
apt-get update


apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 console-setup : Depends: console-setup-linux but it is not installable
                 Depends: keyboard-configuration (= 1.108ubuntu15.3) but 1.70ubuntu5 is installed
                 Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 dbus : Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 gvfs:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 gvfs-libs:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.2.1~) but 0.122ubuntu8.8 is installed
 klibc-utils : Depends: libklibc (= 1.5.25-1ubuntu2) but 2.0.4-8ubuntu1.16.04.3 is installed
 libdbus-glib-1-2:i386 : Depends: libdbus-1-3:i386 (>= 1.2.16) but it is not installed
 libgconf-2-4:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 libgnutls26:i386 : Depends: libgcrypt11:i386 (>= 1.5.1) but it is not installed
 libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.4.0) but it is not installed
 libpulse0:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 libqtdbus4:i386 : Depends: libdbus-1-3:i386 (>= 1.3.1) but it is not installed
 librtmp0:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
 libsane:i386 : Depends: libavahi-client3:i386 (>= 0.6.16) but it is not installed
 libxslt1.1:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
E: Unmet dependencies. Try using -f.

apt-get -f dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 console-setup : Depends: console-setup-linux but it is not installable
                 Depends: keyboard-configuration (= 1.108ubuntu15.3) but 1.70ubuntu5 is installed
                 Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 dbus : Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 gvfs:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 gvfs-libs:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.2.1~) but 0.122ubuntu8.8 is installed
 klibc-utils : Depends: libklibc (= 1.5.25-1ubuntu2) but 2.0.4-8ubuntu1.16.04.3 is installed
 libdbus-glib-1-2:i386 : Depends: libdbus-1-3:i386 (>= 1.2.16) but it is not installed
 libgconf-2-4:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 libgnutls26:i386 : Depends: libgcrypt11:i386 (>= 1.5.1) but it is not installed
 libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.4.0) but it is not installed
 libpulse0:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 libqtdbus4:i386 : Depends: libdbus-1-3:i386 (>= 1.3.1) but it is not installed
 librtmp0:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
 libsane:i386 : Depends: libavahi-client3:i386 (>= 0.6.16) but it is not installed
 libxslt1.1:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #8 : 11 Апрель 2017, 09:36:02 »
hound672, cat /etc/apt/sources.list ?

Оффлайн hound672

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #9 : 11 Апрель 2017, 09:37:19 »
cat /etc/apt/sources.list
#

# deb cdrom:[Ubuntu-Server 14.04.5 LTS _Trusty Tahr_ - Release amd64 (20160803)]/ trusty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://ru.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://ru.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://ru.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ trusty universe
deb http://ru.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://ru.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://ru.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu trusty partner
# deb-src http://archive.canonical.com/ubuntu trusty partner

## Uncomment the following two lines to add software from Ubuntu's
## 'extras' repository.
## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
# deb http://extras.ubuntu.com/ubuntu trusty main
# deb-src http://extras.ubuntu.com/ubuntu trusty main

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #10 : 11 Апрель 2017, 09:43:16 »
Здесь вроде нормально, а здесь?
ls /etc/apt/sources.list.d

Оффлайн hound672

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #11 : 11 Апрель 2017, 09:46:35 »
ls /etc/apt/sources.list.d
mongodb.list  mongodb-org-3.2.list  nodesource.list

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #12 : 11 Апрель 2017, 09:51:56 »
Цитировать
apt-get -f dist-upgrade
Только заметил, ты где это откопал? Выполни сначала это - sudo apt install -f

Оффлайн hound672

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #13 : 11 Апрель 2017, 09:56:59 »
Выполнил, вот ответ:
apt install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 console-setup : Depends: console-setup-linux but it is not installable
                 Depends: keyboard-configuration (= 1.108ubuntu15.3) but 1.70ubuntu5 is installed
                 Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 dbus : Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.0-0ubuntu20.3 is installed
 gvfs:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 gvfs-libs:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 initramfs-tools : Depends: initramfs-tools-bin (< 0.99ubuntu13.2.1~) but 0.122ubuntu8.8 is installed
 klibc-utils : Depends: libklibc (= 1.5.25-1ubuntu2) but 2.0.4-8ubuntu1.16.04.3 is installed
 libdbus-glib-1-2:i386 : Depends: libdbus-1-3:i386 (>= 1.2.16) but it is not installed
 libgconf-2-4:i386 : Depends: libdbus-1-3:i386 (>= 1.0.2) but it is not installed
 libgnutls26:i386 : Depends: libgcrypt11:i386 (>= 1.5.1) but it is not installed
 libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.4.0) but it is not installed
 libpulse0:i386 : Depends: libdbus-1-3:i386 (>= 1.1.1) but it is not installed
 libqtdbus4:i386 : Depends: libdbus-1-3:i386 (>= 1.3.1) but it is not installed
 librtmp0:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
 libsane:i386 : Depends: libavahi-client3:i386 (>= 0.6.16) but it is not installed
 libxslt1.1:i386 : Depends: libgcrypt11:i386 (>= 1.4.5) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: Устранить конфликты зависимостей
« Ответ #14 : 11 Апрель 2017, 10:13:23 »
Мдя, уже не знаю. Предложу ещё переименовать папку sources.list.d и создать там же пустую с этим именем (а то там какие то репы непонятные). И весь набор команд для чистки.
sudo apt-get update
sudo apt-get upgrade
sudo apt-get autoremove
sudo apt-get clean
sudo apt-get -f install

 

Страница сгенерирована за 0.188 секунд. Запросов: 25.