Форум русскоязычного сообщества Ubuntu


Автор Тема: Проблема с phpmyadmin  (Прочитано 4899 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн itshy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Проблема с phpmyadmin
« : 18 Апрель 2017, 00:19:41 »
Всё началось с установки lamp.
Как дошло до phpmyadmin, то началось сие чудо:

Fatal error: Uncaught Error: Call to undefined function __() in
/usr/share/phpmyadmin/libraries/core.lib.php:245 Stack trace: #0
/usr/share/phpmyadmin/libraries/core.lib.php(321): PMA_fatalError('The
[a@./url.ph...') #1 /usr/share/phpmyadmin/libraries/common.inc.php(298):
PMA_warnMissingExtension('json', true) #2 /usr/share/phpmyadmin/index.php(12):
require_once('/usr/share/phpm...') #3 {main} thrown in
/usr/share/phpmyadmin/libraries/core.lib.php on line 245

Оно появляется при загрузке localhost/phpmyadmin
« Последнее редактирование: 18 Апрель 2017, 00:23:02 от itshy »

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 588
    • Просмотр профиля
Re: Проблема с phpmyadmin
« Ответ #1 : 18 Апрель 2017, 01:57:40 »
sudo apt-get install php-mbstringНе стесняйтесь гуглить, пожалуйста.

Оффлайн itshy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Проблема с phpmyadmin
« Ответ #2 : 18 Апрель 2017, 08:27:42 »
Я гуглил, установил данный пакет.
Перезагрузил apache.
Ничего не изменилось. Снес phpmyadmin вместе с этим пакетом, позже поставил пакет, потом phpmyadmin, все та же проблема...

Я подозреваю, что проблема кроется и в php-пакетах...

Пользователь добавил сообщение 18 Апрель 2017, 09:24:59:
Дополнительно, должно помочь


https://itmages.ru/image/view/5659627/73177800
« Последнее редактирование: 18 Апрель 2017, 09:26:04 от itshy »

Оффлайн scsiman

  • Активист
  • *
  • Сообщений: 344
    • Просмотр профиля
Re: Проблема с phpmyadmin
« Ответ #3 : 18 Апрель 2017, 10:03:58 »
itshy, как ставили lamp? По какой инструкции?
Dell Studio XPS 16, Ubuntu 16.04 LTS (Home).
HP nx6110, Ubuntu 8.04 LTS => 10.04 LTS (Home).

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 588
    • Просмотр профиля
Re: Проблема с phpmyadmin
« Ответ #4 : 18 Апрель 2017, 13:23:58 »
itshy, а подключать расширение кто за вас будет? В файле php.ini добавьте строку:
extension=mbstring.so

Оффлайн itshy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Проблема с phpmyadmin
« Ответ #5 : 18 Апрель 2017, 15:59:10 »
archuser, спасибо.
Недавно начал работать с консолью, а на счет подключения даже не подозревал. Можешь посоветовать литературу по этой теме?
scsiman, всякие разные способы, подскажи пожалуйста оптимальный вариант на свое усмотрение.
« Последнее редактирование: 18 Апрель 2017, 17:33:55 от itshy »

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 588
    • Просмотр профиля
Re: Проблема с phpmyadmin
« Ответ #6 : 18 Апрель 2017, 19:10:49 »
Можешь посоветовать литературу по этой теме?
О какой теме идет речь?

Оффлайн itshy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Проблема с phpmyadmin
« Ответ #7 : 18 Апрель 2017, 21:04:25 »
archuser, о подключениях и том, чего это касается. Ведь устанавливая пакет, я не знаю нужно что-либо там подключать.
На своё усмотрение ещё... Я рад любой информации. Прошу, т.к. читая что-либо, не всегда понятно нужно ли оно, как и где использовать.

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 588
    • Просмотр профиля
Re: Проблема с phpmyadmin
« Ответ #8 : 18 Апрель 2017, 22:28:38 »
itshy, любые не входящие в состав ядра php (но не в состав пакета!) расширения нужно явно подключать. И далеко не для всех расширений в дистрибутиве собирается пакет. В документации на официальной странице проекта php.net подробно описывается установка расширения, приводятся примеры его использования и дается API. Есть еще одна возможность распространения расширений и называется она PEAR. А по поводу литературы, то подойдет любая толстая и умная книга по php  :)

Оффлайн itshy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Проблема с phpmyadmin
« Ответ #9 : 18 Апрель 2017, 22:49:16 »
Всё работает! Можно тему считать решенной)

На случай, если кто-то набредет на эту тему, то вот мануал хороший нашел:

http://senokosov.info/lamp/install-lamp#remote_access

А тут отличные вопросы и в комментариях проблемы, которые решены:

http://www.cyberforum.ru/apache/thread1835459.html

Пользователь добавил сообщение 18 Апрель 2017, 23:19:38:
archuser, спасибо, занимательно)
PHP - Я иду!
« Последнее редактирование: 18 Апрель 2017, 23:19:56 от itshy »

 

Страница сгенерирована за 0.137 секунд. Запросов: 24.