Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Проблема с русификацией LibreOffice  (Прочитано 1840 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн timofey1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Проблема с русификацией LibreOffice
« : 19 Апрель 2017, 15:00:56 »
В школе есть компьютерный класс на Ubuntu 14.04.
Учитель пожаловался что LibreOffice Impress виснет на глухо при работе с правами обычного пользователя. При работе из пользователя Гость такого не наблюдалось.
Решил для начала обновить
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libreoffice
Офис как обычно установился английский прописываю команду для русификации
sudo apt-get install libreoffice-l10n-ruПолучаю вот такую ошибку
administrator@PC32-2:/home/user$ sudo apt-get install libreoffice-l10n-ru
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libreoffice-l10n-ru : Зависит: libreoffice-common (>= 1:5.3.2~rc2-0ubuntu1~trusty1) но он не будет установлен
                       Рекомендует: libreoffice-core (> 1:5.3.2~rc2) но он не будет установлен или
                                               language-support-translations-ru но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Пробывал различные команды из того что находил в гугле, ничего не помогло. Зашел в тупик.


Вот здесь вроде схожая проблема но я (по не опытности) не понимаю что он сделал в последнем сообщении.
https://forum.ubuntu.ru/index.php?topic=133620.0



Оффлайн DoctorRover

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 1831
  • Ubuntu 20.04 LTS, Ubuntu 20.10
    • Просмотр профиля
Re: Проблема с русификацией LibreOffice
« Ответ #1 : 19 Апрель 2017, 15:13:23 »
timofey1,
Пробовали следовать рекомендациям отсюда: help.ubuntu.ru -- Решение проблем при установке программ?
Выполняли такую команду?
sudo apt-get -f installЕсли нет, попробуйте для начала это.
You're never too old to Rock'n'Roll if you're too young to die.

Оффлайн timofey1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Проблема с русификацией LibreOffice
« Ответ #2 : 19 Апрель 2017, 15:33:52 »
2 DoctorRover
sudo apt-get -f installВыполнял. Не помогало.

Попробую команды по вашей ссылке.

Оффлайн DoctorRover

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 1831
  • Ubuntu 20.04 LTS, Ubuntu 20.10
    • Просмотр профиля
Re: Проблема с русификацией LibreOffice
« Ответ #3 : 19 Апрель 2017, 15:44:34 »
timofey1, скажите, я правильно понимаю, что у Вас подключен PPA и установлен LO версии 5.3.2?
You're never too old to Rock'n'Roll if you're too young to die.

Оффлайн timofey1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Проблема с русификацией LibreOffice
« Ответ #4 : 19 Апрель 2017, 16:39:23 »
DoctorRover, да я когда то давно вводил команду
Цитировать
ppa:libreoffice/ppa
чтоб установить LO. И периодически через командную строку обновлял. не добавляя заново ppa.
LO установлен версии 5.3.2.2

Попробовал с начала sudo apt-get -f install  а потом все команды по вашей ссылке, не помогло.

Оффлайн DoctorRover

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 1831
  • Ubuntu 20.04 LTS, Ubuntu 20.10
    • Просмотр профиля
Re: Проблема с русификацией LibreOffice
« Ответ #5 : 19 Апрель 2017, 18:14:58 »
timofey1, попробуйте так:
sudo apt-get install aptitude
sudo aptitude install libreoffice-l10n-ru
You're never too old to Rock'n'Roll if you're too young to die.

Оффлайн timofey1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Проблема с русификацией LibreOffice
« Ответ #6 : 20 Апрель 2017, 10:24:10 »
DoctorRover, Если я на первый вопрос соглашаюсь ничего не происходит. Если я на первый вопрос говорю нет, а на второй да то он откатывает LO на версию 4.3. Попробовал затем команду sudo aptitude install libreoffice установилась версия  5,3. Английская и при попытки русификации история повторяется.
Если на второй запрос отвечать "нет" то терминал выдает его же заново.


administrator@PC32-13:/home/user$ sudo aptitude install libreoffice-l10n-ru
Следующие НОВЫЕ пакеты будут установлены:       
  libreoffice-l10n-ru
0 пакетов обновлено, 1 установлено новых, 0 пакетов отмечено для удаления, и 9 пакетов не обновлено.
Необходимо получить 509 kБ архивов. После распаковки 3.283 kБ будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 libreoffice-common : Конфликтует: libreoffice-l10n-5.2 который является виртуальным пакетом.
Следующие действия разрешат зависимости:

     Оставить для следующих пакетов их текущие версии:
1)     libreoffice-l10n-ru [Не установлен]           



Принять данное решение? [Y/n/q/?] n
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                                                 
1)      libreoffice-gtk2                                                       
2)      libreoffice-style-tango                                                 

      Установить следующие пакеты:                                             
3)      libcdr-0.0-0 [0.0.15-1ubuntu1 (now, trusty)]                           
4)      libcmis-0.4-4 [0.4.1-3ubuntu4 (now, trusty)]                           
5)      libcolamd2.8.0 [1:4.2.1-3ubuntu1 (now, trusty)]                         
6)      libmspub-0.0-0 [0.0.6-1ubuntu2 (now, trusty)]                           
7)      liborcus-0.6-0 [0.5.1-7 (now, trusty)]                                 
8)      libreoffice-gtk [1:4.2.8-0ubuntu5 (trusty-security, trusty-updates)]   
9)      libreoffice-l10n-ru [1:4.2.7-0ubuntu1 (trusty-security)]               
10)     libreoffice-sdbc-firebird [1:5.3.2~rc2-0ubuntu1~trusty1 (trusty)]       
11)     libvisio-0.0-0 [0.0.31-1ubuntu2 (now, trusty)]                         
12)     lp-solve [5.5.0.13-7build1 (trusty)]                                   

      Установить более старую версию для следующих пакетов:                     
13)     libreoffice-base [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 1:4.2.8-
14)     libreoffice-base-core [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 1:4
15)     libreoffice-base-drivers [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) ->
16)     libreoffice-calc [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 1:4.2.8-
17)     libreoffice-common [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 1:4.2.
18)     libreoffice-core [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 1:4.2.8-
19)     libreoffice-draw [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 1:4.2.8-
20)     libreoffice-gnome [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 1:4.2.8
21)     libreoffice-impress [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 1:4.2
22)     libreoffice-java-common [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 1
23)     libreoffice-style-galaxy [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) ->
24)     libreoffice-style-human [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 1
25)     libreoffice-writer [1:5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 1:4.2.
26)     uno-libs3 [5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 4.2.8-0ubuntu5 (t
27)     ure [5.3.2~rc2-0ubuntu1~trusty1 (now, trusty) -> 4.2.8-0ubuntu5 (trusty-



Принять данное решение? [Y/n/q/?] n

Оффлайн RoDoN

  • Любитель
  • *
  • Сообщений: 96
    • Просмотр профиля
    • RoDoN X
Re: Проблема с русификацией LibreOffice
« Ответ #7 : 20 Апрель 2017, 10:34:16 »
Проблема только на 14.04, для себя решил так: удалил LireOffice, потом скачал с оф.сайта три архива с версией 5.3.2.2, распаковал все в один каталог и выполнил sudo dpkg -i *.deb, теперь свежий офис с русским интерфейсом.
Acer Aspire 5250 (AMD E-450, 4 Гб, Radeon HD 6320)
Samsung R20+ (T2390, 3 Гб, Radeon Xpress 1250)

Оффлайн DoctorRover

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 1831
  • Ubuntu 20.04 LTS, Ubuntu 20.10
    • Просмотр профиля
Re: Проблема с русификацией LibreOffice
« Ответ #8 : 20 Апрель 2017, 13:43:05 »
Вообще, aptitude лучше чем apt-get разрешает зависимости. Если и он не справился, значит действительно что-то серьёзно накосячено в репозитории для 14.04.
В этой ситуации я согласен с RoDoN, имеет смысл устанавливать версию с официального сайта.
You're never too old to Rock'n'Roll if you're too young to die.

Оффлайн timofey1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Проблема с русификацией LibreOffice
« Ответ #9 : 21 Апрель 2017, 10:32:04 »
DoctorRover, а у меня 15 компов одинаковых. Пока успел запорот только два) Есть смысл скопировать файл с репозиториями?

Оффлайн DoctorRover

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 1831
  • Ubuntu 20.04 LTS, Ubuntu 20.10
    • Просмотр профиля
Re: Проблема с русификацией LibreOffice
« Ответ #10 : 24 Апрель 2017, 18:52:06 »
timofey1,
Расскажите подробнее, пожалуйста, что Вам надо сделать.
Надо два компьютера, которые “запороты”, вернуть в исходное состояние со старой версией LO? Или на всех компьютерах таки провести обновление LO?
You're never too old to Rock'n'Roll if you're too young to die.

 

Страница сгенерирована за 0.361 секунд. Запросов: 25.