Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Версия пакета в системе выше, чем требуется, поэтому получаем проблемы  (Прочитано 863 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlekseyUbuntu

  • Автор темы
  • Активист
  • *
  • Сообщений: 323
    • Просмотр профиля
Kubuntu 16.10x64

С сайта AMD взял deb- файл с программой- профилировщиком "Сodeanalyst", который при инсталяции сообщает:
Распаковывается codeanalyst (3.4.18-100) …
dpkg: зависимости пакетов не позволяют настроить пакет codeanalyst:
codeanalyst зависит от binutils (<< 2.23), однако:
Версия binutils в системе — 2.27-8ubuntu2.

Поэтому получаем желание системы удалить только что поставленный пакет:
sudo apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Пакеты, которые будут УДАЛЕНЫ:
  codeanalyst

Как все- таки установить профилировщик?


Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2213
    • Просмотр профиля
С сайта AMD взял deb- файл с программой- профилировщиком "Сodeanalyst"
И какие у этого пакета указаны системные требования?

Оффлайн AlekseyUbuntu

  • Автор темы
  • Активист
  • *
  • Сообщений: 323
    • Просмотр профиля
И какие у этого пакета указаны системные требования?

Ubuntu 12.04 Desktop 64bit

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2213
    • Просмотр профиля
По-моему, ответ очевиден.

Оффлайн AlekseyUbuntu

  • Автор темы
  • Активист
  • *
  • Сообщений: 323
    • Просмотр профиля
По-моему, ответ очевиден.

Можно его озвучить?

Оффлайн Бонька

  • Активист
  • *
  • Сообщений: 346
  • life is purple
    • Просмотр профиля
Asus N56VJ, SSD, btrfs, Manjaro 16 (Ellada). x64, XFCE :)

Оффлайн AlekseyUbuntu

  • Автор темы
  • Активист
  • *
  • Сообщений: 323
    • Просмотр профиля
Я тоже умею сравнивать версии. Вопрос в том, что делать в этой ситуации?

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 2827
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04
    • Просмотр профиля
Вопрос в том, что делать в этой ситуации?

Разумным было-бы с самого начала показать откуда-что качалось, не заставляя других это разыскивать. Вот и у меня желания такого тоже не возникло, в смысле искать. А сейчас - может там и исходники какие завалялись, может их скомпилировать на 16.10 получится?
Я странен, а не странен кто ж? (С)

Оффлайн Бонька

  • Активист
  • *
  • Сообщений: 346
  • life is purple
    • Просмотр профиля
Вопрос в том, что делать в этой ситуации?
поставить требуюмую версию убунты, не? Либо, как выше писали, взять исходники с того же сайта, и самому попытаться собрать.
Asus N56VJ, SSD, btrfs, Manjaro 16 (Ellada). x64, XFCE :)

Оффлайн AlekseyUbuntu

  • Автор темы
  • Активист
  • *
  • Сообщений: 323
    • Просмотр профиля
Разумным было-бы с самого начала показать откуда-что качалось, не заставляя других это разыскивать. Вот и у меня желания такого тоже не возникло, в смысле искать. А сейчас - может там и исходники какие завалялись, может их скомпилировать на 16.10 получится?

Простите, что сразу не показал источник deb- файла: http://developer.amd.com/tools-and-sdks/archive/compute/amd-codeanalyst-performance-analyzer/amd-codeanalyst-performance-analyzer-for-linux/

Честно говоря, не очень понимаю как пересборка может решить проблемы зависимостей от старых пакетов. Может Ubuntu позволяет установить пакет ТОЛЬКО для ОДНОГО приложения (не заменяя основного)?
« Последнее редактирование: 29 Апрель 2017, 09:18:34 от AlekseyUbuntu »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13501
  • Xubuntu 18.04
    • Просмотр профиля
Честно говоря, не очень понимаю как пересборка может решить проблемы зависимостей от старых пакетов.
Зависимости при сборке руками прописываются. Только не факт что работать будет.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн AlekseyUbuntu

  • Автор темы
  • Активист
  • *
  • Сообщений: 323
    • Просмотр профиля
Зависимости при сборке руками прописываются. Только не факт что работать будет.

У вас хоть аватарка нормальная. У линуксоидов почему-то на аватарках черти и извращения. Какая-то странная корреляция.

ТС, как видно по состоянию на 30/01/2020 потерял интерес к созданной им теме (пометка Решено в теме отсутствует, тема оставлена не закрытой, сообщений в теме давно не было). Тема стародавняя (последнее сообщение в топике: 29/04/2017; последнее сообщение от ТС в топике: 29/04/2017). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 30 Январь 2020, 18:55:49 от zg_nico »

Оффлайн alsoijw

  • Старожил
  • *
  • Сообщений: 4073
  • Fedora 25 GNOME 3 amd64
    • Просмотр профиля
У вас хоть аватарка нормальная. У линуксоидов почему-то на аватарках черти и извращения. Какая-то странная корреляция.
(Нажмите, чтобы показать/скрыть)
А сейчас - может там и исходники какие завалялись, может их скомпилировать на 16.10 получится?
А ещё лучше пнуть производителя обновить пакеты, ибо поддержка 12.04 скоро закончится.
Мало видеть нам начало - надо видеть и конец. Если видишь ты создание - значит где-то есть ТВОРЕЦ
Многие жалуются: геометрия в жизни не пригодилась. Ямб от хорея им приходится отличать ежедневно?

 

Страница сгенерирована за 0.297 секунд. Запросов: 22.