Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Как нужно скачивать пакет и нужные зависимости  (Прочитано 1215 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alex-sky

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
На сайте http://packages.ubuntu.com/trusty/libpam-systemd - есть вот  пакет

libpam-systemd (204-5ubuntu20) ,  но данный пакет нужен для архитектуры armhf

Как настроить скачивание и установку ?
Зависимости пакета сами будут установлены и настроены, или пользователь должен это делать?

Команды

Код: Bash
  1. sudo apt-get install -f
  2. sudo apt-get update
  3. sudo apt-get dist-upgrade

Не помогают и не показывают ошибок, но когда выполнил

Код: Bash
  1. sudo apt-get install bluefish

пакет установился, но в конце установки были предупреждения

Цитировать
dpkg: зависимости пакетов не позволяют настроить пакет policykit-1:
policykit-1 зависит от libpam-systemd, однако: Пакет libpam-systemd:armhf пока не настроен
...

dpkg error processing package policykit-1 (--configure)
проблемы зависимостей оставляем не настроенными
...

Поэтому хочу поставить данный пакет , ну и соответственно понять как дальше могу самостоятельно искать нужные пакеты и скачивать вручную и производить установку



Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2084
  • Lubuntu 16.04 LTS
    • Просмотр профиля
alex-sky, какая у вас система?

Оффлайн alex-sky

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
Ubuntu 14.04 LTS, архитектура armhf

Сама система установлена в chroot на планшете с Андроид, через программу Linux Deploy

Вывод команды lsb_release -a

(Нажмите, чтобы показать/скрыть)

uname -r

Цитировать
3.4.0

uname -a

Цитировать
Linux localhost 3.4.0 #1 SMP PREEMPT Tue Jul 29 10:26:32 CST 2014 armv7l armv7l armv7l GNU/Linux


Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2084
  • Lubuntu 16.04 LTS
    • Просмотр профиля
alex-sky, есть подозрение, что у вас не порядок с репозиториями.

Смотреть файл /etc/apt/sources.list

Там должны быть прописаны стандартные репозитории для вашей версии системы, а у вас система почему то не находит нужные пакеты.

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля

Оффлайн alex-sky

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
Смотреть файл /etc/apt/sources.list

Там должны быть прописаны стандартные репозитории для вашей версии системы, а у вас система почему то не находит нужные пакеты.

Как его переписать, чтоб вручную не делать установки ?

Цитировать
http://packages.ubuntu.com/trusty/armhf/libpam-systemd/download
http://launchpadlibrarian.net/172806685/libpam-systemd_204-5ubuntu20_armhf.deb
Спасибо скачал...

Пробовал ставить, но появилась ошибка , что это за ошибка ???
 Как исправляется ?

Код: Bash
  1. sudo dpkg -i libpam-systemd_204-5ubuntu20_armhf.deb

(Нажмите, чтобы показать/скрыть)


Пользователь добавил сообщение 02 Май 2017, 14:03:38:
Вот что только есть в /etc/apt/sources.list

Цитировать
deb http://ports.ubuntu.com/ trusty main universe multiverse
deb-src http://ports.ubuntu.com/ trusty main universe multiverse

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
http://ports.ubuntu.com/  по этому адресу нет таких путей - trusty main universe multiverse.

Оффлайн alex-sky

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
http://ports.ubuntu.com/  по этому адресу нет таких путей - trusty main universe multiverse.

И как поступить

Я сформировал список

https://repogen.simplylinux.ch/generate.php

Затем выполнил команду

Код: Bash
  1. curl https://repogen.simplylinux.ch/txt/trusty/sources_1112689a3b5bb366eecaa54ba1f75043c07ee90d.txt | sudo tee /etc/apt/sources.list

Что делает данная команда ???

Затем скопировал новый список

Запустил команду
Код: Bash
  1. curl https://repogen.simplylinux.ch/txt/trusty/sources_1112689a3b5bb366eecaa54ba1f75043c07ee90d.txt | sudo tee /etc/apt/sources.list

Вначале было без ошибок, в конце появилось

(Нажмите, чтобы показать/скрыть)

А как это исправить ???

Затем выполнил команду





Пользователь добавил сообщение 02 Май 2017, 15:10:25:
Код: Bash
  1. sudo apt-get dist-upgrade

(Нажмите, чтобы показать/скрыть)

А как это исправить ?

Код: Bash
  1. sudo apt-get install -f

(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 02 Май 2017, 15:10:26 от alex-sky »

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
alex-sky, Я не знаю что ты делаешь, и по какой инструкции, но адрес то проверить можно? Например -
http://by.archive.ubuntu.com , там нет того что ты ищешь!!!

Оффлайн alex-sky

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
Я закомментировал строчки в sources.list, которые вызывали ошибку

Код: Bash
  1. sudo apt-get dist-upgrade
Цитировать
sudo apt-get dist-upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Пакет libpam-systemd нуждается в переустановке, но найти архив для него не удалось.

Как же это исправить ???

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Вставь libpam-systemd в поиск синаптика, что скажет?

Оффлайн alex-sky

  • Автор темы
  • Участник
  • *
  • Сообщений: 158
    • Просмотр профиля
 
Код: Bash
  1. sudo synaptic

Цитировать
sudo: synaptic: command not found

Затем скачал
Код: Bash
  1. wget http://ports.ubuntu.com/pool/main/s/systemd/libpam-systemd_204-5ubuntu20_armhf.deb

Попробовал поставить

Код: Bash
  1. sudo dpkg -i libpam-systemd_204-5ubuntu20_armhf.deb

Вот вывод с ошибками
(Нажмите, чтобы показать/скрыть)




Пользователь добавил сообщение 02 Май 2017, 17:28:48:
Затем выполнил

Код: Bash
  1. sudo touch /etc/init.d/systemd-logind
  2. sudo apt-get update && sudo  apt-get -f install
  3. wget http://ports.ubuntu.com/pool/main/s/systemd/libpam-systemd_204-5ubuntu20_armhf.deb
  4. sudo dpkg -i libpam-systemd_204-5ubuntu20_armhf.deb
  5. sudo apt-get dist-upgrade
  6.  

Ошибка про пакет libpam-systemd исчезла, а почему ???
« Последнее редактирование: 02 Май 2017, 17:28:48 от alex-sky »

 

Страница сгенерирована за 0.516 секунд. Запросов: 23.