Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Научите, пожалуйста, устанавливать программы.  (Прочитано 370 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Mohammad

  • Автор темы
  • Участник
  • *
  • Сообщений: 115
    • Просмотр профиля
Приветствую всех.
Научите, пожалуйста, устанавливать программы в Ubuntu. Пытался делать по аналогии с Windows, но ничего не вышло и непонятно что делать. У меня стоит Ubuntu 16.04 LTS. В Windows работаю с LibreOffice 5.3.3, а Ubuntu - с LibreOffice 5.1.6. Зайдя на сайт libreoffice.org, увидел, что есть версия 5.3 для Linux. Я его скачал, а заодно скачал ещё два файла для локализации: langpack и helppack. В Windows в таких случаях обычно запускается файл с расширением .exe и дальше всё идёт как надо. А тут все три файла заканчиваются на tar.gz, при попытке запуска открывается менеджер архивов и предлагает разархивировать файлы. Я разархивировал. Полученные файлы имеют расширение .deb и непонятно что с ними дальше делать.
Как мне установить, в данном случае, скачанный офис, а вообще - любую другую скачанную подобным образом или принесённую на диске/флешке программу?

ТС, как видно по состоянию на 30/01/2020 потерял интерес к созданной им теме (пометка Решено в теме отсутствует, тема оставлена не закрытой, сообщений в теме давно не было). На реплики форумчан реакции со стороны ТС нет. Тема стародавняя (последнее сообщение в топике: 17/05/2017; последнее сообщение от ТС в топике: 17/05/2017). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 30 Январь 2020, 19:07:41 от zg_nico »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13708
  • Xubuntu 18.04
    • Просмотр профиля
В Ubuntu программы по-другому устанавливаются. Не вполне понятно чем не устраивает штатный LibreOffice в Ubuntu.
Но если совсем сильно хочется именно 5.3, то лучше всего ставить из PPA. Там уже адаптировано под Ubuntu. Можно и из deb файлов, но для новичка будут некоторые проблемы.



Пользователь добавил сообщение 17 Май 2017, 16:15:41:
Из PPA ставится так

sudo add-apt-repository ppa:libreoffice/ppa
sudo apt update
sudo apt upgrade
« Последнее редактирование: 17 Май 2017, 16:15:41 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6780
    • Просмотр профиля
Mohammad, .deb и есть установщик - аналог.exe, точнее даже msi, так как .exe, в отличие от .deb, может быть и ещё и исполняемым файлом самой программы. По идее. двойной клик мышкой на .deb должен запустить его установку через "Менеджер приложений", где, возможно, ещё раз нужно будет нажать "Установить" и/или ввести пароль пользователя. Собственно, не обязательно скачивать какие-то программы, большинство часто используемых есть в самом "Центре приложений", хотя, да, не всегда там самая актуальная версия.
Но лучше ставить программы через репозитории самих программ (ppa на Launchpad). Тогда через них будут приходить обновления, совместно с обновлениями системы. А Языковая поддержка может быть установлена через Терминал, через менеджер пакетов Synaptic или сама подтянется через "Языки" в настройках Ubuntu.

Подробнее всё есть в нашей wiki:
https://help.ubuntu.ru/wiki/установка_и_удаление_программ
В частности:
https://help.ubuntu.ru/manual/программы_и_обновления
https://help.ubuntu.ru/manual/центр_приложений_ubuntu
https://help.ubuntu.ru/manual/репозитории
https://help.ubuntu.ru/manual/ppa

Пользователь добавил сообщение 17 Май 2017, 16:25:27:
sudo add-apt-repository ppa:libreoffice/ppa
sudo apt update
sudo apt upgrade
Если LO уже установлен, то последнюю строчку, согласно
https://forum.ubuntu.ru/index.php?topic=203117.0
нужно заменить на
sudo apt dist-upgrade
« Последнее редактирование: 17 Май 2017, 23:38:22 от maks05 »

 

Страница сгенерирована за 0.074 секунд. Запросов: 23.