Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Зависимости в Ubuntu  (Прочитано 1508 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Teemitze

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Зависимости в Ubuntu
« : 20 Май 2017, 13:40:18 »
Всем привет. Ребят ставил teamviewer с официального сайта, какая-то фигня с зависимостями происходит при вводе:

sudo apt install -f
Выдаёт следующее:

Чтение списков пакетов…
Построение дерева зависимостей…
Чтение информации о состоянии…
Следующий пакет устанавливался автоматически и больше не требуется:
  libasound2:i386
Для его удаления используйте «sudo apt autoremove».
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 8 пакетов.
Необходимо скачать 0 B/46,8 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
dpkg: ошибка при обработке пакета libgcc1:i386 (--configure):
 пакет libgcc1:i386 не готов к настройке
 настройка невозможна (текущее состояние: «half-installed»)
dpkg: зависимости пакетов не позволяют настроить пакет libc6:i386:
 libc6:i386 зависит от libgcc1, однако:
  Пакет libgcc1:i386 не установлен.

dpkg: ошибка при обработке пакета libc6:i386 (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет liblzma5:i386:
 liblzma5:i386 зависит от libc6 (>= 2.4), однако:
  Пакет libc6:i386 пока не настроен.

dpkg: ошибка при обработке пакета liblzma5:i386 (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет libpcre3:i386:
 libpcre3:i386 зависит от libc6 (>= 2.4), однако:
  Пакет libc6:i386 пока не настроен.

dpkg: ошибка при обработке пакета libpcre3:i386 (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет libgpg-error0:i386:
 libgpg-error0:i386 зависит от libc6 (>= 2.15), однако:
  Пакет libc6:i386 пока не настроен.

dpkg: ошибка при обработке пакета libgpg-error0:i386 (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет libgcrypt20:i386:
 libgcrypt20:i386 зависит от libc6 (>= 2.15), однако:
  Пакет libc6:i386 пока не настроен.
 libgcrypt20:i386 зависит от libgpg-error0 (>= 1.14), однако:
  Пакет libgpg-error0:i386 пока не настроен.

dpkg: ошибка при обработке пакета libgcrypt20:i386 (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет libselinux1:i386:
 libselinux1:i386 зависит от libc6 (>= 2.8), однако:
  Пакет libc6:i386 пока не настроен.
 libselinux1:i386 зависит от libpcre3, однако:
  Пакет libpcre3:i386 пока не настроен.

dpkg: ошибка при обработке пакета libselinux1:i386 (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет libasound2:i386:
 libasound2:i386 зависит от libc6 (>= 2.16), однако:
  Пакет libc6:i386 пока не настроен.

dpkg: ошибка при обработке пакета libasound2:i386 (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 libgcc1:i386
 libc6:i386
 liblzma5:i386
 libpcre3:i386
 libgpg-error0:i386
 libgcrypt20:i386
 libselinux1:i386
 libasound2:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)


Как вообще можно решать зависимости? Был бы благодарен если бы дали что-то почитать на эту тему.

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2084
  • Lubuntu 16.04 LTS
    • Просмотр профиля
Re: Зависимости в Ubuntu
« Ответ #1 : 20 Май 2017, 14:31:43 »
Как вообще можно решать зависимости? 

"Решать зависимости" пользователю не нужно, этим занимается пакетный менеджер. Но у пакетного менеджера должен быть доступ к репозиториям, в которых есть необходимые пакеты.
При установке приложения из deb пакета, нужно внимательно читать инструкцию по установке, возможно там необходимо подключать дополнительный репозиторий. Так же важно, что бы приложение соответствовали версии вашей операционной системы. Но для начала нужно убедиться, что у вас порядок со стандартными репозиториями в файле sources.list

cat /etc/apt/sources.list
Приведите его содержание тут под спойлер.

Пользователь добавил сообщение 20 Май 2017, 15:51:47:

Только что попробовал установить teamviewer.

Скачал deb пакет здесь, потом при помощи gdebi всё установилось без проблем.
Установщик написал, что ему нужен всего один дополнительный пакет, который он потом сам докачал при установке.

Поэтому смотрите свои настройки репозиториев в sources.list
« Последнее редактирование: 20 Май 2017, 15:56:23 от ecc83 »

Оффлайн Teemitze

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Зависимости в Ubuntu
« Ответ #2 : 20 Май 2017, 15:58:30 »
Спасибо, что объяснили)

cat /etc/apt/sources.list
Вывод такой:
(Нажмите, чтобы показать/скрыть)

При попытке установить с GDebi выдаёт следующее:

« Последнее редактирование: 20 Май 2017, 16:11:17 от Teemitze »

Оффлайн ecc83

  • Старожил
  • *
  • Сообщений: 2084
  • Lubuntu 16.04 LTS
    • Просмотр профиля

Оффлайн Teemitze

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Зависимости в Ubuntu
« Ответ #4 : 20 Май 2017, 16:26:58 »
Вся проблема в этом заключается:

(Нажмите, чтобы показать/скрыть)

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Re: Зависимости в Ubuntu
« Ответ #5 : 20 Май 2017, 16:52:31 »

версия ОС? Разрядность?

1 проблемный пакет это
dpkg: ошибка при обработке пакета libgcc1:i386 (--configure): пакет libgcc1:i386 не готов к настройке настройка невозможна (текущее состояние: «half-installed»)все другие в зависимостях от него
попробуйте переустановить или удалить
sudo apt install --reinstall libgcc1

Оффлайн Teemitze

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Зависимости в Ubuntu
« Ответ #6 : 20 Май 2017, 17:11:34 »

версия ОС? Разрядность?

1 проблемный пакет это
dpkg: ошибка при обработке пакета libgcc1:i386 (--configure): пакет libgcc1:i386 не готов к настройке настройка невозможна (текущее состояние: «half-installed»)все другие в зависимостях от него
попробуйте переустановить или удалить
sudo apt install --reinstall libgcc1

Спасибо! Вы гений!



Терминал больше не ругается при вводе:
sudo apt install -f
« Последнее редактирование: 20 Май 2017, 17:45:35 от Teemitze »

 

Страница сгенерирована за 0.171 секунд. Запросов: 22.