Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Откатить Mesa  (Прочитано 2594 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ConnaiSSant

  • Автор темы
  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
Откатить Mesa
« : 21 Мая 2017, 12:43:50 »
Всем привет, имею карточку
Код: (bash) [Выделить]
lspci -k | grep -iA2 vga
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7640G]
Subsystem: Lenovo Trinity [Radeon HD 7640G]
Kernel driver in use: radeon

Проблема в том, что пару недель назад появились полосы и играх ВОТ и ВОВ. Видео гляньте

Предположительно, косячит mesa, текущая версия 17.2.0-devel как откатить до 17.1? Или более ранее. Использую ppa:oibaf/graphics-drivers

Пользователь добавил сообщение 21 Мая 2017, 12:49:01:
Код: (bash) [Выделить]
glxinfo | grep 'OpenGL version string' | grep Mesa
OpenGL version string: 3.0 Mesa 17.2.0-devel

cat /etc/issue.net
Ubuntu 16.04.2 LTS

uname -a
Linux IdeaPad 4.8.0-52-generic #55~16.04.1-Ubuntu SMP Fri Apr 28 14:36:29 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Код: (bash) [Выделить]
glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD ARUBA (DRM 2.46.0 / 4.8.0-52-generic, LLVM 4.0.1)
OpenGL core profile version string: 4.1 (Core Profile) Mesa 17.2.0-devel
OpenGL core profile shading language version string: 4.10
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.2.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 17.2.0-devel
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тега [spoiler]...[/spoiler] или [code]...[/code], либо прикреплять к сообщению в виде отдельного файла.
--Azure
« Последнее редактирование: 21 Мая 2017, 12:59:35 от Azure »

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3831
  • Kubuntu 12.04, 18.04, 20.04, 22.04, 24.04, 24.10
    • Просмотр профиля
Re: Откатить Mesa
« Ответ #1 : 21 Мая 2017, 14:59:10 »
Предположительно, косячит mesa, текущая версия 17.2.0-devel как откатить до 17.1? Или более ранее. Использую ppa:oibaf/graphics-drivers
Ежели на этой странице вам не удастся найти для себя утешения, то оставьте надежду на откат.

С другой стороны mesa 17.1 из основного репозитория уже присутствует на активно тестируемой Ubuntu 17.10 пользователями этого форума. Быть может это станет единственным выходом.
Я странен, а не странен кто ж? (С)

Оффлайн ConnaiSSant

  • Автор темы
  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
Re: Откатить Mesa
« Ответ #2 : 21 Мая 2017, 15:55:39 »
У меня и так подключены репы:

http://ppa.launchpad.net/commendsarnex/winedri3/ubuntu
http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu

Все ставилось от туда. Я хотел откатить mesa на более старую версию, может косяк бы ушел, но там нет более старых, только новая 17.2.0-devel. Как поставить от туда старую Mesa?

Пользователь добавил сообщение 21 Мая 2017, 16:01:58:
Быть может это станет единственным выходом.

Все равно не вижу выход((
« Последнее редактирование: 21 Мая 2017, 16:01:58 от ConnaiSSant »

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3831
  • Kubuntu 12.04, 18.04, 20.04, 22.04, 24.04, 24.10
    • Просмотр профиля
Re: Откатить Mesa
« Ответ #3 : 21 Мая 2017, 16:30:36 »
Все равно не вижу выход((

Отчего же вам его не видно? Нет, другое дело, если применять не хочется такой вариант, только он, похоже единственным остался на сегодня, в смысле иметь хоть какую-то систему с mesa 17.1 прямо сейчас. Или ваше желание уже изменилось?
Поскольку на 16.04 в основном репозитории mesa только 12.06, еще можно сидеть и смиренно ждать 17.1 - раньше или позже она там должна обновиться.
Я странен, а не странен кто ж? (С)

Оффлайн ConnaiSSant

  • Автор темы
  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
Re: Откатить Mesa
« Ответ #4 : 21 Мая 2017, 16:35:18 »
дело в том, что у меня сейчас Mesa 17.2.0-devel на 16.04
А хотелось бы без установки самой системы использовать более раннею mesa, так как последние обновления наносят ущерб. Какой смысл ставить промежуточную версию дистрибутива, чтобы потом, через определенное время ставить другой? Если же я могу досидеть на LTS дистрибутиве до выхода следующего LTS (18.04)?

Оффлайн Vikonrob

  • Активист
  • *
  • Сообщений: 364
    • Просмотр профиля
Re: Откатить Mesa
« Ответ #5 : 21 Мая 2017, 16:40:22 »
http://www.omgubuntu.co.uk/2017/05/mesa-17-1-ubuntu-ppa
Вот тут вроде как меса 17.1

Но до этого нужно удалить все ппа связанные с месой 17.2 и вернуть стоковую месу, от 16.04-й убунты, я так полагаю.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3831
  • Kubuntu 12.04, 18.04, 20.04, 22.04, 24.04, 24.10
    • Просмотр профиля
Re: Откатить Mesa
« Ответ #6 : 21 Мая 2017, 16:52:07 »
Vikonrob, вы правильно полагаете, а главное что нашли источник mesa 17.1, я особо не искал и ТС, похоже, тоже.
Но и откатом это не назовешь, простая переустановка.
Я странен, а не странен кто ж? (С)

Оффлайн ConnaiSSant

  • Автор темы
  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
Re: Откатить Mesa
« Ответ #7 : 21 Мая 2017, 17:17:41 »
http://www.omgubuntu.co.uk/2017/05/mesa-17-1-ubuntu-ppa
Вот тут вроде как меса 17.1

Но до этого нужно удалить все ппа связанные с месой 17.2 и вернуть стоковую месу, от 16.04-й убунты, я так полагаю.

Благодарю, не видел эту ссылку ранее.

Пользователь добавил сообщение 21 Мая 2017, 18:01:28:
Я полагаю, что не удастся это реализовать, ибо:

sudo ppa-purge ppa:oibaf/graphics-drivers (много букв)
(Нажмите, чтобы показать/скрыть)

Далее, предлагает и unity-desktop и virtualbox заменить и чуть ли не всю систему.

Пользователь добавил сообщение 21 Мая 2017, 18:06:50:
Хотел конечно выложить весь лог, но выдает ошибку
Следующие ошибки возникли при попытке отправки сообщения:
Сообщение превышает максимально допустимую длину (30000 знаков).


В общем, это не дело, так удалять репу нельзя


Пользователь добавил сообщение 21 Мая 2017, 18:15:41:
Косячу, не та репа.

 sudo ppa-purge ppa:oibaf/gallium-nine
(Нажмите, чтобы показать/скрыть)

Репа удалена, осталось только заменить mesa на более раннею
« Последнее редактирование: 21 Мая 2017, 18:15:41 от ConnaiSSant »

 

Страница сгенерирована за 0.047 секунд. Запросов: 25.