Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Установка Unreal Engine 4 последней версии  (Прочитано 3117 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Green_Chameleon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Ребят, помогите, не могу нормально скомпилировать UE 4, чтобы все это наконец-то заработало.
Что я делал:
sudo apt-get install build-essential mono-gmcs mono-xbuild mono-dmcs libmono-corlib4.0-cil libmono-system-data-datasetextensions4.0-cil
После этого скачал и распаковал архив с их Git-а
Дальше:
./Setup.sh
./GenerateProjectFiles.sh
после начал компиляцию командой make не изменяя никакие параметры в MakeFile

В итоге, на выходе, я получаю ошибку сегментации при загрузку самого движка.
Буду очень благодарен помощи.
Просто сложилась такая ситуация, что перестал уважать винду после пары обновлений и смерти системы, но при этом не равнодушен к лини, давно хотел полностью на нее перехать. Помогите с переездом! :'( :'( :'( :'(

Оффлайн ReNzRv

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Re: Установка Unreal Engine 4 последней версии
« Ответ #1 : 01 Июнь 2017, 01:17:26 »
В итоге, на выходе, я получаю ошибку сегментации при загрузку самого движка.
Текст ошибки давай, но сперва для поиска решения погугли его сам.

Оффлайн Green_Chameleon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Установка Unreal Engine 4 последней версии
« Ответ #2 : 01 Июнь 2017, 08:56:05 »
Я точно не знаю где тут ошибка, но вот лог всего запуска после команды: ./UE4Editor
(Нажмите, чтобы показать/скрыть)

Оффлайн scsiman

  • Активист
  • *
  • Сообщений: 344
    • Просмотр профиля
Re: Установка Unreal Engine 4 последней версии
« Ответ #3 : 01 Июнь 2017, 09:06:42 »
[2017.06.01-05.51.28:627][  0]LogInit:Error: _PlatformCreateOpenGLContextCore - Could not create OpenGL 4.3 context, SDL error: 'Could not create GL context: GLXBadFBConfig'
Какая видеокарта и какие драйверы установлены? UE4 хочет OpenGL версии 4.3, ваша видеокарта это поддерживает?
Dell Studio XPS 16, Ubuntu 16.04 LTS (Home).
HP nx6110, Ubuntu 8.04 LTS => 10.04 LTS (Home).

Оффлайн Green_Chameleon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Установка Unreal Engine 4 последней версии
« Ответ #4 : 01 Июнь 2017, 09:11:57 »
Должна, стоит GTX 960
Полный конфиг компа:
Intel Core i5 4690K
RAM 8GB
GPU GTX 960 2GB
HDD 1000GB
Чтобы сразу отбросить вопрос с нехваткой ОЗУ для работы движка!
« Последнее редактирование: 01 Июнь 2017, 11:22:19 от Green_Chameleon »

Оффлайн ReNzRv

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Re: Установка Unreal Engine 4 последней версии
« Ответ #5 : 02 Июнь 2017, 09:11:30 »
Покажи вывод
lspci -k | egrep -iA3 'vga|video|3d'

Оффлайн Green_Chameleon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Установка Unreal Engine 4 последней версии
« Ответ #6 : 02 Июнь 2017, 17:31:26 »
После команды lspci -k | egrep -iA3 'vga|video|3d'Получаю на выходе вот что:
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 02 Июнь 2017, 17:34:27 от Green_Chameleon »

Оффлайн scsiman

  • Активист
  • *
  • Сообщений: 344
    • Просмотр профиля
Re: Установка Unreal Engine 4 последней версии
« Ответ #7 : 02 Июнь 2017, 17:39:10 »
Понятно. Проприетарные драйверы nvidia ставьте.
Dell Studio XPS 16, Ubuntu 16.04 LTS (Home).
HP nx6110, Ubuntu 8.04 LTS => 10.04 LTS (Home).

Оффлайн Green_Chameleon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Установка Unreal Engine 4 последней версии
« Ответ #8 : 03 Июнь 2017, 10:22:06 »
Все заработало! Ребят, огромное спасибо вам за помощь, сегодня еще один человек стал чуточку счастливее благодаря вам!

Оффлайн fiveseven

  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Установка Unreal Engine 4 последней версии
« Ответ #9 : 02 Июль 2017, 09:58:18 »
Здравствуйте.

Установил UnrealEngine-4.15

Использовал инструкцию:
http://linuxoidblog.blogspot.ru/2015/07/unreal-engine-4.html

Железо: ноутбук, дискретная видеокарта NVidia GeForce 660M
Драйвер: 375.66 + bumblebee

Есть одна проблема:
Запуск из терминала проходит без проблем. Можно создать проект, загрузить его в редакторе.
Однако при запуске редактора с ярлыка, при создании проекта, или при открытии существующего проекта происходит загрузка где-то 45%, потом редактор валится.

Запуск из терминала редактора с указанием в параметрах существующего проекта тоже проходит без проблем.

Пробовал стартовать и через optirun и через primusrun

Подскажите, сталкивался ли кто-либо с подобным. Вроде мелочь, но раздражает.

Спасибо.
« Последнее редактирование: 02 Июль 2017, 10:04:13 от fiveseven »

 

Страница сгенерирована за 0.218 секунд. Запросов: 22.