Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Проблемма после установки uswsusp [решено]  (Прочитано 921 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн filin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Столкнулся с проблеммой в Ubuntu 7.10, не работали ждущий, спящий режимы, пришлось искать решение кроме как с коробки...На этом же форуме нашел линк на ман по установке uswusp, после установки так ничего и не заработало как надо....Уже думал.. ну и ладно...И вдруг система начала страшно тормозить и виснуть (буквально после запуска оперы и пары вкладок на ней). Посмотрел в здешней менеджере процессов, оказалось что система вообще не видит swap (пишет что используется 0 из возможных 0 мб файла подкачки) Уверен что проблемма возникла в связи с запуском проги суспенда вот так: # s2disk `fdisk -l | grep "Linux swap" | awk '{print $1}'`
Команда swapon -s не дала результатов, т.е. ни одной строки...
Fstab тоже настроен вроде правельно...
Я не силен в командах юникса, поэтому прошу помочь и вернуть своп на родину  :)
« Последнее редактирование: 04 Июнь 2008, 13:22:26 от filin »

Оффлайн SIO

  • Активист
  • *
  • Сообщений: 558
    • Просмотр профиля
Re: Проблемма после установки uswsusp
« Ответ #1 : 03 Июнь 2008, 23:09:30 »
Было такое. Я отформатировал своп-партицию, и снова подключил ее. С этим теперь все ОК.

PS: присоединяюсь к вопросу о корректной настройке s2disk.

Оффлайн filin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Проблемма после установки uswsusp
« Ответ #2 : 03 Июнь 2008, 23:41:31 »
Можно подробней с форматированием и монтированием партиции? Желательно в командах, просто мне сложновато гуглить при такой системе, спасибо за ответ.

Оффлайн SIO

  • Активист
  • *
  • Сообщений: 558
    • Просмотр профиля
Re: Проблемма после установки uswsusp
« Ответ #3 : 04 Июнь 2008, 00:02:27 »
Форматировать проще всего через gparted. Далее mkswap, swapon.

PS: Не уверен, но кажется, fstab тоже должна быть правильной. Не помню, редактировал ли после того происшествия

Оффлайн 12d3

  • Активист
  • *
  • Сообщений: 674
  • Ubuntu 10.04
    • Просмотр профиля
Re: Проблемма после установки uswsusp
« Ответ #4 : 04 Июнь 2008, 00:42:18 »
swapon - a <--- врубить своп. Если пишет, что нифига не получается, то глядим в fstab. Наверняка там стоит неправильный uuid после форматирования. Смотрим uuid в /dev/disk/by-uuid/ и ставим правильный. После это все должно быть окей.
p.s. форматирование с помощью gparted.

Оффлайн Alatar

  • Любитель
  • *
  • Сообщений: 96
    • Просмотр профиля
Re: Проблемма после установки uswsusp
« Ответ #5 : 04 Июнь 2008, 01:57:56 »
Было такое. Я отформатировал своп-партицию, и снова подключил ее. С этим теперь все ОК.

PS: присоединяюсь к вопросу о корректной настройке s2disk.
Возможно, поможет http://www.opennet.ru/base/sys/hibernate.txt.html,
или http://www.linux.com/articles/54610
или http://blog.paulbetts.org/index.php/2007/02/11/fixing-software-suspend-hibernate-with-uswsusp-in-ubuntu-feisty-and-edgy/
Последний линк кстати - конкретно по топику

Оффлайн filin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Проблемма после установки uswsusp
« Ответ #6 : 04 Июнь 2008, 13:15:03 »
Всем спасибо, проблема решена довольно просто.
Скачал gparted после чего под рутом отформатировал своп (на него небыло определено вообще файловой системы) после включил своп swapon -a .

 

Страница сгенерирована за 0.055 секунд. Запросов: 22.