Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Проблемы с ядром старше 4.8.6  (Прочитано 1140 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dmtr.S.

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Проблемы с ядром старше 4.8.6
« : 01 Июля 2017, 14:08:27 »
Здравствуйте.

Стояла Ubuntu 16.04.2, Unity. Ядра старше 4.8.6 корректно не работало. Часть программ (например Opera, Dowble Commander, почта) запускаются, но на мониторе ничего не происходит. При этом Лиса и служебные программы работают штатно. Пробовал поставить Гном, ничего не изменилось.

Решил обновиться до 17.04, с надеждой, что все заработает. Но ничего не изменилось. В итоге стоит 17.04,ядро 4.8.6, Unity.

Intel® Core™ i5-6500 CPU @ 3.20GHz × 4
Intel® HD Graphics 530 (Skylake GT2)
64-разрядная   

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 3765
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 22.04, 24.04
    • Просмотр профиля
Re: Проблемы с ядром старше 4.8.6
« Ответ #1 : 01 Июля 2017, 14:45:15 »
Dmtr.S., вообще-то 17.04 выходила на ядре 4.10. Вы ничего не путаете?
Я странен, а не странен кто ж? (С)

Оффлайн Dmtr.S.

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Проблемы с ядром старше 4.8.6
« Ответ #2 : 01 Июля 2017, 15:19:40 »
 AlexBKost.
Служебные программы то работают. :) Поставил Ukuu и стал с ядрами экспериментировать. 4.8.6 и младше - все работает. Старше - программы запускаются, но на мониторе пусто. Пробовал и последние ядра.
 

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6786
    • Просмотр профиля
Re: Проблемы с ядром старше 4.8.6
« Ответ #3 : 01 Июля 2017, 16:24:30 »
Dmtr.S., ну и откатитесь на работающее ядро. Вообще, зачем вам новые? Ядра менять стоит, если только что-то на старых не работает. А так - только текущее обновление штатного ядра - и всё будет норм.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 14038
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблемы с ядром старше 4.8.6
« Ответ #4 : 01 Июля 2017, 17:05:08 »
Dmtr.S.,
У вас ядра не от Ubuntu.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Dmtr.S.

  • Автор темы
  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
Re: Проблемы с ядром старше 4.8.6
« Ответ #5 : 01 Июля 2017, 17:17:33 »
Pilot6, 4.10 точно от Ubuntu. И обновления от Ubuntu приходят на это ядро.

Пользователь добавил сообщение 01 Июля 2017, 17:31:36:
maks05, это понятно. Думал, может легко данную проблему решить. Тогда бы сидел на 4.10 до окнчания поддержки.
« Последнее редактирование: 01 Июля 2017, 17:31:36 от Dmtr.S. »

Оффлайн rainall

  • Любитель
  • *
  • Сообщений: 73
  • Ubuntu-Mate 16.10
    • Просмотр профиля
Re: Проблемы с ядром старше 4.8.6
« Ответ #6 : 01 Июля 2017, 20:55:42 »
...Часть программ (например Opera, Dowble Commander, почта).
...
Пробовал поставить Гном, ничего не изменилось.
Еще программ не работающих хотелось бы увидеть.
А то у меня стоит ядро
 
~$ uname -r
4.10.15-041015-generic
и все работает в 16.10 Mate.

Palemoon, Skype, Thunderbird Mail...

Ядро прилетело оттуда
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.10.15

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 14038
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблемы с ядром старше 4.8.6
« Ответ #7 : 01 Июля 2017, 21:02:31 »
4.10.15-041015-generic
Это ядро не от Ubuntu.
Ядро прилетело оттуда
Прилететь оттуда он не могло. Это вы ручками поставили ядро mainline. Зачем только не понятно. Я бы еще понял, если бы оттуда ставили другие мажорные версии, которых нет в Ubuntu.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн rainall

  • Любитель
  • *
  • Сообщений: 73
  • Ubuntu-Mate 16.10
    • Просмотр профиля
Re: Проблемы с ядром старше 4.8.6
« Ответ #8 : 01 Июля 2017, 21:32:34 »
4.10.15-041015-generic
Это ядро не от Ubuntu.
Ядро прилетело оттуда
Прилететь оттуда он не могло. Это вы ручками поставили ядро mainline. Зачем только не понятно.
Да, неточно выразился. Поставил сам. Сначала посмотреть, так как ползли слухи что в 4.10 поддержка Kabby Lake улучшена. В результате осмотра решил его оставить. Например грузится оно на моем Kabby Lake процентов на 15 быстрее 4.8-х. Ну и штатное 4.8-е лежит пока на диске. Вдруг с помощью ТС найдутся неработающие программы.
« Последнее редактирование: 01 Июля 2017, 21:35:54 от rainall »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 14038
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблемы с ядром старше 4.8.6
« Ответ #9 : 01 Июля 2017, 21:35:41 »
rainall,
А что просто не обновиться на 17.04? Мейнлайновые ядра выложены для двух задач: обработки баг репортов, чтобы проверить где баг и для поддержки оборудования в новых ядрах, которое не поддреживается в предыдущих.
Совсем не для повседневного использования. Да и обновлять придется руками.
Откуда столько любителей ставить не те ядра?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн rainall

  • Любитель
  • *
  • Сообщений: 73
  • Ubuntu-Mate 16.10
    • Просмотр профиля
Re: Проблемы с ядром старше 4.8.6
« Ответ #10 : 01 Июля 2017, 21:45:17 »
rainall,
А что просто не обновиться на 17.04? Мейнлайновые ядра выложены для двух задач: обработки баг репортов, чтобы проверить где баг и для поддержки оборудования в новых ядрах, которое не поддреживается в предыдущих.
Совсем не для повседневного использования. Да и обновлять придется руками.
Ну ведь для старожилов не секрет, что иногда (если не всегда) поставить новую систему быстрее и проще чем обновить старую. Да и 17.04 такая же не LTS как и 16.10, т.е. будет смена шила на мыло. Проблемы с DNS в 17.04 пофиксили?

werlock

  • Гость
Re: Проблемы с ядром старше 4.8.6
« Ответ #11 : 01 Июля 2017, 22:52:24 »
В репах есть ядро 4.10 ничего колхозить не надо

 

Страница сгенерирована за 0.037 секунд. Запросов: 25.