Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Ошибка при выполнении ./configure  (Прочитано 3083 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Shlepov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Ошибка при выполнении ./configure
« : 20 Июль 2017, 14:02:35 »
При выполнении ./configure выходит ошибка "configure: error: C compiler cannot create executables". Переустановил libc6-dev и все его зависимости. Система 14.04

Вылоп ./configure 
(Нажмите, чтобы показать/скрыть)

config.log
(Нажмите, чтобы показать/скрыть)

Что еще можно попробовать?



ТС не появлялся на Форуме более полугода по состоянию на 09/09/2019 (последняя явка: 11/02/2019). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 09 Сентябрь 2019, 18:26:04 от zg_nico »

Оффлайн hesoyamatogun

  • Активист
  • *
  • Сообщений: 343
    • Просмотр профиля
Re: Ошибка при выполнении ./configure
« Ответ #1 : 20 Июль 2017, 14:21:17 »
А о чем это вы сейчас, точнее что это за программа, что делает, что конфигурирует, с какой целью вы её запускаете и что xотите получить?

Оффлайн Shlepov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Ошибка при выполнении ./configure
« Ответ #2 : 20 Июль 2017, 14:41:36 »
программа squid 3.5.8. Из репозитория она идет без поддержки SSL. Делаю по инструкции https://habrahabr.ru/post/272733/ .

Оффлайн hesoyamatogun

  • Активист
  • *
  • Сообщений: 343
    • Просмотр профиля
Re: Ошибка при выполнении ./configure
« Ответ #3 : 20 Июль 2017, 15:09:26 »
Может ты не заметил, у тебя error'ы не только в конце но и в середине парочка, которые объясняют причину а не только извещают что "error: C compiler cannot create executables"

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: Ошибка при выполнении ./configure
« Ответ #4 : 20 Июль 2017, 16:01:33 »
Цитировать
gcc: error: unrecognized command line option '-fstack-protector-strong'
что опять версии пропустили gcc пакеты в ubuntu?
a@a:~$
a@a:~$ cat 3.c
#include <stdio.h>

int main()
{
char *str; // [] = "hello";
printf ((const char*)str);
}
a@a:~$
a@a:~$
a@a:~$
a@a:~$ LANG=C gcc-4.9 -fstack-protector-strong -c  3.c  || echo "Ошибка"
a@a:~$
a@a:~$ LANG=C gcc-4.8 -fstack-protector-strong -c  3.c  || echo "Ошибка"
gcc-4.8: error: unrecognized command line option '-fstack-protector-strong'
Ошибка
a@a:~$

в шоке. :(
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн Shlepov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Ошибка при выполнении ./configure
« Ответ #5 : 20 Июль 2017, 17:13:41 »
Нет, не заметил. Спасибо!
Насколько я понял требуется версия gcc >5?

configure:5032: gcc -V >&5
gcc: error: unrecognized command line option '-V'
gcc: fatal error: no input files

Я обновил gcc до 5.4.1 20160904, и этот момент прошел успешно.
Теперь борюсь со следующей ошибкой:

configure: error: Basic auth helper getpwnam ... found but cannot be built

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: Ошибка при выполнении ./configure
« Ответ #6 : 20 Июль 2017, 17:28:40 »
gcc --version


Пользователь добавил сообщение 20 Июль 2017, 17:49:59:

Цитировать
Я обновил gcc до 5.4.1 20160904, и этот момент прошел успешно.
не а, плохо Ubuntu от сборки для пакеты gcc.


Пользователь добавил сообщение 21 Июль 2017, 02:51:08:
14.04
sudo apt-get install gccgo-4.9 g++-4.8
sudo rm -f /usr/local/bin/{gcc,g++}
sudo ln -s /usr/bin/gcc-4.9 /usr/local/bin/gcc
sudo ln -s /usr/bin/g++-4.8 /usr/local/bin/g++
exit

16.04
sudo apt-get install gccgo-6 g++-5
sudo rm -f /usr/local/bin/{gcc,g++}
sudo ln -s /usr/bin/gcc-6 /usr/local/bin/gcc
sudo ln -s /usr/bin/g++-5 /usr/local/bin/g++
exit
« Последнее редактирование: 21 Июль 2017, 02:51:08 от victor00000 »
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн Shlepov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Ошибка при выполнении ./configure
« Ответ #7 : 21 Июль 2017, 08:12:12 »
shlepov@it:~$ gcc --version
gcc (Ubuntu 5.4.1-2ubuntu1~14.04) 5.4.1 20160904
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

обновлял по этой инструкции.

Не пойму что за ошибка вылетает:

(Нажмите, чтобы показать/скрыть)

getpwnam это вроде обращение к файлу с паролями. На кой вообще свиду пароли? Я что-то запутался.
« Последнее редактирование: 21 Июль 2017, 09:06:19 от Shlepov »

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: Ошибка при выполнении ./configure
« Ответ #8 : 21 Июль 2017, 13:15:21 »
смотри мою посту "16.04" и команды.
Нельзя друзья, дулу - AnrDaemon видите?
~.o

 

Страница сгенерирована за 0.192 секунд. Запросов: 22.