Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Ребята помогите проблема с зависимостями  (Прочитано 3831 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cunningfox

  • Автор темы
  • Участник
  • *
  • Сообщений: 148
  • Системный чайник
    • Просмотр профиля
    • Создание сайтов в Крыму
Сверху у вай фая кирпич висит глаголящий

Произошла ошибка, пожалуйста запустите менеджера пакетов из меню или запустите команду apt-get install -f чтобы исправить.

Сообщение об ошибке BrokenCount > 0

Запускаю команду

(Чтение базы данных … на данный момент установлено 212459 файлов и каталогов.)
Подготовка к распаковке …/sni-qt_0.2.7+16.04.20170217.1-0ubuntu1_i386.deb …
Распаковывается sni-qt:i386 (0.2.7+16.04.20170217.1-0ubuntu1) на замену (0.2.6-0ubuntu1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/sni-qt_0.2.7+16.04.20170217.1-0ubuntu1_i386.deb (--unpack):
 попытка перезаписать общий «/usr/share/doc/sni-qt/copyright», который отличается от других экземпляров пакета sni-qt:i386
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/sni-qt_0.2.7+16.04.20170217.1-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Прошу помощи



Пользователь добавил сообщение 04 Август 2017, 15:39:20:
При установке темы выдает

sudo apt-get install unity-tweak-tool
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 sni-qt : Ломает: sni-qt:i386 (!= 0.2.7+16.04.20170217.1-0ubuntu1) но 0.2.6-0ubuntu1 будет установлен
 sni-qt:i386 : Ломает: sni-qt (!= 0.2.6-0ubuntu1) но 0.2.7+16.04.20170217.1-0ubuntu1 будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
« Последнее редактирование: 04 Август 2017, 15:39:20 от cunningfox »
< ?php echo "Изучаю ubuntu"; ? >

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6780
    • Просмотр профиля
Re: Ребята помогите проблема с зависимостями
« Ответ #1 : 04 Август 2017, 16:43:09 »
cunningfox, ну, собственно, всё вам Терминал правильно пишет: настоятельно рекомендует исправить зависимости с помощью команды
sudo apt-get install -f

Оффлайн cunningfox

  • Автор темы
  • Участник
  • *
  • Сообщений: 148
  • Системный чайник
    • Просмотр профиля
    • Создание сайтов в Крыму
Re: Ребята помогите проблема с зависимостями
« Ответ #2 : 04 Август 2017, 19:56:01 »
cunningfox, ну, собственно, всё вам Терминал правильно пишет: настоятельно рекомендует исправить зависимости с помощью команды
sudo apt-get install -f

Я же писал в тему что при вводе команды sudo apt-get install -f появляются ошибки. нужен был иной выход

(Чтение базы данных … на данный момент установлено 212459 файлов и каталогов.)
Подготовка к распаковке …/sni-qt_0.2.7+16.04.20170217.1-0ubuntu1_i386.deb …
Распаковывается sni-qt:i386 (0.2.7+16.04.20170217.1-0ubuntu1) на замену (0.2.6-0ubuntu1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/sni-qt_0.2.7+16.04.20170217.1-0ubuntu1_i386.deb (--unpack):
 попытка перезаписать общий «/usr/share/doc/sni-qt/copyright», который отличается от других экземпляров пакета sni-qt:i386
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/sni-qt_0.2.7+16.04.20170217.1-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Но уже не важно, надо было снести 2 пакета и все заработало. Быстрее оказалось догадаться самому.
« Последнее редактирование: 04 Август 2017, 19:58:18 от cunningfox »
< ?php echo "Изучаю ubuntu"; ? >

Оффлайн Jack_oS

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Ребята помогите проблема с зависимостями
« Ответ #3 : 24 Август 2017, 19:48:11 »
такая же ошибка...

надо было снести 2 пакета и все заработало

какие и как?

Оффлайн cunningfox

  • Автор темы
  • Участник
  • *
  • Сообщений: 148
  • Системный чайник
    • Просмотр профиля
    • Создание сайтов в Крыму
Re: Ребята помогите проблема с зависимостями
« Ответ #4 : 26 Август 2017, 20:58:04 »
какие и как?

Ввел
sudo apt-get install -f
Мне выдало  ошибки, глянул что за программы, снес их и все заработало.

У меня были

dpkg: ошибка при обработке архива /var/cache/apt/archives/sni-qt_0.2.7+16.04.20170217.1-0ubuntu1_i386.deb (--unpack):
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/sni-qt_0.2.7+16.04.20170217.1-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Посмотрите что у вас и исправьте, после кирпич пропадет.


P/S перешел на гнома 3 тут нервирующего кирпича вообще нету.

< ?php echo "Изучаю ubuntu"; ? >

Оффлайн Jack_oS

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Ребята помогите проблема с зависимостями
« Ответ #5 : 26 Август 2017, 21:38:10 »
на моё $ sudo apt-get -f install отвечает:
(Нажмите, чтобы показать/скрыть)
сносить /var/cache/apt/archives/sni-qt_0.2.7+16.04.20170217.1-0ubuntu1_i386.deb?

Оффлайн ReNzRv

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Re: Ребята помогите проблема с зависимостями
« Ответ #6 : 26 Август 2017, 23:05:48 »
Jack_oS,
sudo apt-get clean

Оффлайн Jack_oS

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Ребята помогите проблема с зависимостями
« Ответ #7 : 27 Август 2017, 00:01:08 »
renzrv, делал, равно как и sudo apt autoremove, sudo apt clean & sudo apt update, sudo apt upgrade...
И все равно:
(Нажмите, чтобы показать/скрыть)
Меня даже не кипич в трее волнует, а то, что эта ошибка со sni-qt ничего не дает установить...
Видимо, в сисеме был sni-qt:i386 0.2.7, и я умудрился установить 0.2.6? Как это исправить?

PS выдохнул и сделал $ sudo dpkg -r sni-qt
Кирпича нет  :D
$ sudo apt-get -f install - без ошибок.
После
$ sudo apt-get clean
$ sudo apt-get update && sudo apt-get upgrade
среди прочего:
распаковка sni-qt:i386 (0.2.7+16.04.20170217.1-0ubuntu1) над (0.2.6-0ubuntu1)
и ниже:
настройка sni-qt:i386 (0.2.7+16.04.20170217.1-0ubuntu1) ...
« Последнее редактирование: 27 Август 2017, 00:24:29 от Jack_oS »

Оффлайн ReNzRv

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Re: Ребята помогите проблема с зависимостями
« Ответ #8 : 27 Август 2017, 00:20:00 »
И все равно:
Это уже другая ошибка.

dpkg -s sni-qt?

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Re: Ребята помогите проблема с зависимостями
« Ответ #9 : 27 Август 2017, 00:25:30 »
Jack_oS, разрядность ОС?
dpkg --print-architecture;dpkg --print-foreign-architectures

Оффлайн Jack_oS

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Ребята помогите проблема с зависимостями
« Ответ #10 : 27 Август 2017, 00:37:10 »
renzrv, $ dpkg -s sni-qt
(Нажмите, чтобы показать/скрыть)
ps Вы тоже хотели сменить зеленый значек скайпа на серый?  ???

ARTGALGANO, $ dpkg --print-architecture;dpkg --print-foreign-architectures
(Нажмите, чтобы показать/скрыть)

Я выше писАл про $ sudo dpkg -r sni-qt и результат...
Что скажете? Жить будет? если я снова ничего не сломаю, конечно...  :-\
« Последнее редактирование: 27 Август 2017, 00:44:23 от Jack_oS »

 

Страница сгенерирована за 0.147 секунд. Запросов: 22.