Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Установка Ubuntu 16 поверх win 10 (очень нуждаюсь в помощи)  (Прочитано 947 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн BelarusNoob

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Собственно в чем цимус господа - я кривенький и Ubuntu никогда не юзал, но мне она резко понадобилась. Я решил установить ее второй системой и делал вроде как все по мануалам - разбил как надо все, поставил и вышло так, что мою win 10 никак не распознает загрузчик и никакого меню нет для выбора при загрузке ноута. Просто запускается Ubuntu и все. Тонну статей уже перечитал - ничего не помогает. Атас господа - нуб молит о пощаде  ;)
Вот так выглядят сейчас разделы, которые я сделал:



« Последнее редактирование: 15 Август 2017, 16:09:37 от BelarusNoob »

Оффлайн ReNzRv

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Вывод
sudo lshw; sudo update-grub

Оффлайн BelarusNoob

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Вот:
(Нажмите, чтобы показать/скрыть)

Оффлайн ReNzRv

  • Старожил
  • *
  • Сообщений: 2628
    • Просмотр профиля
Adding boot menu entry for EFI firmware configuration
Перезагрузись. Меню GRUB появилось?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13498
  • Xubuntu 18.04
    • Просмотр профиля
Судя по разметке, Windows установлена не в режиме UEFI, так как раздел EFI находится на расширенном разделе, и видимо создан ТС. Да и диск размечен в MBR. Отсюда и проблемы. Надо просто поставить в legacy.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн BelarusNoob

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Никакого загрузчика с менюшкой не появилось, просто запустилась ubuntu как обычно.
На счет UEFI - win 10 вроде как можно только в UEFI ставить. А раздел EFI я создал сам, потому что установщик Ubuntu матерился и ссылался на то, что не может поставить граб в /target/ , после чего я создал efi и Ubuntu стала как родная.

Пользователь добавил сообщение 15 Август 2017, 17:34:07:
Судя по разметке, Windows установлена не в режиме UEFI, так как раздел EFI находится на расширенном разделе, и видимо создан ТС. Да и диск размечен в MBR. Отсюда и проблемы. Надо просто поставить в legacy.
Если выставить в биосе legacy - это может помочь? И запуститься ли у меня тогда win 10? Хотя попытка не пытка  :-\

Пользователь добавил сообщение 15 Август 2017, 17:40:16:
Вообщем я попробовал выставить legacy - у меня просто такого пункта в биосе нет, но на загрузке системы я попробовал нажать ESC и у меня вылезла граб-менюха, но там было всего 3 пукнта: ubuntu, доп настройки ubuntu и system setup. Винды там нет - получается grab не видит винду? Я что-то не так разметил на установке ubuntu?

Пользователь добавил сообщение 15 Август 2017, 18:53:25:
Ладно, раз такое дело - буду сносить обе оси и ставить все заново, видимо ничего другого не остается. Всем откликнувшимся спасибо, хотя бы за оказанное внимание  :-[
« Последнее редактирование: 15 Август 2017, 18:53:25 от BelarusNoob »

Оффлайн Дюшик

  • Активист
  • *
  • Сообщений: 801
    • Просмотр профиля
BelarusNoob,
Вы позанимались самодеятельностью (создали раздел EFI на диске с разметкой MBR), соответсвенно и результат получили.
У вас 10-ка установлена на MBR диск в режиме Legacy, это значит, что у вас или "простой" BIOS без UEFI или UEFI-BIOS и включён режим Legacy (он может называтся по-разному Launch CSM; CMS Boot и т.л.). Вообщем вам нужно правильно загрузиться с установочной флешки Ubuntu (в Legacy) и устанавливать систему.

Оффлайн BelarusNoob

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
BelarusNoob,
Вы позанимались самодеятельностью (создали раздел EFI на диске с разметкой MBR), соответсвенно и результат получили.
У вас 10-ка установлена на MBR диск в режиме Legacy, это значит, что у вас или "простой" BIOS без UEFI или UEFI-BIOS и включён режим Legacy (он может называтся по-разному Launch CSM; CMS Boot и т.л.). Вообщем вам нужно правильно загрузиться с установочной флешки Ubuntu (в Legacy) и устанавливать систему.
ОГРОМНОЕ ВАМ СПАСИБО! Вы дали мне очень ценную подсказку на счет launch CSM, я его выключил и полностью переустановил Оси: win8->апдейт до 10->Ubuntu 16.04 и ткнул загрузочник в efi как мне и говорили. И все ок, все работает как часы! Появляется менюшка и там выбор, вообщем сказка!) Еще раз огромное спасибо за наводку.

 

Страница сгенерирована за 0.409 секунд. Запросов: 22.