Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Неудовлетворённые зависимости.  (Прочитано 2364 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sandcrawler

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Неудовлетворённые зависимости.
« : 05 Сентябрь 2017, 00:46:43 »
Господа, выручайте. Надоел мне, понимаете, Unity и захотел я себе установить новую графическую оболочку. Выбор пал на Plasma. Однако, во время установки произошла ошибка. Теперь apt-get отказывается нормально работать. Каждый раз при установке пакета выскакивает: Неудовлетворённые зависимости. Попытайтесь использовать -f.
Что я делал:
1. Запускал sudo apt-get -f install
На что получал сообщение:
Цитировать
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb
2. Удалял файлы вручную и через apt-get clean
3. Пытался удалить оболочку
4. Пытался установить заново
5. Прошёлся по всем страницам
Цитировать
https://www.google.ru/search?newwindow=1&q=%D0%BD%D0%B5%D1%83%D0%B4%D0%BE%D0%B2%D0%BB%D0%B5%D1%82%D0%B2%D0%BE%D1%80%D1%91%D0%BD%D0%BD%D1%8B%D0%B5+%D0%B7%D0%B0%D0%B2%D0%B8%D1%81%D0%B8%D0%BC%D0%BE%D1%81%D1%82%D0%B8&oq=%D0%9D%D0%B5&gs_l=psy-ab.1.0.35i39k1l2j0i131k1l2.352054.352734.0.354615.2.2.0.0.0.0.72.144.2.2.0....0...1.1.64.psy-ab..0.2.141.7T7ZLKl_4bc
и выполнил всё. Но ничего не помогает. Я так понимаю, что какой-то пакет не был установлен, а он нужен. И теперь каждый раз при установки пакета apt-get говорит, что один из них не был установлен. Команда -f install должна автоматически докачать все неустановленные пакеты, но в одном из них происходит ошибка.
Я так понимаю, нужно удалить пакеты, которые требуют ошибочный, но как это сделать?
Мудрецы, я надеюсь на вашу помощь.
UPD. Ubuntu 16.04

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 2827
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04
    • Просмотр профиля
Re: Неудовлетворённые зависимости.
« Ответ #1 : 05 Сентябрь 2017, 00:59:31 »
Выбор пал на Plasma.
...
UPD. Ubuntu 16.04

Проще будет установить kubuntu с нуля, только на 16.04 я не советую возлагать большие надежды. Будет интересно что делать дальше, готов посильно помочь.
Я странен, а не странен кто ж? (С)

Оффлайн sandcrawler

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Неудовлетворённые зависимости.
« Ответ #2 : 05 Сентябрь 2017, 01:12:26 »
Выбор пал на Plasma.
...
UPD. Ubuntu 16.04

Проще будет установить kubuntu с нуля, только на 16.04 я не советую возлагать большие надежды. Будет интересно что делать дальше, готов посильно помочь.
С нуля, это в смысле форматировать диск и заново всё ставить? Обидно, придется заново кучу программ ставить и настраивать. Я на это несколько дней потрачу.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 2827
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04
    • Просмотр профиля
Re: Неудовлетворённые зависимости.
« Ответ #3 : 05 Сентябрь 2017, 06:54:34 »
sandcrawler, есть такой славный менеджер пакетов Synaptic, он замечательно справляется с Исправлением пакетов "с ошибками".
Я странен, а не странен кто ж? (С)

Aceler

  • Гость
Re: Неудовлетворённые зависимости.
« Ответ #4 : 05 Сентябрь 2017, 11:22:03 »
Цитируйте текст ошибки полностью.

Оффлайн sandcrawler

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Неудовлетворённые зависимости.
« Ответ #5 : 05 Сентябрь 2017, 11:34:20 »
Synaptic
Похоже, это невозможно. Через apt-get получить не получается, естественно. Установить из .deb тоже.
Цитировать
Выбор ранее не выбранного пакета synaptic.
(Чтение базы данных … на данный момент установлен 557931 файл и каталог.)
Подготовка к распаковке synaptic-0-81-2-multi-ubu.deb …
Распаковывается synaptic (0.81.2) …
dpkg: зависимости пакетов не позволяют настроить пакет synaptic:
 synaptic зависит от libapt-inst1.5 (>= 0.8.16~exp12), однако:
  Пакет libapt-inst1.5 не установлен.
 synaptic зависит от libapt-pkg4.12 (>= 0.9.11), однако:
  Пакет libapt-pkg4.12 не установлен.
 synaptic зависит от libept1.4.12, однако:
  Пакет libept1.4.12 не установлен.
 synaptic зависит от libvte-2.90-9 (>= 1:0.27.2), однако:
  Пакет libvte-2.90-9 не установлен.
 synaptic зависит от libxapian22, однако:
  Пакет libxapian22 не установлен.

dpkg: ошибка при обработке пакета synaptic (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для man-db (2.7.5-1) …
Обрабатываются триггеры для bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index...
Обрабатываются триггеры для gnome-menus (3.13.3-6ubuntu3.1) …
Обрабатываются триггеры для desktop-file-utils (0.22-1ubuntu5) …
Обрабатываются триггеры для mime-support (3.59ubuntu1) …
Обрабатываются триггеры для hicolor-icon-theme (0.15-0ubuntu1) …
При обработке следующих пакетов произошли ошибки:
 synaptic

Пользователь добавил сообщение 05 Сентябрь 2017, 11:37:16:
Aceler,
sudo apt-get -f install
Цитировать
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-headers-4.4.0-81 linux-headers-4.4.0-81-generic linux-headers-4.4.0-83 linux-headers-4.4.0-83-generic linux-headers-4.4.0-87 linux-headers-4.4.0-87-generic
  linux-headers-4.4.0-89 linux-headers-4.4.0-89-generic linux-headers-4.4.0-91 linux-headers-4.4.0-91-generic linux-image-4.4.0-81-generic
  linux-image-4.4.0-83-generic linux-image-4.4.0-87-generic linux-image-4.4.0-89-generic linux-image-4.4.0-91-generic linux-image-extra-4.4.0-81-generic
  linux-image-extra-4.4.0-83-generic linux-image-extra-4.4.0-87-generic linux-image-extra-4.4.0-89-generic linux-image-extra-4.4.0-91-generic
  linux-signed-image-4.4.0-81-generic linux-signed-image-4.4.0-83-generic linux-signed-image-4.4.0-87-generic linux-signed-image-4.4.0-89-generic
  linux-signed-image-4.4.0-91-generic
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  kde-config-telepathy-accounts libept1.5.0 synaptic
Предлагаемые пакеты:
  dwww menu deborphan apt-xapian-index
Рекомендуемые пакеты:
  rarian-compat
НОВЫЕ пакеты, которые будут установлены:
  kde-config-telepathy-accounts libept1.5.0
Пакеты, которые будут обновлены:
  synaptic
обновлено 1, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 225 пакетов не обновлено.
не установлено до конца или удалено 3 пакетов.
Необходимо скачать 1 431 kB/1 568 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 341 kB.
Хотите продолжить? [Д/н] y
Пол:1 http://ru.archive.ubuntu.com/ubuntu xenial/universe amd64 libept1.5.0 amd64 1.1+nmu3 [77,6 kB]
Пол:2 http://ru.archive.ubuntu.com/ubuntu xenial/universe amd64 synaptic amd64 0.83 [1 354 kB]
Получено 1 431 kБ за 0с (2 386 kБ/c) 
(Чтение базы данных … на данный момент установлено 558206 файлов и каталогов.)
Подготовка к распаковке …/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb …
Распаковывается kde-config-telepathy-accounts (4:15.12.3-0ubuntu1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb (--unpack):
 попытка перезаписать «/usr/share/accounts/services/google-im.service», который уже имеется в пакете account-plugin-google 0.12+16.04.20160126-0ubuntu1
Выбор ранее не выбранного пакета libept1.5.0:amd64.
Подготовка к распаковке …/libept1.5.0_1.1+nmu3_amd64.deb …
Распаковывается libept1.5.0:amd64 (1.1+nmu3) …
Подготовка к распаковке …/synaptic_0.83_amd64.deb …
Распаковывается synaptic (0.83) на замену (0.81.2) …
Обрабатываются триггеры для libc-bin (2.23-0ubuntu9) …
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

Обрабатываются триггеры для man-db (2.7.5-1) …
Обрабатываются триггеры для bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index...
Обрабатываются триггеры для gnome-menus (3.13.3-6ubuntu3.1) …
Обрабатываются триггеры для desktop-file-utils (0.22-1ubuntu5) …
Обрабатываются триггеры для mime-support (3.59ubuntu1) …
Обрабатываются триггеры для hicolor-icon-theme (0.15-0ubuntu1) …
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo apt-get install smth
Цитировать
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 duck : Зависит: libfile-which-perl но он не будет установлен
        Зависит: libparse-debcontrol-perl но он не будет установлен
        Зависит: libpath-class-perl но он не будет установлен
        Зависит: libregexp-common-email-address-perl но он не будет установлен
        Зависит: libregexp-common-perl но он не будет установлен
        Зависит: libstring-similarity-perl но он не будет установлен
        Зависит: libwww-curl-perl но он не будет установлен
        Зависит: libxml-xpath-perl но он не будет установлен
        Зависит: libconfig-inifiles-perl но он не будет установлен
 kde-telepathy-minimal : Зависит: kde-config-telepathy-accounts (>= 15.04.0) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
« Последнее редактирование: 05 Сентябрь 2017, 11:37:16 от sandcrawler »

Aceler

  • Гость
Re: Неудовлетворённые зависимости.
« Ответ #6 : 05 Сентябрь 2017, 11:49:12 »
попытка перезаписать «/usr/share/accounts/services/google-im.service», который уже имеется в пакете account-plugin-google 0.12+16.04.20160126-0ubuntu1
Раз уж вы меняете DE на KDE, придётся удалить account-plugin-google, который конфликтует с kde-config-telepathy-accounts.

После чего выполить apt-get install -f

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Re: Неудовлетворённые зависимости.
« Ответ #7 : 05 Сентябрь 2017, 11:49:33 »
sudo dpkg -P unity-scope-gdrive account-plugin-google account-plugin-facebook
sudo apt-get install -f
?

Оффлайн sandcrawler

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Неудовлетворённые зависимости.
« Ответ #8 : 05 Сентябрь 2017, 14:07:49 »
Господа, спасибо, это помогло. Но можете, пожалуйста, немного подробнее объяснить что я сделал этой командой и почему это помогло?

toZen

  • Гость
Re: Неудовлетворённые зависимости.
« Ответ #9 : 05 Сентябрь 2017, 16:36:54 »
что я сделал этой командой
man dpkg  :coolsmiley:

 

Страница сгенерирована за 0.15 секунд. Запросов: 22.