Форум русскоязычного сообщества Ubuntu


Автор Тема: не могу установить php7.1  (Прочитано 3302 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Loader

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
не могу установить php7.1
« : 16 Сентябрь 2017, 18:43:36 »
Добавил репозитарий для 7.1
root@h2726115:/etc/apt# apt-get update
Get:1 http://ppa.launchpad.net/ondrej/php/ubuntu xenial InRelease [23.9 kB]
Ign:1 http://ppa.launchpad.net/ondrej/php/ubuntu xenial InRelease
Get:2 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main Sources [28.0 kB]
Get:3 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main amd64 Packages [48.2 kB]
Get:4 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main Translation-en [27.2 kB]
Hit:5 ftp://ftp.stratoserver.net/pub/linux/ubuntu xenial InRelease
Hit:6 ftp://ftp.stratoserver.net/pub/linux/ubuntu xenial-updates InRelease
Hit:7 ftp://ftp.stratoserver.net/pub/linux/ubuntu xenial-security InRelease
Fetched 127 kB in 0s (159 kB/s)
Reading package lists... Done
W: GPG error: http://ppa.launchpad.net/ondrej/php/ubuntu xenial InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 4F4EA0AAE5267A6C
W: The repository 'http://ppa.launchpad.net/ondrej/php/ubuntu xenial InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
root@h2726115:/etc/apt# apt-secure
bash: apt-secure: command not found
root@h2726115:/etc/apt# apt-secure(8)
bash: syntax error near unexpected token `8'
root@h2726115:/etc/apt# apt-secure
bash: apt-secure: command not found
Почему-то на него ругается. Как вставить ссылку на подписанный репозитарий?
Ну и как следствие

root@h2726115:/etc/apt# apt install php7.1
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php7.1
E: Couldn't find any package by glob 'php7.1'
E: Couldn't find any package by regex 'php7.1'
Ubuntu 16,04
Как решить проблему?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27413
    • Просмотр профиля
Re: не могу установить php7.1
« Ответ #1 : 16 Сентябрь 2017, 18:51:28 »
Правильно добавить репо в систему.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Loader

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: не могу установить php7.1
« Ответ #2 : 16 Сентябрь 2017, 18:58:45 »
А как это сделать?

Оффлайн F12

  • Старожил
  • *
  • Сообщений: 2404
    • Просмотр профиля
Re: не могу установить php7.1
« Ответ #3 : 16 Сентябрь 2017, 19:04:20 »
А как это сделать?
- примерно так

Оффлайн Loader

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: не могу установить php7.1
« Ответ #4 : 16 Сентябрь 2017, 22:59:45 »
Спасибо, разобрался, просто не везде пишут что перед добавлением репозитариев таким способом нужно:
apt-get install software-properties-common python-software-properties
« Последнее редактирование: 16 Сентябрь 2017, 23:03:54 от Loader »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27413
    • Просмотр профиля
Re: не могу установить php7.1
« Ответ #5 : 17 Сентябрь 2017, 08:25:53 »
перед добавлением репозитариев таким способом нужно:
Выберите что-то одно. Либо software-properties-common, либо python-software-properties.
(Для новых систем, кстати, правильно - первое.)
А не везде пишут потому, что везде это по умолчанию уже стоит.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.159 секунд. Запросов: 24.