Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Не устанавливаются драйвера nvidia в Ubuntu 17.04 после смены слота на материнке  (Прочитано 933 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн north.leshiy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Переставил видеокарту в другой слот в связи со сменой корпуса (теперь БП снизу и старый слот перекрыт) и после этого система перестала загружаться. Точнее перестал загружаться драйвер.

Симптомы:
1. grub стал загружаться в разрешнии 640, хотя раньше загружался в 1920 по умолчанию
2. при загрузке системы мигает курсор, перейти через ctrl+alt+f[1-7] не получается, экран мигает и текст консоли высвечивается на секунду с таймаутом в несколько секунд.

Что пробовал:
1. В режиме загрузки удалял драйвера и по очереди ставил
- из официального репозитория
- из неофициального репозитория
- из исходников
разные версии (384, 381, 370) драйверов.
В духе:
sudo apt-get purge nvidia*
sudo apt-get install nvidia-N nvidia-settings

2. Без проприетарного драйвера под nouveau работает нормально. Но он не устраивает, нужна бОльшая производительность для работы и развлечений и как следствие возможность использования проприетарного драйвера.
3. Пробовал ставить версии через встроенный в kde диспетчер драйверов - та же проблема.
4. Протестировал под своей виндой (стоит windows10 на отельной ssd), проблема с драйвером тоже имеется. При включении оригинального драйвера монитор гаснет.
5. Отнес видеокарту товарищу, под виндой и оригинальным драйвером работает на "Ура", стрес-тесты и даже майнер запускали - карта рабочая.
6. Переустановил kubuntu с нуля (в т.ч. с чистой папкой /home), проблема осталась.
7. Пробовал устанавливать видео в разные слоты (их на старенькой мамке почему то 4шт) и пробовал использовать другой кабель доп.питания видюхи.

Версия системы:
kubuntu 17.04. До переустановки видеокарты в другой слот все работало отлично!

Оборудование:
Мать: GIGABYTE GA-990FXA-D3 (https://market.yandex.ru/product/7306177/spec)
Видеокарта: ASUS NVIDIA GeForce GTX 960 TURBO (https://market.yandex.ru/product/12559432/spec)
Монитор: Asus VE247 1920х1080, подключен через DVI (на всякий)

Подскажите, куда копать?

Уже совсем отчаялся, мысли в духе покупать что-нибудь из комплектующих нового, хотя ценники нынче конские  :-[

Оффлайн mahinist

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3363
  • Ubuntu-20.04, Archlinux, Gentoo
    • Просмотр профиля
1. grub стал загружаться в разрешнии 640, хотя раньше загружался в 1920 по умолчанию

Покажи вывод -
sudo cat /boot/grub/grub.cfg
под спойлер или код .
31-регион

Оффлайн CrazyDimson

  • Участник
  • *
  • Сообщений: 244
    • Просмотр профиля
north.leshiy,
Цитировать
1. 2 разъема PCI Express x16 (PCIEX16_1и PCIEX16_2, режим работы x16)
** Если видеоподсистема представлена одной дискретной графической PCIe-платой, с целью обеспечения максимальной производительности рекомендуем установить ее в разъем PCIEX16_1; тандем в составе двух графических PCIe-плат следует установить их в разъемы PCIEX16_1 и PCIEX16_2.
2. 2 порта PCI Express x16 (разъем PCIEX4_1 и PCIEX4_2, функционируют в режиме x4)
3. 2 порта PCI Express x1 * Все разъёмы PCI Express удовлетворяют требованиям спецификации PCI Express 2.0.

Так в какой слот установлена видеокарта?

Оффлайн north.leshiy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
sudo cat /boot/grub/grub.cfg
(Нажмите, чтобы показать/скрыть)

Цитировать
Так в какой слот установлена видеокарта?
Сейчас в PCIEX16_1, но пробовал и в PCIEX16_2, PCIEX4_1 - поведение идентичное.
Раньше была в PCIEX4_2


В режиме ndvidia удалось зайти в ctrl+alt+f1 (прорвался сквозь дрегания экрана) и потушить service sddm stop.
После этого скопировал логи

/var/log/Xorg.0.log
https://pastebin.com/AUeezK7F

/var/log/gpu-manager.log
https://pastebin.com/LmpXdzkp

P.S. скопировал в pastebin чтобы обойти лимит сообщения.

Оффлайн CrazyDimson

  • Участник
  • *
  • Сообщений: 244
    • Просмотр профиля
north.leshiy, В BIOS есть возможность выключить secure boot?

Оффлайн north.leshiy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
north.leshiy, В BIOS есть возможность выключить secure boot?

Нет такой настройки =(

Пробовал отключать EFI (где то прочитал что без EFI нет secure boot, мб бред) - ничего не дает.
« Последнее редактирование: 20 Сентябрь 2017, 02:01:22 от north.leshiy »

Оффлайн north.leshiy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Нашел решение на одном из виндузовых форумов.
Кто бы подумал - при смене DVI на HDMI проблема решилась.

До сих пор в голове не укладывается каким фигом дрова так влияют на кабель? Почему DVI под nouevae работает, а под проприетарным нет?) И почему работало до этого норм?)

 

Страница сгенерирована за 0.272 секунд. Запросов: 24.