Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Как установить проприетарный драйвер для видеокарты HD4200?  (Прочитано 1714 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Простой юзер

  • Автор темы
  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
надо установить проприетарный драйвер на видео, ось - Xubuntu 14.04.5
вроде бы надо откатить Xorg до 1.12 и установить 3-е ядро, плюс какие патчи
подскажите пожалуйста, что конкретно мне надо сделать?

ТС не появлялся на Форуме более полугода по состоянию на 17/07/2019 (последняя явка: 25/09/2018). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 17 Июль 2019, 08:43:07 от zg_nico »

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2101
    • Просмотр профиля

Оффлайн Простой юзер

  • Автор темы
  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
разве описание установки драйвера в debian без изменений подходит для убунты?
вроде раньше у них были отличия...

п.с. вдобавок статья старая, тогда проблем ни с хоргом, ни с ядром ещё не было
« Последнее редактирование: 20 Сентябрь 2017, 15:44:06 от Простой юзер »

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2101
    • Просмотр профиля
Вот что пишет поддержка amd 
http://support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-HD-4000%2c-HD-3000%2c-and-HD-2000-Series-LINUX-support.aspx
Они прекращают поддержку данной серии и рекомендуют купить новую карту.
Отличия только в окружении, основа одна.
Ну драйвера нужно ставить соответственно из репозитория ubuntu.
« Последнее редактирование: 20 Сентябрь 2017, 15:51:34 от Dzhoser »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13498
  • Xubuntu 18.04
    • Просмотр профиля
Простой юзер,
Для этой карты не надо ставить никаких драйверов.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Простой юзер

  • Автор темы
  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
Вот что пишет поддержка amd...

вы не там смотрите! надо смотреть здесь:   http://support.amd.com/en-us/download/desktop/legacy?product=Legacy2&os=Linux+x86_64

и читать я умею: поддержка пишет, что не будет новых драйверов, а мне на мой ПК надо поставить драйвер 2013 года

Пользователь добавил сообщение 20 Сентябрь 2017, 16:51:28:
Простой юзер,
... не надо ставить никаких драйверов.

и в упор не замечать сильно греющиеся без этого драйвера мосты?
у меня сейчас южный мост греется сильнее, чем с драйвером нагревался северный, так что имхо драйвер обязательно нужен

кто-нибудь может объяснить, как его установить?


п.с. я нашёл довольно толковую статью об установке этого драйвера  http://segaawakens.blogspot.com/2014/05/legacy-amd-radeon-ubuntu.html, но там всё упирается в пустую ссылку на пропатченные драйвера, которые надо установить
« Последнее редактирование: 20 Сентябрь 2017, 17:08:15 от Простой юзер »

Оффлайн werkty

  • Участник
  • *
  • Сообщений: 232
    • Просмотр профиля
кто-нибудь может объяснить, как его установить?


Говорю вам как давний пользователь амд (хотя и карта у меня поновее). Так вот -- никак. Или так https://www.opennet.ru/tips/2977_ubuntu_amd_driver_install_fglrx_amdgpu.shtml
« Последнее редактирование: 20 Сентябрь 2017, 17:06:48 от werkty »

Оффлайн Простой юзер

  • Автор темы
  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
увы, но указанный в статье драйвер для моей карты не подходит

да и с хоргом автор что-то намутил... мало что там понятно для простого юзера, но имхо автор выбрал не самый простой вариант решения вопроса
« Последнее редактирование: 20 Сентябрь 2017, 17:21:06 от Простой юзер »

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2101
    • Просмотр профиля
Простой юзер, Вы рассматриваете вариант обновления системы? Есть репозиторий с рвсширенной поддержкой видеокарт https://launchpad.net/~xorg-edgers/+archive/ubuntu/ppa

Оффлайн Простой юзер

  • Автор темы
  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
рассмотрю любые реальные варианты, как говорится "согласен на любую работу!")

Оффлайн Dzhoser

  • Старожил
  • *
  • Сообщений: 2101
    • Просмотр профиля
Простой юзер, ссылка на драйвер который вы прислали устанавливается так
1. Распаковываете архив;
2. Переходите в папку куда распаковали (например cd \home\user\driver)
3. Выполняете команду 
sudo chmod +x amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run 4. Выполняем команду
sudo ./amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run Запускается инсталятор следуем указаниям мастера настройки.

Оффлайн Простой юзер

  • Автор темы
  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
благодарю за совет, когда поставлю Ubuntu 10.04 (валяется у меня в загашнике такой диск), то так и сделаю  ;)
а с убунтой 14.04 есть проблема, обозначенная производителем:
Цитировать
Description:
Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4
- хорг до 1.12 и ядро до 3.4, а уже в убунте 12.04 стоит хорг 1.13
сейчас пытаюсь найти релиз убунты с хоргом 1.12 и буду апать ядро (если получится конечно)
а потом может и с хоргом что-то внятное найду

Оффлайн Простой юзер

  • Автор темы
  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
Простой юзер, ссылка на драйвер который вы прислали устанавливается так
1. Распаковываете архив;
2. Переходите в папку куда распаковали (например cd \home\user\driver)
3. Выполняете команду
sudo chmod +x amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run

поставил Ubuntu 10.04, скачал драйвер, распаковал его в папку home\vlad\Документы...
а дальше в упор не въеду, как в папке можно выполнить команду sudo ...

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1435
  • Ubuntu 16.04 LTS
    • Просмотр профиля
Простой юзер, у меня на ноуте HD3200 (RS780), если нужен fglrx, то устанавливаете 12.04 (НЕ 12.04.2, 12.04.3 и т.д. - эти не подходят), именно 12.04 (она идёт с ядром 3.2 и иксами версии 1.11), устанавливаете обновления, затем устанавливаете fglrx из репозитория без всяких плясок с бубнами. Графический стек и ядро от 12.04.2 и выше лучше не устанавливать, потому что с ними fglrx отвалится и не будет работать.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 2827
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 21.04
    • Просмотр профиля
Простой юзер, папка Документы - это плохая идея, лучше какая-нибудь папка типа AMD, а то из-за кириллицы может что-то пойти не так.

Через консоль по cd имя папки заходим в папку и выполняем вышеозначенную команду.
Я странен, а не странен кто ж? (С)

 

Страница сгенерирована за 0.157 секунд. Запросов: 23.