Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Не устанавливается mod wcgi на apache  (Прочитано 643 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн CraZZZy

  • Автор темы
  • Любитель
  • *
  • Сообщений: 71
    • Просмотр профиля
Не устанавливается mod wcgi на apache
« : 21 Сентябрь 2017, 19:01:36 »
Хочу установить модуль wcgi на свой apache, но возникает ошибка:
user@hostname ~ $ sudo apt-get install libapache2-mod-wsgi-py3
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libapache2-mod-wsgi-py3 : Зависит: apache2.2-common но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Почему пишет, что он зависит от apache2.2-common, когда apache у меня стоит 2.4?

Ubuntu 12.04 64bit
Python 3.4.5
Apache 2.4.12
sudo apt-get remove windows && sudo apt-get install linux

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27415
    • Просмотр профиля
Re: Не устанавливается mod wcgi на apache
« Ответ #1 : 21 Сентябрь 2017, 20:43:25 »
Вы апач установили из PPA, а модуль ставите родной.
Конечно ничего не встанет. Обновите уже систему, давно пора.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн CraZZZy

  • Автор темы
  • Любитель
  • *
  • Сообщений: 71
    • Просмотр профиля
Re: Не устанавливается mod wcgi на apache
« Ответ #2 : 21 Сентябрь 2017, 21:01:27 »
Вы апач установили из PPA, а модуль ставите родной.

Apache я ставил из репозитория ondrej/apache2, но пакета libapache2-mod-wsgi-py3 в нём нет. Где его можно взять?

Обновите уже систему, давно пора.

У меня VDS-хостинг, поэтому обновить Ubuntu проблематично.
« Последнее редактирование: 21 Сентябрь 2017, 21:19:41 от CraZZZy »
sudo apt-get remove windows && sudo apt-get install linux

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27415
    • Просмотр профиля
Re: Не устанавливается mod wcgi на apache
« Ответ #3 : 22 Сентябрь 2017, 18:04:51 »
Apache я ставил из репозитория ondrej/apache2
Именно.

обновить Ubuntu проблематично
Не лгите ни мне, ни себе.
VDS обновлятся так же, как и любой другой сервер.
Как самый последний вариант, всегда можно вайпнуть заказанный VDS и развернуть новую OS.
« Последнее редактирование: 22 Сентябрь 2017, 18:09:47 от AnrDaemon »
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн CraZZZy

  • Автор темы
  • Любитель
  • *
  • Сообщений: 71
    • Просмотр профиля
Re: Не устанавливается mod wcgi на apache
« Ответ #4 : 22 Сентябрь 2017, 18:36:48 »
VDS обновлятся так же, как и любой другой сервер.

Обновление версии дистрибутива влечёт обновление ядра. У меня виртуализация OpenVZ, ядро пещерное 2.6.32 (даже 14-я Ubuntu на нем скорее всего не заведётся), а в настройках хостинга отсутствует возможность изменить ядро. Сам хостинг мега-эконом за $2 в месяц, без какой-либо поддержки. Я конечно попробую написать им, но боюсь нужно будет новый сервер заказывать и с нуля настраивать текущее окружение, на что пока у меня нет достаточного времени.
sudo apt-get remove windows && sudo apt-get install linux

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27415
    • Просмотр профиля
Re: Не устанавливается mod wcgi на apache
« Ответ #5 : 22 Сентябрь 2017, 22:17:11 »
Забэкапить файлы одного пользователя и настройки одного виртуалхоста, вайпнуть сервер и вернуть всё вз… эээ, обратно - сложно?
А подключать PPA и настраивать сервер было несложно?
Ну, сидите, плакайте. Ничем не могу помочь.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.155 секунд. Запросов: 24.