Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Ошибка с установкой драйвера видеокарты АМД 8850м  (Прочитано 2395 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн psychomonkey

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Помогите пож убрать ошибку

admin@kirill:~$ sudo apt-get install playonlinux
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 libglamor-amdgpu-pro-dev:i386 : Зависит: xserver-xorg-video-glamoregl-amdgpu-pro:i386 (= 1.19.0-465504) но он не будет установлен
 playonlinux : Зависит: python-wxgtk2.8 но он не может быть установлен или
                               python-wxgtk3.0 но он не будет установлен
               Зависит: cabextract
               Зависит: icoutils
 rocm-amdgpu-pro : Зависит: rocm-amdgpu-pro-opencl но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
admin@kirill:~$ ^C
admin@kirill:~$ apt --fix-broken install
E: Не удалось открыть файл блокировки /var/lib/dpkg/lock - open (13: Отказано в доступе)
E: Не удалось выполнить блокировку управляющего каталога (/var/lib/dpkg/); у вас есть права суперпользователя?
admin@kirill:~$ sudo apt --fix-broken install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  rocm-amdgpu-pro-opencl xserver-xorg-video-glamoregl-amdgpu-pro:i386
НОВЫЕ пакеты, которые будут установлены:
  rocm-amdgpu-pro-opencl xserver-xorg-video-glamoregl-amdgpu-pro:i386
обновлено 0, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 6 пакетов не обновлено.
не установлено до конца или удалено 98 пакетов.
Необходимо скачать 0 B/20,3 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 71,6 MB.
Хотите продолжить? [Д/н] д
Пол:1 file:/var/opt/amdgpu-pro-local ./ xserver-xorg-video-glamoregl-amdgpu-pro 1.19.0-465504 [82,9 kB]
Пол:2 file:/var/opt/amdgpu-pro-local ./ rocm-amdgpu-pro-opencl 17.30-465504 [20,3 MB]
(Чтение базы данных … на данный момент установлено 218759 файлов и каталогов.)
Подготовка к распаковке …/xserver-xorg-video-glamoregl-amdgpu-pro_1.19.0-465504_i386.deb …
Распаковывается xserver-xorg-video-glamoregl-amdgpu-pro:i386 (1.19.0-465504) …
dpkg: ошибка при обработке архива /var/opt/amdgpu-pro-local/./xserver-xorg-video-glamoregl-amdgpu-pro_1.19.0-465504_i386.deb (--unpack):
 попытка перезаписать общий «/opt/amdgpu-pro/lib/xorg/modules/libglamoregl.so», который отличается от других экземпляров пакета xserver-xorg-video-glamoregl-amdgpu-pro:i386
Подготовка к распаковке …/rocm-amdgpu-pro-opencl_17.30-465504_amd64.deb …
Распаковывается rocm-amdgpu-pro-opencl:amd64 (17.30-465504) …
dpkg: ошибка при обработке архива /var/opt/amdgpu-pro-local/./rocm-amdgpu-pro-opencl_17.30-465504_amd64.deb (--unpack):
 попытка перезаписать «/opt/amdgpu-pro/bin/llvm-link», который уже имеется в пакете llvm-amdgpu-pro:i386 1:5.0-465504
dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)
При обработке следующих пакетов произошли ошибки:
 /var/opt/amdgpu-pro-local/./xserver-xorg-video-glamoregl-amdgpu-pro_1.19.0-465504_i386.deb
 /var/opt/amdgpu-pro-local/./rocm-amdgpu-pro-opencl_17.30-465504_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Последнее редактирование: 08 Октябрь 2017, 09:51:52 от psychomonkey »

Оффлайн Morisson

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 4588
    • Просмотр профиля
Re: Страшная ошибка
« Ответ #1 : 07 Октябрь 2017, 15:30:48 »
psychomonkey, sudo apt-get -f install

Оффлайн Morisson

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 4588
    • Просмотр профиля
Re: Страшная ошибка
« Ответ #2 : 07 Октябрь 2017, 15:31:14 »
И исправьте название темы на более информативное.

Оффлайн psychomonkey

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Страшная ошибка
« Ответ #3 : 07 Октябрь 2017, 15:32:06 »
$ sudo apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  rocm-amdgpu-pro-opencl xserver-xorg-video-glamoregl-amdgpu-pro:i386
НОВЫЕ пакеты, которые будут установлены:
  rocm-amdgpu-pro-opencl xserver-xorg-video-glamoregl-amdgpu-pro:i386
обновлено 0, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 6 пакетов не обновлено.
не установлено до конца или удалено 98 пакетов.
Необходимо скачать 0 B/20,3 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 71,6 MB.
Хотите продолжить? [Д/н] д
Пол:1 file:/var/opt/amdgpu-pro-local ./ xserver-xorg-video-glamoregl-amdgpu-pro 1.19.0-465504 [82,9 kB]
Пол:2 file:/var/opt/amdgpu-pro-local ./ rocm-amdgpu-pro-opencl 17.30-465504 [20,3 MB]
(Чтение базы данных … на данный момент установлено 218759 файлов и каталогов.)
Подготовка к распаковке …/xserver-xorg-video-glamoregl-amdgpu-pro_1.19.0-465504_i386.deb …
Распаковывается xserver-xorg-video-glamoregl-amdgpu-pro:i386 (1.19.0-465504) …
dpkg: ошибка при обработке архива /var/opt/amdgpu-pro-local/./xserver-xorg-video-glamoregl-amdgpu-pro_1.19.0-465504_i386.deb (--unpack):
 попытка перезаписать общий «/opt/amdgpu-pro/lib/xorg/modules/libglamoregl.so», который отличается от других экземпляров пакета xserver-xorg-video-glamoregl-amdgpu-pro:i386
Подготовка к распаковке …/rocm-amdgpu-pro-opencl_17.30-465504_amd64.deb …
Распаковывается rocm-amdgpu-pro-opencl:amd64 (17.30-465504) …
dpkg: ошибка при обработке архива /var/opt/amdgpu-pro-local/./rocm-amdgpu-pro-opencl_17.30-465504_amd64.deb (--unpack):
 попытка перезаписать «/opt/amdgpu-pro/bin/llvm-link», который уже имеется в пакете llvm-amdgpu-pro:i386 1:5.0-465504
dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)
При обработке следующих пакетов произошли ошибки:
 /var/opt/amdgpu-pro-local/./xserver-xorg-video-glamoregl-amdgpu-pro_1.19.0-465504_i386.deb
 /var/opt/amdgpu-pro-local/./rocm-amdgpu-pro-opencl_17.30-465504_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Последнее редактирование: 07 Октябрь 2017, 15:34:12 от psychomonkey »

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
При обработке следующих пакетов произошли ошибки:
 /var/opt/amdgpu-pro-local/./xserver-xorg-video-glamoregl-amdgpu-pro_1.19.0-465504_i386.deb
 /var/opt/amdgpu-pro-local/./rocm-amdgpu-pro-opencl_17.30-465504_amd64.deb
Судя по этому, вы нашли что то такое левое, что даже боюсь спросить , где вы это нашли ( по какому гайду ) ?

Оффлайн Morisson

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 4588
    • Просмотр профиля
psychomonkey, смени название темы на более информативное.

Оффлайн psychomonkey

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
При обработке следующих пакетов произошли ошибки:
 /var/opt/amdgpu-pro-local/./xserver-xorg-video-glamoregl-amdgpu-pro_1.19.0-465504_i386.deb
 /var/opt/amdgpu-pro-local/./rocm-amdgpu-pro-opencl_17.30-465504_amd64.deb
Судя по этому, вы нашли что то такое левое, что даже боюсь спросить , где вы это нашли ( по какому гайду ) ?
устанавливал драйвера на видеокарту
делал по гайду http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx
но по ходу оно ничего не установилось, а еще добавило конфликт какой то
еще отсюда пробовал http://help.ubuntu.ru/wiki/%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80_%D0%B2%D0%B8%D0%B4%D0%B5%D0%BE%D0%BA%D0%B0%D1%80%D1%82_nvidia
как это исправить можно?

psychomonkey, смени название темы на более информативное.
я хз как назвать поточнее) помоги с названием пож.


Пользователь добавил сообщение 07 Октябрь 2017, 18:15:22:
может удалить amdgpu-pro?
« Последнее редактирование: 07 Октябрь 2017, 18:19:08 от psychomonkey »

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
psychomonkey, a что  за видюха?
dpkg --audit


Оффлайн psychomonkey

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Решил обратно поставить 16.04, но проблема с видеокартой осталась
lspci -nn | grep -E 'VGA|Display'
00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09)
03:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Venus PRO [Radeon HD 8850M / R9 M265X] [1002:6823] (rev ff)

поприетарный драйвер не используется, если делать по инструкции с амд, то вылазит побочка
$ ./amdgpu-pro-install –y
deb [ trusted=yes ] file:/var/opt/amdgpu-pro-local/ ./
Пол:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Игн:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Пол:2 file:/var/opt/amdgpu-pro-local ./ Release [814 B]
Сущ:3 http://ua.archive.ubuntu.com/ubuntu xenial InRelease
Пол:4 http://ua.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Пол:2 file:/var/opt/amdgpu-pro-local ./ Release [814 B]                       
Пол:5 file:/var/opt/amdgpu-pro-local ./ Release.gpg                           
Игн:5 file:/var/opt/amdgpu-pro-local ./ Release.gpg                           
Пол:6 file:/var/opt/amdgpu-pro-local ./ Packages [72,4 kB]                     
Пол:7 http://ua.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB] 
Пол:8 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Получено 306 kБ за 1с (257 kБ/c)         
Чтение списков пакетов… Готово
E: Неверная операция –y
kirill@pc:~/Загрузки/amdgpu-pro-17.30-465504$ ./amdgpu-pro-install
Сущ:1 http://ua.archive.ubuntu.com/ubuntu xenial InRelease
Пол:2 http://ua.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Пол:3 http://ua.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB] 
Пол:4 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]     
Получено 306 kБ за 0с (945 kБ/c)                                   
Чтение списков пакетов… Готово
deb [ trusted=yes ] file:/var/opt/amdgpu-pro-local/ ./
Пол:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Игн:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Пол:2 file:/var/opt/amdgpu-pro-local ./ Release [814 B]
Пол:2 file:/var/opt/amdgpu-pro-local ./ Release [814 B]
Пол:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg                           
Игн:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg                           
Пол:4 file:/var/opt/amdgpu-pro-local ./ Packages [72,4 kB]                     
Сущ:5 http://ua.archive.ubuntu.com/ubuntu xenial InRelease                     
Пол:6 http://ua.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]   
Пол:7 http://ua.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB] 
Пол:8 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]     
Получено 306 kБ за 0с (899 kБ/c)                                   
Чтение списков пакетов… Готово
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 amdgpu-pro : Зависит: libdrm-amdgpu-pro-amdgpu1 (= 1:2.4.70-465504) но он не будет установлен
              Зависит: libgbm1-amdgpu-pro-base (= 17.30-465504) но он не будет установлен
              Зависит: libgbm1-amdgpu-pro (= 17.30-465504) но он не будет установлен
              Зависит: libgl1-amdgpu-pro-appprofiles (= 17.30-465504) но он не будет установлен
              Зависит: libgl1-amdgpu-pro-glx (= 17.30-465504) но он не будет установлен
              Зависит: libgl1-amdgpu-pro-ext (= 17.30-465504) но он не будет установлен
              Зависит: libgl1-amdgpu-pro-dri (= 17.30-465504) но он не будет установлен
              Зависит: libegl1-amdgpu-pro (= 17.30-465504) но он не будет установлен
              Зависит: libgles2-amdgpu-pro (= 17.30-465504) но он не будет установлен
              Зависит: libopencl1-amdgpu-pro (= 17.30-465504) но он не будет установлен
              Зависит: clinfo-amdgpu-pro (= 17.30-465504) но он не будет установлен
              Зависит: opencl-amdgpu-pro-icd (= 17.30-465504) но он не будет установлен
              Зависит: vulkan-amdgpu-pro (= 17.30-465504) но он не будет установлен
              Зависит: libvdpau-amdgpu-pro (= 1:17.0.1-465504) но он не будет установлен
              Зависит: xserver-xorg-video-glamoregl-amdgpu-pro (= 1.19.0-465504) но он не будет установлен
              Зависит: xserver-xorg-video-amdgpu-pro (= 1:1.3.99-465504) но он не будет установлен
 amdgpu-pro-dkms : Зависит: dkms (>= 1.95) но он не будет установлен
                   Зависит: amdgpu-pro-core но он не будет установлен
 amdgpu-pro-lib32 : Зависит: libdrm-amdgpu-pro-amdgpu1:i386 (= 1:2.4.70-465504)
                    Зависит: libgbm1-amdgpu-pro:i386 (= 17.30-465504)
                    Зависит: libgl1-amdgpu-pro-glx:i386 (= 17.30-465504)
                    Зависит: libgl1-amdgpu-pro-dri:i386 (= 17.30-465504)
                    Зависит: libegl1-amdgpu-pro:i386 (= 17.30-465504)
                    Зависит: libgles2-amdgpu-pro:i386 (= 17.30-465504)
                    Зависит: vulkan-amdgpu-pro:i386 (= 17.30-465504)
                    Зависит: libvdpau-amdgpu-pro:i386 (= 1:17.0.1-465504)
                    Зависит: libopencl1-amdgpu-pro:i386 (= 17.30-465504)
                    Зависит: opencl-amdgpu-pro-icd:i386 (= 17.30-465504)
 fglrx : Зависит: fglrx-core но он не может быть установлен
         Рекомендует: fglrx-amdcccle но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

Оффлайн DimanBG

  • Старожил
  • *
  • Сообщений: 1297
    • Просмотр профиля
Правильно ошибки будут, потому что карта работает с radeon, а не с amdgpu и тем более с нашлёпкой pro.
Ей нужен fglrx. Причем очень желательно. Иначе она на свободном драйвере чуть быстрее встроенной в Haswell.
Профит только от собственной памяти, и то если уж ОЗУ мало и внешний большой экран с высоким разрешением подключается.
Инструкции, как установить fglrx в 16.04 и дальше, и ей подобные в сети есть.   

 

Страница сгенерирована за 0.311 секунд. Запросов: 24.