Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Крах пакетного менеджера после операций с smb  (Прочитано 1190 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sammy-el

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
День добрый!

Случилась беда, пытались добавить в smb пользователя, и что то пошло не так, сейчас любые движения с apt-get приводят к

sudo apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
The following additional packages will be installed:
  python-pip python-samba
Рекомендуемые пакеты:
  python-all-dev
Пакеты, которые будут обновлены:
  python-pip python-samba
обновлено 2, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 250 пакетов не обновлено.
не установлено до конца или удалено 51 пакетов.
Необходимо скачать 0 B/1 646 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 5 120 B.
Хотите продолжить? [Д/н] y
Настраивается пакет dpkg (1.18.4ubuntu1.2) …
Обрабатываются триггеры для man-db (2.7.5-1) …
(Чтение базы данных … на данный момент установлено 225332 файла и каталога.)
Подготовка к распаковке …/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Подготовка к распаковке …/python-pip_8.1.1-2ubuntu0.4_all.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-pip_8.1.1-2ubuntu0.4_all.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb
 /var/cache/apt/archives/python-pip_8.1.1-2ubuntu0.4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

даже не знаю с чего начать что бы исправить положение. smb не работает совсем , сломался webmin, не понятно вообще что происходит.
Спасибо и за шутки и за помощь.

Переименовал тему.
--toZen
« Последнее редактирование: 31 Октябрь 2017, 10:42:48 от τοΖεη »

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: Не знаю как описать проблему, все плохо (
« Ответ #1 : 31 Октябрь 2017, 08:42:58 »
Для начала -
sudo apt install -f вывод показать здесь.

Оффлайн sammy-el

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: Не знаю как описать проблему, все плохо (
« Ответ #2 : 31 Октябрь 2017, 09:03:27 »
По моему это одно и тоже

sudo apt install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
The following additional packages will be installed:
  python-pip python-samba
Рекомендуемые пакеты:
  python-all-dev
Пакеты, которые будут обновлены:
  python-pip python-samba
обновлено 2, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 250 пакетов не обновлено.
не установлено до конца или удалено 50 пакетов.
Необходимо скачать 0 B/1 646 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 5 120 B.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 225332 файла и каталога.)
Подготовка к распаковке …/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Подготовка к распаковке …/python-pip_8.1.1-2ubuntu0.4_all.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-pip_8.1.1-2ubuntu0.4_all.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb
 /var/cache/apt/archives/python-pip_8.1.1-2ubuntu0.4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Последнее редактирование: 31 Октябрь 2017, 09:17:08 от sammy-el »

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6015
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
Re: Не знаю как описать проблему, все плохо (
« Ответ #3 : 31 Октябрь 2017, 09:30:43 »
250 пакетов не обновлено
Сначала стоило всё-таки обновится… Выполняетеsudo apt purge -f
sudo apt update
sudo apt dist-upgrade
После этого скорее всего потребуется перезагрузка. Потом ставите что надо.
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн sammy-el

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: Крах пакетного менеджера после операций с smb
« Ответ #4 : 31 Октябрь 2017, 11:25:24 »
После проведения всех манипуляций, они просто не хотят ставиться, я это уже наблюдал, вот так по чуть чуть идут.

sudo apt install -f     
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
The following additional packages will be installed:
  python-pip python-samba
Рекомендуемые пакеты:
  python-all-dev
Пакеты, которые будут обновлены:
  python-pip python-samba
обновлено 2, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 188 пакетов не обновлено.
не установлено до конца или удалено 95 пакетов.
Необходимо скачать 0 B/1 646 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 5 120 B.
Хотите продолжить? [Д/н] y
Настраивается пакет coreutils (8.25-2ubuntu3~16.04) …
(Чтение базы данных … на данный момент установлено 225296 файлов и каталогов.)
Подготовка к распаковке …/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Подготовка к распаковке …/python-pip_8.1.1-2ubuntu0.4_all.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-pip_8.1.1-2ubuntu0.4_all.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb
 /var/cache/apt/archives/python-pip_8.1.1-2ubuntu0.4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


sudo apt purge -f     
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
The following additional packages will be installed:
  python-pip python-samba
Рекомендуемые пакеты:
  python-all-dev
Пакеты, которые будут обновлены:
  python-pip python-samba
обновлено 2, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 188 пакетов не обновлено.
не установлено до конца или удалено 94 пакетов.
Необходимо скачать 0 B/1 646 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 5 120 B.
Хотите продолжить? [Д/н] y
(Чтение базы данных … на данный момент установлено 225296 файлов и каталогов.)
Подготовка к распаковке …/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Подготовка к распаковке …/python-pip_8.1.1-2ubuntu0.4_all.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-pip_8.1.1-2ubuntu0.4_all.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb
 /var/cache/apt/archives/python-pip_8.1.1-2ubuntu0.4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
sudo apt update
Get:1 http://ru.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Get:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]                     
Hit:3 http://ru.archive.ubuntu.com/ubuntu xenial-updates InRelease                                   
Hit:4 http://ru.archive.ubuntu.com/ubuntu xenial-backports InRelease                                 
Получено 349 kБ за 0с (429 kБ/c)                                                                     
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Может быть обновлено 190 пакетов. Запустите «apt list --upgradable» для их показа.
sudo apt dist-upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
  libmircommon5
Для его удаления используйте «sudo apt autoremove».
НОВЫЕ пакеты, которые будут установлены:
  libcapnp-0.5.3 libevent-core-2.0-5 libllvm4.0 libmircommon7 libmircore1 linux-headers-4.4.0-98
  linux-headers-4.4.0-98-generic linux-image-4.4.0-98-generic linux-image-extra-4.4.0-98-generic
Пакеты, которые будут обновлены:
  accountsservice apache2 apache2-bin apache2-data apache2-utils apparmor apt apt-transport-https apt-utils bind9-host
  binutils cifs-utils console-setup console-setup-linux curl distro-info-data dnsutils dpkg-dev eject git git-man gnupg
  gpgv grub-common grub-pc grub-pc-bin grub2-common htop humanity-icon-theme init isc-dhcp-client isc-dhcp-common kbd
  keyboard-configuration krb5-locales less lib32z1 libaccountsservice0 libapache2-mod-php7.0 libapparmor-perl
  libarchive13 libbind9-140 libc-bin libcurl3 libcurl3-gnutls libdbd-mysql-perl libdns-export162 libdns162 libdpkg-perl
  libdrm-amdgpu1 libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libegl1-mesa libepoxy0 libevent-2.0-5 libfdisk1
  libfreetype6 libgbm1 libgc1c2 libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgl1-mesa-dri libgl1-mesa-glx
  libglapi-mesa libglib2.0-0 libglib2.0-data libgraphite2-3 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common libharfbuzz0b libhdb9-heimdal libirs141 libisc-export160 libisc160 libisccc140
  libisccfg140 libjasper1 libjs-sphinxdoc libkdc2-heimdal libllvm3.8 liblwres141 libmirclient9 libmirprotobuf3
  libmysqlclient-dev libmysqlclient20 libnl-3-200 libnl-genl-3-200 libnm0 libnma-common libnma0 libnspr4 libnss3
  libnss3-nssdb libpci3 libpcsclite1 libplymouth4 libpulse0 libpython3.5 libpython3.5-dev libpython3.5-minimal
  libpython3.5-stdlib librtmp1 libruby2.3 libsane libsane-common libsmartcols1 libsndfile1 libsoup-gnome2.4-1
  libsoup2.4-1 libssh2-1 libtiff5 libwayland-client0 libwayland-cursor0 libwayland-egl1-mesa libwayland-server0 libxpm4
  linux-firmware linux-generic linux-headers-generic linux-image-generic linux-libc-dev locales login logrotate lshw
  makedev multiarch-support mysql-client mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server
  mysql-server-5.7 mysql-server-core-5.7 nano ntfs-3g ntp openjdk-8-jre-headless openssh-client openssh-server
  openssh-sftp-server os-prober p11-kit pciutils php7.0-cli php7.0-common php7.0-gd php7.0-json php7.0-mbstring
  php7.0-mcrypt php7.0-mysql php7.0-opcache php7.0-readline php7.0-snmp php7.0-xml plymouth python-crypto
  python-cryptography python-pip python-samba python3.5 python3.5-dev python3.5-minimal resolvconf ruby2.3 sudo tar
  tcpdump tftpd-hpa tzdata ubuntu-mono uuid-runtime vim vim-common vim-gtk vim-gui-common vim-runtime vim-tiny vlan w3m
  wget wpasupplicant zabbix-agent
обновлено 190, установлено 9 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 94 пакетов.
Необходимо скачать 0 B/296 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 436 MB.
Хотите продолжить? [Д/н] y
Извлечение шаблонов из пакетов: 100%
Предварительная настройка пакетов ...
(Чтение базы данных … на данный момент установлено 225296 файлов и каталогов.)
Подготовка к распаковке …/python-crypto_2.6.1-6ubuntu0.16.04.2_amd64.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-crypto_2.6.1-6ubuntu0.16.04.2_amd64.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Подготовка к распаковке …/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Подготовка к распаковке …/python-cryptography_1.2.3-1ubuntu0.1_amd64.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-cryptography_1.2.3-1ubuntu0.1_amd64.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Подготовка к распаковке …/python-pip_8.1.1-2ubuntu0.4_all.deb …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 1
dpkg: попытка использовать сценарий из нового пакета …
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: ошибка при обработке архива /var/cache/apt/archives/python-pip_8.1.1-2ubuntu0.4_all.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Подготовка к распаковке …/init_1.29ubuntu4_amd64.deb …
Распаковывается init (1.29ubuntu4) на замену (1.29ubuntu3) …
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/python-crypto_2.6.1-6ubuntu0.16.04.2_amd64.deb
 /var/cache/apt/archives/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb
 /var/cache/apt/archives/python-cryptography_1.2.3-1ubuntu0.1_amd64.deb
 /var/cache/apt/archives/python-pip_8.1.1-2ubuntu0.4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Последнее редактирование: 31 Октябрь 2017, 11:43:25 от sammy-el »

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: Крах пакетного менеджера после операций с smb
« Ответ #5 : 31 Октябрь 2017, 11:51:21 »
Удалить архив пакетов
sudo apt clean  повторить sudo apt update

Оффлайн archuser

  • Активист
  • *
  • Сообщений: 588
    • Просмотр профиля
Re: Крах пакетного менеджера после операций с smb
« Ответ #6 : 31 Октябрь 2017, 12:04:48 »
Судя по ошибкам у Вас что-то с python.
File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
Данный синтаксис применим для python версии < 3.0. Обработка исключений для версии python 3.0+ производится следующей синтаксической конструкцией:
except (IOError, OSError) as e:
Проверьте, какая версия интерпретатора у Вас стоит по умолчанию. Для этого в терминале выполните:
python -VЕсли 3.* то измените по дефолту на версию 2.*.

Оффлайн svtv1

  • Забанен
  • Старожил
  • *
  • Сообщений: 2652
  • Это Я
    • Просмотр профиля
Re: Крах пакетного менеджера после операций с smb
« Ответ #7 : 31 Октябрь 2017, 12:15:47 »
Может так
sudo apt python-all-dev
sudo apt update
sudo apt dist-upgrade
или
sudo apt --fix-broken install
sudo rm /var/lib/apt/lists/* -vf
sudo apt clean
sudo apt update
"Если достаточно долго сидеть возле реки - мимо проплывет труп твоего врага"

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6015
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
Re: Крах пакетного менеджера после операций с smb
« Ответ #8 : 31 Октябрь 2017, 12:17:49 »
sudo apt purge -f     
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
The following additional packages will be installed:
  python-pip python-samba
Все страньше и страньше… Давайте через dpkgsudo dpkg -P --force-remove-reinstreq python-pip python-samba
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн sammy-el

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: Крах пакетного менеджера после операций с smb
« Ответ #9 : 31 Октябрь 2017, 12:44:47 »
Спасибо огромное всем, стоял не тот пайтон по умолчанию, все заработало, ура товарищи! УРА!

 

Страница сгенерирована за 0.292 секунд. Запросов: 22.