Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: gnome-terminal  (Прочитано 1911 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mrgood

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
gnome-terminal
« : 10 Декабрь 2017, 17:12:04 »
Всем привет , после каких-то моих манипуляций перестал открываться терминал , в xterm пишет вот  что , помогите ,пожалуйста .


mrgood@mrgood-HP-Pavilion-Notebook:~$ gnome-terminal
Traceback (most recent call last):
  File "/usr/bin/gnome-terminal", line 9, in <module>
    from gi.repository import GLib, Gio
  File "/usr/lib/python3/dist-packages/gi/__init__.py", line 42, in <module>
    from . import _gi
ImportError: cannot import name '_gi'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 63, in apport_excepthook
    from apport.fileutils import likely_packaged, get_recent_crashes
  File "/usr/lib/python3/dist-packages/apport/__init__.py", line 5, in <module>
    from apport.report import Report
  File "/usr/lib/python3/dist-packages/apport/report.py", line 30, in <module>
    import apport.fileutils
  File "/usr/lib/python3/dist-packages/apport/fileutils.py", line 23, in <module>
    from apport.packaging_impl import impl as packaging
  File "/usr/lib/python3/dist-packages/apport/packaging_impl.py", line 23, in <module>
    import apt
  File "/usr/lib/python3/dist-packages/apt/__init__.py", line 23, in <module>
    import apt_pkg
ModuleNotFoundError: No module named 'apt_pkg'

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/gnome-terminal", line 9, in <module>
    from gi.repository import GLib, Gio
  File "/usr/lib/python3/dist-packages/gi/__init__.py", line 42, in <module>
    from . import _gi
ImportError: cannot import name '_gi'

ТС не появлялся на Форуме более полугода по состоянию на 17/07/2019 (последняя явка: 27/04/2018). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 17 Июль 2019, 09:10:26 от zg_nico »

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3276
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: gnome-terminal
« Ответ #1 : 10 Декабрь 2017, 17:14:42 »
Всем привет , после каких-то моих манипуляций перестал открываться терминал , в xterm пишет вот  что , помогите ,пожалуйста .
Сначала изображение добавьте нормально. А еще лучше просто текст в сообщение
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн mrgood

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: gnome-terminal
« Ответ #2 : 10 Декабрь 2017, 17:15:51 »
Всем привет , после каких-то моих манипуляций перестал открываться терминал , в xterm пишет вот  что , помогите ,пожалуйста .
Сначала изображение добавьте нормально. А еще лучше просто текст в сообщение

Сейчас нормально ? Скопировать из xterm не получается

Оффлайн kmk

  • Активист
  • *
  • Сообщений: 544
    • Просмотр профиля
Re: gnome-terminal
« Ответ #3 : 10 Декабрь 2017, 17:18:09 »
после каких-то моих манипуляций перестал открываться терминал
Вы его не удалили случайно? Смотрим:
dpkg -l | grep gnome-terminal
(Нажмите, чтобы показать/скрыть)

(ii - установлен)

Оффлайн mrgood

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: gnome-terminal
« Ответ #4 : 10 Декабрь 2017, 17:22:56 »
после каких-то моих манипуляций перестал открываться терминал
Вы его не удалили случайно? Смотрим:
dpkg -l | grep gnome-terminal
(Нажмите, чтобы показать/скрыть)

(ii - установлен)

mrgood@mrgood-HP-Pavilion-Notebook:~$ dpkg -l | grep gnome-terminal
ii  gnome-terminal                              3.18.3-1ubuntu1                              amd64        GNOME terminal emulator application
ii  gnome-terminal-data                         3.18.3-1ubuntu1                              all          Data files for the GNOME terminal emulator

Пользователь добавил сообщение 10 Декабрь 2017, 17:24:37:
Всем привет , после каких-то моих манипуляций перестал открываться терминал , в xterm пишет вот  что , помогите ,пожалуйста .
Сначала изображение добавьте нормально. А еще лучше просто текст в сообщение



поправил
« Последнее редактирование: 10 Декабрь 2017, 17:24:37 от mrgood »

Оффлайн kmk

  • Активист
  • *
  • Сообщений: 544
    • Просмотр профиля
Re: gnome-terminal
« Ответ #5 : 10 Декабрь 2017, 17:34:53 »
/usr/lib/python3
А почему у вас python3? Случайно не меняли дефолтный Python 2.7.12 на Python третий? Этим можно многие программы порушить.

Оффлайн mrgood

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: gnome-terminal
« Ответ #6 : 10 Декабрь 2017, 17:35:59 »
/usr/lib/python3
А почему у вас python3? Случайно не меняли дефолтный Python 2.7.12 на Python третий? Этим можно многие программы порушить.

стоял дефолтный 3.5 , хотел вместо него 3.6 поставить

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3276
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: gnome-terminal
« Ответ #7 : 10 Декабрь 2017, 17:42:57 »
mrgood, с чем вас и поздравляем. Теперь осталось поустановливать все необходимые модули Python или откатываться к 3.5
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн mrgood

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: gnome-terminal
« Ответ #8 : 10 Декабрь 2017, 17:44:16 »
mrgood, с чем вас и поздравляем. Теперь осталось поустановливать все необходимые модули Python или откатываться к 3.5

А какие модули нужны или как откатиться ?

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3276
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: gnome-terminal
« Ответ #9 : 10 Декабрь 2017, 18:44:47 »
mrgood, во первых убрать репозиторий для 3.6. И поставить 3.5 (какие там еще библиотеки надо - у меня не Unity/Gnome потому и не знаю)
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн svtv1

  • Забанен
  • Старожил
  • *
  • Сообщений: 2652
  • Это Я
    • Просмотр профиля
Re: gnome-terminal
« Ответ #10 : 10 Декабрь 2017, 20:21:43 »
$ python --version
Python 2.7.14+
$ gnome-terminal
Вот
(Нажмите, чтобы показать/скрыть)
Переустановить пробовал?


« Последнее редактирование: 10 Декабрь 2017, 20:24:14 от svtv1 »
"Если достаточно долго сидеть возле реки - мимо проплывет труп твоего врага"

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Re: gnome-terminal
« Ответ #11 : 10 Декабрь 2017, 20:40:28 »
ls -l /usr/bin/python*?

Оффлайн svtv1

  • Забанен
  • Старожил
  • *
  • Сообщений: 2652
  • Это Я
    • Просмотр профиля
Re: gnome-terminal
« Ответ #12 : 10 Декабрь 2017, 21:11:30 »
Да еще, тебя же теминал из Х-ов не откроется.
Войди в консоль Apt-Ctrl-F1, выполни
sudo apt update
он тебе предложит или sudo apt autoremove или sudo apt -f install
Выполни, потом
sudo apt-get install --reinstall gnome-terminal
Ну а потом снова в Х-ы и пробуй.

"Если достаточно долго сидеть возле реки - мимо проплывет труп твоего врага"

Оффлайн mrgood

  • Автор темы
  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: gnome-terminal
« Ответ #13 : 10 Декабрь 2017, 23:09:54 »
Да еще, тебя же теминал из Х-ов не откроется.
Войди в консоль Apt-Ctrl-F1, выполни
sudo apt update
он тебе предложит или sudo apt autoremove или sudo apt -f install
Выполни, потом
sudo apt-get install --reinstall gnome-terminal
Ну а потом снова в Х-ы и пробуй.

mrgood@mrgood-HP-Pavilion-Notebook:~$ python --version
Python 2.7.12
mrgood@mrgood-HP-Pavilion-Notebook:~$ gnome-terminal
Traceback (most recent call last):
  File "/usr/bin/gnome-terminal", line 9, in <module>
    from gi.repository import GLib, Gio
  File "/usr/lib/python3/dist-packages/gi/__init__.py", line 42, in <module>
    from . import _gi
ImportError: cannot import name '_gi'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 63, in apport_excepthook
    from apport.fileutils import likely_packaged, get_recent_crashes
  File "/usr/lib/python3/dist-packages/apport/__init__.py", line 5, in <module>
    from apport.report import Report
  File "/usr/lib/python3/dist-packages/apport/report.py", line 30, in <module>
    import apport.fileutils
  File "/usr/lib/python3/dist-packages/apport/fileutils.py", line 23, in <module>
    from apport.packaging_impl import impl as packaging
  File "/usr/lib/python3/dist-packages/apport/packaging_impl.py", line 23, in <module>
    import apt
  File "/usr/lib/python3/dist-packages/apt/__init__.py", line 23, in <module>
    import apt_pkg
ModuleNotFoundError: No module named 'apt_pkg'

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/gnome-terminal", line 9, in <module>
    from gi.repository import GLib, Gio
  File "/usr/lib/python3/dist-packages/gi/__init__.py", line 42, in <module>
    from . import _gi
ImportError: cannot import name '_gi'

вот что было после

Пользователь добавил сообщение 10 Декабрь 2017, 23:10:41:
ls -l /usr/bin/python*?


mrgood@mrgood-HP-Pavilion-Notebook:~$ ls -l /usr/bin/python*
lrwxrwxrwx 1 root root       9 ноя 24 00:18 /usr/bin/python -> python2.7
lrwxrwxrwx 1 root root       9 ноя 24 00:18 /usr/bin/python2 -> python2.7
-rwxr-xr-x 1 root root 3542008 ноя 23 20:08 /usr/bin/python2.7
lrwxrwxrwx 1 root root      33 ноя 23 20:08 /usr/bin/python2.7-config -> x86_64-linux-gnu-python2.7-config
lrwxrwxrwx 1 root root      16 дек 10  2015 /usr/bin/python2-config -> python2.7-config
lrwxrwxrwx 1 root root      25 дек  6 21:03 /usr/bin/python3 -> /etc/alternatives/python3
-rwxr-xr-x 2 root root 4464400 ноя 28 19:53 /usr/bin/python3.5
lrwxrwxrwx 1 root root      33 ноя 28 19:53 /usr/bin/python3.5-config -> x86_64-linux-gnu-python3.5-config
-rwxr-xr-x 2 root root 4464400 ноя 28 19:53 /usr/bin/python3.5m
lrwxrwxrwx 1 root root      34 ноя 28 19:53 /usr/bin/python3.5m-config -> x86_64-linux-gnu-python3.5m-config
-rwxr-xr-x 2 root root 4519936 окт  6 14:53 /usr/bin/python3.6
-rwxr-xr-x 2 root root 4519936 окт  6 14:53 /usr/bin/python3.6m
lrwxrwxrwx 1 root root      16 мар 23  2016 /usr/bin/python3-config -> python3.5-config
lrwxrwxrwx 1 root root      10 ноя 24 00:18 /usr/bin/python3m -> python3.5m
lrwxrwxrwx 1 root root      17 мар 23  2016 /usr/bin/python3m-config -> python3.5m-config
lrwxrwxrwx 1 root root      16 дек 10  2015 /usr/bin/python-config -> python2.7-config

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3276
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: gnome-terminal
« Ответ #14 : 10 Декабрь 2017, 23:16:25 »
mrgood,
Код: Bash
  1. sudo rm /usr/bin/python3
  2. sudo ln -s /usr/bin/python3.5 /usr/bin/python3
  3.  
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

 

Страница сгенерирована за 0.377 секунд. Запросов: 22.