Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Ошибка apt-get (tigervncserver, xtigervncviewer)  (Прочитано 501 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн stixia007

  • Автор темы
  • Участник
  • *
  • Сообщений: 148
    • Просмотр профиля
Ошибка apt-get (tigervncserver, xtigervncviewer)
« : 13 Декабрь 2017, 15:12:28 »
После манипуляций:
$ wget https://ruvds.com/downloads/tightvnc-packages.tar
$ tar -xvf tightvnc-packages.tar
$ cd ./tightvnc-packages
$ dpkg -i *.deb || (apt -f install -y ; dpkg -i *.deb)

Поломался apt-get, как восстановить? :)
Ошибка снизу. На любой пакет установочный жалуется:

root@ubuntu1604x64:~# apt-get install htop
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 fltk1.3-games : Depends: libjpeg62-turbo (>= 1.3.1) but it is not installable
 libfltk-images1.3 : Depends: libjpeg62-turbo (>= 1.3.1) but it is not installable
 libfltk1.3-dev : Depends: libx11-dev but it is not going to be installed
                  Recommends: libgl1-mesa-dev but it is not going to be installed or
                              libgl-dev
                  Recommends: libglu1-mesa-dev but it is not going to be installed or
                              libglu-dev
 tigervncserver : Depends: libgnutls-deb0-28 but it is not installable
                  Depends: libjpeg62-turbo but it is not installable
                  Depends: libtasn1-3-bin but it is not going to be installed
                  Depends: libglu1-mesa but it is not going to be installed
 xtigervncviewer : Depends: libgnutls-deb0-28 but it is not installable
                   Depends: libjpeg62-turbo but it is not installable
                   Depends: libtasn1-3-bin but it is not going to be installed
                   Depends: libglu1-mesa but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: Ошибка apt-get (tigervncserver, xtigervncviewer)
« Ответ #1 : 13 Декабрь 2017, 15:30:22 »
Try 'apt-get -f install'
Вот что предлагается.

Оффлайн stixia007

  • Автор темы
  • Участник
  • *
  • Сообщений: 148
    • Просмотр профиля
Re: Ошибка apt-get (tigervncserver, xtigervncviewer)
« Ответ #2 : 13 Декабрь 2017, 15:39:02 »
Try 'apt-get -f install'
Вот что предлагается.
Спасибо что помогаете таким тупым как я.

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: Ошибка apt-get (tigervncserver, xtigervncviewer)
« Ответ #3 : 13 Декабрь 2017, 15:54:15 »
И что? Помогло? Вывод команды покажете?

 

Страница сгенерирована за 0.125 секунд. Запросов: 24.