Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Не работает WiFi. Realtek RTL8723DE [10ec:d723]  (Прочитано 7090 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DenisLopin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Не работает WiFi. Realtek RTL8723DE [10ec:d723]
« : 18 Декабрь 2017, 07:42:20 »
День назад приобрел ноутбук в подарок для сестры, т.к. ноут был без ОС, а цена на Windows не маленькая (8,5К рублей для студентки это очень дорого) было решено поставить Ubuntu. Установил 16.04, всё заработало из коробки кроме WiFi и bluetooth. Это мой первый опыт использования Ubuntu. Немного погуглив решение проблемы не нашел, очень много всяких консольных команд и я немного в растерялся.

$ lspci -knn | grep "Eth\|Net" -A2
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
DeviceName: Hanksville Gbe Lan Connection
Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:8328]
Kernel driver in use: r8169
Kernel modules: r8169
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:d723]
DeviceName: WLAN
Subsystem: Hewlett-Packard Company Device [103c:8319]

Что делать дальше даже не представляю.
« Последнее редактирование: 19 Декабрь 2017, 10:54:15 от DenisLopin »

Онлайн zg_nico

  • Заслуженный пользователь
  • Активист
  • *
  • Сообщений: 991
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #1 : 18 Декабрь 2017, 08:16:28 »
Попробовать в live-режиме ubuntu 17.04, 17.10
Если какая-то из систем соответствующий драйвер подтянула, и wifi и bluetooth завелись, то далее два варианта:
1. её и ставим, и пусть стоит себе вплоть до стабильного релиза 18.04
2. записываем себе версию ядра, на которой в live-дистрибутиве всё ожило. Версия узнается командой
uname -r
далее ищем варианты установки этого ядра в уже установленную на диск Ubuntu 16.04.
---
А вообще - Вы уверены что wifi и bluetooth не работают? В выхлопе, который Вы привели что-то по поводу WLAN есть...
Покажите:
ifconfiglsusb
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], Ubuntu 18.04 64x [KDE, Budgie].

Оффлайн viktor ne perestukin

  • Активист
  • *
  • Сообщений: 429
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #2 : 18 Декабрь 2017, 08:33:51 »
zg_nico, Определение чипа RTL8723DE есть, драйвера нет.

Оффлайн DenisLopin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #3 : 18 Декабрь 2017, 08:43:40 »
zg_nico,
$ ifconfig
eno1      Link encap:Ethernet  HWaddr ac:e2:d3:76:d3:4f 
          inet addr:192.168.1.72  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::8027:b5f8:c305:d55e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1030 errors:0 dropped:0 overruns:0 frame:0
          TX packets:653 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:577804 (577.8 KB)  TX bytes:78883 (78.8 KB)

lo        Link encap:Локальная петля (Loopback) 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:344 errors:0 dropped:0 overruns:0 frame:0
          TX packets:344 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:28302 (28.3 KB)  TX bytes:28302 (28.3 KB)

$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0bda:58ed Realtek Semiconductor Corp.
Bus 001 Device 002: ID 0bda:b009 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Доступно только проводное подключение. Не видит другие WiFi сети. Пытался прописать настройки домашнего, а теперь рабочего, роутера вручную, но это ничего не дало. Тоже самое с Bluetooth ползунок в настройках переведен в положение "вкл.", но никаких устройств не обнаруживает.

Оффлайн viktor ne perestukin

  • Активист
  • *
  • Сообщений: 429
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #4 : 18 Декабрь 2017, 09:04:10 »
Здесь ребята тоже сетуют https://github.com/lwfinger/rtlwifi_new/issues/267
Вроде надо ждать лучших времен

Онлайн zg_nico

  • Заслуженный пользователь
  • Активист
  • *
  • Сообщений: 991
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #5 : 18 Декабрь 2017, 09:32:59 »
DenisLopin, грустно. И всё же попробуйте более свежие версии системы. Если "взлетит", - подскажите. Расскажу как ядро на 16.04 накатить (была там одна софтина, удобная и понятная, - название только навскидку не помню, смотреть надо, а сейчас не за ноутбуком).
Хотя, учитывая что нашёл viktor ne perestukin, в купе с Вашим lsusb, подозреваю что не взлетит, и действительно осталось только ждать... :(
« Последнее редактирование: 18 Декабрь 2017, 09:38:42 от zg_nico »
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], Ubuntu 18.04 64x [KDE, Budgie].

Оффлайн symon.2014

  • Старожил
  • *
  • Сообщений: 1228
  • Ковырятель страны OS.
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #6 : 18 Декабрь 2017, 09:51:31 »
DenisLopin, lusbтоже покажи , на ноуте вайфай так определяется часто.

Оффлайн DenisLopin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #7 : 18 Декабрь 2017, 09:53:57 »
symon.2014, "Команда не найдена"

Оффлайн viktor ne perestukin

  • Активист
  • *
  • Сообщений: 429
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #8 : 18 Декабрь 2017, 10:08:35 »
lsusb

Оффлайн DenisLopin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #9 : 18 Декабрь 2017, 10:15:41 »
lsusb вывод выше.

Вот еще:
======== Wireless-Info START ========

System-Info ~~~~~~~~~~~~~~~~~~~~~~~~

Yana 4.10.0-42-generic x86_64,  Ubuntu 16.04.3 LTS, xenial

CPU    : Intel(R) Core(TM) i3-6006U CPU @ 2.00GHz
Memory : 3866 MB
Uptime : 08:38:39 up 45 min,  1 user,  load average: 0,15, 0,30, 0,35


lspci ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
DeviceName: Hanksville Gbe Lan Connection
Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:8328]
Kernel driver in use: r8169
Kernel modules: r8169
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:d723]
DeviceName: WLAN
Subsystem: Hewlett-Packard Company Device [103c:8319]


lsusb ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0bda:58ed Realtek Semiconductor Corp.
Bus 001 Device 002: ID 0bda:b009 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


PCMCIA Card Info ~~~~~~~~~~~~~~~~~~~



iwconfig ~~~~~~~~~~~~~~~~~~~~~~~~~~~



rfkill ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Interface     Soft blocked  Hard blocked
0: hci0: Bluetooth      no            no


lsmod ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

hp_wmi                 16384  0
sparse_keymap          16384  3 intel_hid,intel_vbtn,hp_wmi
wmi                    16384  1 hp_wmi


module parameters ~~~~~~~~~~~~~~~~~~

wmi           (2): debug_dump_wdg=N | debug_event=N


nm-tool ~~~~~~~~~~~~~~~~~~~~~~~~~~~~


================o======o========o========o=========o===========o==============o===========
 Interface & ID | Type | Driver | State  | Default | Speed     | Support      | HW Addr   
================o======o========o========o=========o===========o==============o===========
                |      |        |        |         |           |              |           
----------------+------+--------+--------+---------+-----------+--------------+-----------


NetworkManager.state ~~~~~~~~~~~~~~~
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true


NetworkManager.conf ~~~~~~~~~~~~~~~~

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false


NM WiFi Profiles ~~~~~~~~~~~~~~~~~~~
 


interfaces ~~~~~~~~~~~~~~~~~~~~~~~~~

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

resolv.conf ~~~~~~~~~~~~~~~~~~~~~~~~

nameserver 127.0.1.1


Routes & Ping ~~~~~~~~~~~~~~~~~~~~~~

Таблица маршутизации ядра протокола IP
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    100    0        0 eno1
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eno1
192.168.1.0     0.0.0.0         255.255.255.0   U     100    0        0 eno1

--- 192.168.1.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1020ms
rtt min/avg/max/mdev = 0.344/0.356/0.368/0.012 ms

--- 127.0.1.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1016ms
rtt min/avg/max/mdev = 0.021/0.046/0.071/0.025 ms


iw reg get ~~~~~~~~~~~~~~~~~~~~~~~~~

(Region : "ru_RU.UTF-8")
country 00: DFS-UNSET
(2402 - 2472 @ 40), (6, 20), (N/A)
(2457 - 2482 @ 20), (6, 20), (N/A), PASSIVE-SCAN
(2474 - 2494 @ 20), (6, 20), (N/A), NO-OFDM, PASSIVE-SCAN
(5170 - 5250 @ 80), (6, 20), (N/A), PASSIVE-SCAN
(5250 - 5330 @ 80), (6, 20), (0 ms), DFS, PASSIVE-SCAN
(5490 - 5730 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
(5735 - 5835 @ 80), (6, 20), (N/A), PASSIVE-SCAN
(57240 - 63720 @ 2160), (N/A, 0), (N/A)


iwlist chan ~~~~~~~~~~~~~~~~~~~~~~~~

           -


iwlist scan ~~~~~~~~~~~~~~~~~~~~~~~~



blacklist ~~~~~~~~~~~~~~~~~~~~~~~~~~

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode


modinfo ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[hp_wmi]
filename:       /lib/modules/4.10.0-42-generic/kernel/drivers/platform/x86/hp-wmi.ko
srcversion:     DF8202C6FAC1665D4B64952
depends:        wmi,sparse-keymap

[wmi]
filename:       /lib/modules/4.10.0-42-generic/kernel/drivers/platform/x86/wmi.ko
srcversion:     AC4196BC3F95425047FF4FF
depends:       
parm:           debug_event:Log WMI Events [0/1] (bool)
parm:           debug_dump_wdg:Dump available WMI interfaces [0/1] (bool)


udev rules ~~~~~~~~~~~~~~~~~~~~~~~~~


Custom files/entries ~~~~~~~~~~~~~~~

/etc/modules        : Default
/etc/rc.local       : Default
/etc/modprobe.d     : Not Default
/etc/pm/(cnf|pw|sl) : Default

[/etc/modprobe.d]
iwlwifi.conf      : remove iwlwifi \
                    (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
                    && /sbin/modprobe -r mac80211
mlx4.conf         : softdep mlx4_core post: mlx4_en


Kernel boot line ~~~~~~~~~~~~~~~~~~~

BOOT_IMAGE=/vmlinuz-4.10.0-42-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7


dmesg ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[    1.143658] audit: initializing netlink subsys (disabled)
[    1.548949] wmi: Mapper loaded
[    1.562033] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    1.626657] [drm] GuC firmware load skipped
[   11.120479] systemd[1]: Started Trigger resolvconf update for networkd DNS.
[   19.845023] Bluetooth: hci0: rtl: examining hci_ver=08 hci_rev=000d lmp_ver=08 lmp_subver=8723
[   19.845025] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[   19.894795] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[   19.894798] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
[   19.894802] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[   20.618065] Bluetooth: hci0: rtl: examining hci_ver=08 hci_rev=000d lmp_ver=08 lmp_subver=8723
[   20.618072] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[   20.618131] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[   20.618133] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
[   20.618136] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[   25.893787] Bluetooth: BNEP (Ethernet Emulation) ver 1.3

======== Done ========

Оффлайн viktor ne perestukin

  • Активист
  • *
  • Сообщений: 429
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #10 : 18 Декабрь 2017, 10:17:40 »
DenisLopin, Коллега глаза открой. LSUSB  и LUSB

Оффлайн DenisLopin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #11 : 18 Декабрь 2017, 10:49:24 »
viktor ne perestukin, ещё выше ;)

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3017
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #12 : 18 Декабрь 2017, 10:52:54 »
DenisLopin, https://github.com/lwfinger/rtlwifi_new - вам сюда) и собирать драйвер.
Дополнительное инфо можете найти, если воспользуетесь поиском rtl8192
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн DenisLopin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #13 : 18 Декабрь 2017, 12:30:28 »
Поставил Ubuntu 17.10 (4.13.0-19-generic), в параметрах: "адаптеры Wi-Fi не найдены", что-то совсем всё грустно.
Если собирать драйвер самостоятельно, то из чего? Можно ссылку на исходники и хотя бы примерную инструкцию, я даже не могу понять какой у меня адаптер WiFi.

Оффлайн viktor ne perestukin

  • Активист
  • *
  • Сообщений: 429
    • Просмотр профиля
Re: Не работает WiFi
« Ответ #14 : 18 Декабрь 2017, 12:43:32 »
Берешь ID (в твоем первом страдании) 10ec:d723. Бежишь в гугл - видишь, что это Realtek RTL8723DE. Дальше опять штудируешь гугл, и понимаешь что Realtek не любит делать за бесплатно. И вроде бы обещал под Линукс для этого чипа что-то сделать до конца 2017 года.

 

Страница сгенерирована за 0.075 секунд. Запросов: 24.