Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: AMD ATI 15.302 драйвер для ядер 4.14.x и ниже для версий убунты 16.x/17.x  (Прочитано 675 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн d4vid1

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Для начала устанавливаем своё ядро 4.10.х/4.14.х или на примере ядра 4.14.11

открываем терминал и следуем..

64-bit OS:

$ cd /tmp/

$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.11/linux-headers-4.14.11-041411_4.14.11-041411.201801022143_all.deb

$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.11/linux-headers-4.14.11-041411-generic_4.14.11-041411.201801022143_amd64.deb

$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.11/linux-image-4.14.11-041411-generic_4.14.11-041411.201801022143_amd64.deb

$ sudo dpkg -i *.deb

32-bit OS:

$ cd /tmp/

$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.11/linux-headers-4.14.11-041411_4.14.11-041411.201801022143_all.deb

$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.11/linux-headers-4.14.11-041411-generic_4.14.11-041411.201801022143_i386.deb

$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.11/linux-image-4.14.11-041411-generic_4.14.11-041411.201801022143_i386.deb

$ sudo dpkg -i *.deb

НЕ ПЕРЕГРУЖАЕМ СИСТЕМУ!!!

1) Удаляем старые драйвера видеокарты

$ sudo sh /usr/share/ati/fglrx-uninstall.sh
$ sudo apt-get remove --purge fglrx*

2) Качаем новые драйвера 15.302 + патчим для 4.14.11 ядра

$ mkdir /tmp/ati

$ cd /tmp/ati/

$ wget --referer='http://support.amd.com/en-us/download/desktop?os=Linux+x86' http://www2.ati.com/drivers/linux/radeon-crimson-15.12-15.302-151217a-297685e.zip

$ unzip radeon-crimson-15.12-15.302-151217a-297685e.zip

$ cd fglrx-15.302

$ wget --no-check-certificate 'http://aur.archlinux.org/cgit/aur.git/snapshot/catalyst-test.tar.gz' -O patches.tar.gz

$ chmod a+x patches.tar.gz

$ tar xzvf patches.tar.gz

$ chmod +x amd-driver-installer-15.302-x86.x86_64.run

$ ./amd-driver-installer-15.302-x86.x86_64.run --extract ./drv

$ cd drv/

выделяем + (CTRL + C)

patch -Np1 --verbose < ../catalyst-test/4.10-arch-sling00-virtual_address-acpi_get_table_with_size.patch
patch -Np1 --verbose < ../catalyst-test/4.11-npfeiler-signal_vmf.patch
patch -Np1 --verbose < ../catalyst-test/4.12-arch-remove_clts.patch
patch -Np1 --verbose < ../catalyst-test/4.12-npfeiler-movsl_mask.patch
patch -Np1 --verbose < ../catalyst-test/4.12-npfeiler-PUD_OFFSET.patch
patch -Np1 --verbose < ../catalyst-test/4.13-npfeiler-wait_queue_t.patch
patch -Np1 --verbose < ../catalyst-test/4.14-npfeiler-task_struct-mm_segment_t.patch
patch -Np1 --verbose < ../catalyst-test/4.3-gentoo-mtrr.patch
patch -Np1 --verbose < ../catalyst-test/4.3-kolasa-seq_printf.patch
patch -Np1 --verbose < ../catalyst-test/4.4-manjaro-xstate.patch
patch -Np1 --verbose < ../catalyst-test/4.6-arch-get_user_pages-page_cache_release.patch
patch -Np1 --verbose < ../catalyst-test/4.7-arch-cpu_has_pge-v2.patch
patch -Np1 --verbose < ../catalyst-test/4.9_over_4.6-arch-get_user_pages_remote.patch
patch -Np1 --verbose < ../catalyst-test/arch-fglrx-authatieventsd_new.patch
patch -Np1 --verbose < ../catalyst-test/crimson_i686_xg.patch
patch -Np1 --verbose < ../catalyst-test/fglrx_gpl_symbol.patch
patch -Np1 --verbose < ../catalyst-test/grsec_arch.patch
patch -Np1 --verbose < ../catalyst-test/lano1106_fglrx_intel_iommu.patch
patch -Np1 --verbose < ../catalyst-test/lano1106_kcl_agp_13_4.patch
patch -Np1 --verbose < ../catalyst-test/makefile_compat.patch
patch -Np1 --verbose < ../catalyst-test/makesh-dont-check-gcc-version.patch

(CTRL + V) в терминале + ENTER + ENTER

64bit
$ sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases lib32gcc1 libqtgui4 xserver-xorg-dev

32bit
$ sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases libqtgui4 xserver-xorg-dev

$ sudo ./ati-installer.sh 15.302 --buildpkg Ubuntu/xenial или trusty

$ cd ..

4) Устанавливаем:

$ sudo chmod a+x *.deb

$ sudo dpkg -i *.deb

$ sudo aticonfig --initial -f

для 2 и больше видеокарт
$ sudo aticonfig --adapter=all --initial -f

5) наконец Перезагружаем систему и молимся ^^

5.1) Проблема с переключением на tty 1-6 терминалы? решение > http://uh.cx/m8wv0

6) Если всё получилось то удалить вы старые версии ядра в системе могли бы всего одной командой например как:

sudo apt-get purge 4.14.1-*

Удачи ;)

 

Страница сгенерирована за 0.059 секунд. Запросов: 24.