Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: При подклучении репозитория перестаёт работать пакетный менеджер  (Прочитано 1110 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Stazot

  • Автор темы
  • Участник
  • *
  • Сообщений: 146
    • Просмотр профиля
Всем привет. Решил я значит поставить Zentyal. нашел ссылки посмотрел, добавил репозиторий
deb http://archive.zentyal.org/zentyal 5.0 main
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 10E239FF
wget -q http://keys.zentyal.org/zentyal-4.1-archive.asc -O- | sudo apt-key add -
после чего при попытке поставить пакеты вижу следующее
Пакеты, имеющие неудовлетворённые зависимости:
 zentyal : Зависит: zentyal-core но он не будет установлен
           Зависит: zentyal-software но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
Это происходит при попытки установить практически любого пакета(samba? winbind и т.п.)
как только удаляю(комментирую) репу, и обновляю кЭш
ошибка пропадает.
не могу понять в чем может быть проблема, ПоможИте мне разобраться?



Пользователь добавил сообщение 31 Января 2018, 17:38:07:
P.S.
ОС Ubuntu server 16.04.3
« Последнее редактирование: 31 Января 2018, 17:38:07 от Stazot »

Оффлайн suslikk

  • Старожил
  • *
  • Сообщений: 2485
    • Просмотр профиля
Нарисуй свой город на openstreetmap.org

Оффлайн ALiEN175

  • Администратор
  • Старожил
  • *
  • Сообщений: 6562
  • 20% Cooler
    • Просмотр профиля
Stazot, после добавления реп

sudo apt update

делали?
🖥 AsRock B550M Pro4 :: AMD Ryzen 5 3600 :: 16 GB DDR4 :: AMD Radeon RX 6600 :: XFCE
💻 ACER 5750G :: Intel Core i5-2450M :: 6 GB DDR3 :: GeForce GT 630M :: XFCE

Оффлайн Stazot

  • Автор темы
  • Участник
  • *
  • Сообщений: 146
    • Просмотр профиля
sudo apt update

делали?
admin@FS:~$ sudo apt update
Сущ:1 http://ru.archive.ubuntu.com/ubuntu xenial InRelease
Сущ:2 http://ru.archive.ubuntu.com/ubuntu xenial-updates InRelease
Сущ:3 http://ru.archive.ubuntu.com/ubuntu xenial-backports InRelease
Игн:4 http://webmin.mirror.somersettechsolutions.co.uk/repository sarge InRelease
Сущ:5 http://webmin.mirror.somersettechsolutions.co.uk/repository sarge Release
Игн:6 http://download.webmin.com/download/repository sarge InRelease
Сущ:7 http://security.ubuntu.com/ubuntu xenial-security InRelease
Пол:9 http://archive.zentyal.org/zentyal 5.0 InRelease [4 887 B]
Сущ:10 http://download.webmin.com/download/repository sarge Release
Пол:11 http://archive.zentyal.org/zentyal 5.0/main i386 Packages [6 531 B]
Получено 11,4 kБ за 0с (16,0 kБ/c)
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Может быть обновлено 2 пакета. Запустите «apt list --upgradable» для их показа.
sudo apt install -f
Не помогло, просто пишет что ничего не установлено
admin@FS:~$ sudo apt install zentyal
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 zentyal : Зависит: zentyal-core но он не будет установлен
           Зависит: zentyal-software но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
admin@FS:~$ sudo apt install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.

Пользователь добавил сообщение 01 Февраля 2018, 13:48:47:
sudo apt install zentyal-core
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 zentyal-core : Зависит: libhtml-mason-perl (>= 1:1.56+zentyal1-1) но 1:1.56-1 будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Пользователь добавил сообщение 01 Февраля 2018, 13:51:40:
Мне вот это строка мало понятна.
zentyal-core : Зависит: libhtml-mason-perl (>= 1:1.56+zentyal1-1) но 1:1.56-1 будет установлен
« Последнее редактирование: 01 Февраля 2018, 13:51:40 от Stazot »

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3487
  • Ubuntu 22.04 х64
    • Просмотр профиля
Stazot, Я даже стесняюсь спросить, а чего у вас ключик от репозитория 4.2, а подключен 5.0 ?
Ну и огласите разрядность ОС
HP Pro 840 G3: Intel i5-6300U, 32GB DDR4 2133MHz, Intel 520, Intel Pro 2500 180GB/Ubuntu 22.04
Dell Latitude 5590: Intel i5-8350U, 16GB DDR4 2400MHz, Intel 620, Samsung 1TB/Ubuntu 22.04

Оффлайн Stazot

  • Автор темы
  • Участник
  • *
  • Сообщений: 146
    • Просмотр профиля
Stazot, Я даже стесняюсь спросить, а чего у вас ключик от репозитория 4.2, а подключен 5.0 ?
Ну и огласите разрядность ОС
Пробовал другие версии, видимо осталось, ключик поменял
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 10E239FF
wget -q http://keys.zentyal.org/zentyal-5.0-archive.asc -O- | sudo apt-key add -
Разрядность 32бита

Пользователь добавил сообщение 01 Февраля 2018, 14:35:26:
C 3.5 такая же проблема


Пользователь добавил сообщение 01 Февраля 2018, 15:18:29:
Переустановил новую U.server x64 все та же ошибка, магия
« Последнее редактирование: 01 Февраля 2018, 15:18:29 от Stazot »

 

Страница сгенерирована за 0.035 секунд. Запросов: 25.