Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Opera стала открыватся в окне  (Прочитано 7161 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ivanich352012

  • Автор темы
  • Участник
  • *
  • Сообщений: 141
    • Просмотр профиля
Opera стала открыватся в окне
« : 12 Февраль 2018, 09:23:51 »
После последнего обновления opera открывается теперь в окне на полэкрана. Приходится растягивать на полный.При запуске в терминале выдает такие ошибки
(Нажмите, чтобы показать/скрыть)
Пробовал убирать конфиг-такие же ошибки,только с дефолтными настройками.
Но в целом работает без глюков.Чего же ей не нравится?
Система xubuntu 16.04 64bit
« Последнее редактирование: 12 Февраль 2018, 11:06:59 от ivanich352012 »

Оффлайн wwe2012

  • Активист
  • *
  • Сообщений: 270
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #1 : 12 Февраль 2018, 09:56:38 »
У меня опера последния не идет на x86, не подскажите почему так

Оффлайн symon.2014

  • Забанен
  • Старожил
  • *
  • Сообщений: 1225
  • Ковырятель страны OS.
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #2 : 12 Февраль 2018, 11:56:07 »
У меня опера последния не идет на x86, не подскажите почему так
Последних опер нет на 32.

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #3 : 12 Февраль 2018, 14:30:58 »
ivanich352012, попробуйте в терминале выполнить
opera --fullscreenдолжна открыться в полноэкранном режиме.
Если проканает, - идем в /usr/share/applications, находим по логотипу desktop-файл запуска Opera (назвается он скорее всего тоже Opera), открываем его с помощью gedit (открыть gedit, и перетащить в его окно этот файл), ищем там строчку:
Exec=operaи правим до вида:
Exec=opera --fullscreenПосле этого с панели задач старый значок запуска удаляем. Запускаем Opera со значка в /usr/share/applications (должна открыться во весь экран), и закрепляем на панели задач. Если запускали с рабочего стола - то то же самое, значок надо заменить. Про меню не уверен, - нет опыта работы с XFCE, по идее в меню из /usr/share/applications все автоматом подтягивается...
« Последнее редактирование: 12 Февраль 2018, 14:32:33 от zg_nico »
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн ivanich352012

  • Автор темы
  • Участник
  • *
  • Сообщений: 141
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #4 : 13 Февраль 2018, 18:18:47 »
zg_nico, что-то подобное в башке крутилось, я когда-то правил десктор файл у хрома, чтобы кэш на файлопомойке был. Счас буду пробовать.

Пользователь добавил сообщение 14 Февраль 2018, 06:43:58:
--fullscreen - не прокатило,ни в терминале ни в /usr/share/applications ни в значке на раб.столе. Хотя для интереса запустил с этой опцией кодировщик handbrake и он раскрылся на полный экран, хотя я его всегда в окне на пол экрана открывал. Где-то что-то другое...
« Последнее редактирование: 14 Февраль 2018, 06:43:58 от ivanich352012 »

Оффлайн ivanich352012

  • Автор темы
  • Участник
  • *
  • Сообщений: 141
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #5 : 23 Февраль 2018, 05:56:31 »
Да,остается только выпилить её всю наверно... :-\

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 3912
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #6 : 23 Февраль 2018, 08:06:27 »
Цитировать
...opera открывается теперь в окне на полэкрана. Приходится растягивать на полный
Попробуй так.
Запусти оперу. Кнопкой окна разверни на весь экран. Нажми "Ctrl+Q" для закрытия.
Снова запусти - у меня запустилась на весь экран.

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1787
  • ubuntu 20.04
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #7 : 23 Февраль 2018, 08:47:44 »
Скорее дело с DE
По тупому можно просто
OperaBrowser& && sleep 5 && wmctrl -r Opera -b toggle,fullscreen
PS: не проверял, так чисто идея

Оффлайн ivanich352012

  • Автор темы
  • Участник
  • *
  • Сообщений: 141
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #8 : 28 Февраль 2018, 10:22:36 »
Скорее дело с DE
По тупому можно просто
OperaBrowser& && sleep 5 && wmctrl -r Opera -b toggle,fullscreen
PS: не проверял, так чисто идея
В DE я ничего не менял с момента установки в 16-ом году.И опера в нем работала с того же времени до последнего обновления.И  с клавиатуры не управляется, хотя в настройках все галки стоят...И команда эта тоже не работает в разных вариациях.Вивальди что-ли поставить?

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 3912
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #9 : 01 Март 2018, 18:22:48 »
 Первый блин вышел комом.
Удивлению не было предела, когда сегодня не смог запустить оперу в развернутом на весь экран виде. Хотя несколько дней назад получалось.
Скорее дело с DEПробовал unity, LXDE, XFCE. Нигде не сработало.
Opera 12, vivaldi, firefox на этих-же DE запускаются в таком размере, как и предыдущий раз.
Похоже, что виновата опера.
Дальше проверял на xubuntu 17.10 и opera 45 32bit.
Удаление конфига и кеша не помогло. Опера упорно запускалось в полэкрана.
Тогда скопировал конфиг оперы из бэкапа (апрель 2016). Опера запустилась развернутой во весь экран.
В старом конфиге "ковырнул" файл Prefernces.
Там нашел вот такой код:
"browser":{"window_placement":{"height":712,"left":65,"maximized":true,"top":68,"width":1215}}Это оказалось то, на что похоже. Попробовал менять значения. Соответственно менялись размеры окна оперы.
В новом конфиге ничего похожего не нашел.
Попробовал добавить этот код в новый конфиг. Опера на него не реагирует.
Срабатывает только замена всего файла Preferences.
Пока так.


Оффлайн chadwick

  • Любитель
  • *
  • Сообщений: 89
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #10 : 01 Март 2018, 20:16:04 »
Пробовал unity, LXDE, XFCE. Нигде не сработало.

в LXDE можно в настройках оконного менеджера openbox указать примерно следующее:
    <application name="opera" type="normal">
      <maximized>true</maximized>
    </application>

и обновить командой:
openbox --reconfigure
настройки находятся в файле ~/.config/openbox/rc.xml, блок applications в самом конце

значения name, type, class и role можно узнать командой:
obxprop | grep "^_OB_APP"
при этом курсор примет форму крестика, которым нужно кликнуть по окну приложения

кстати, с вивальди такие же проблемы http://lubuntu.ru/viewtopic.php?t=3904
« Последнее редактирование: 01 Март 2018, 20:34:26 от chadwick »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 3912
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #11 : 02 Март 2018, 09:46:56 »
Цитировать
в LXDE можно в настройках оконного менеджера openbox указать...
Спасибо, может пригодится. С оперой не сработало. Вроде правильно сделал.
В данном случае мне не нужно, а у ТС - XFCE.
Цитировать
...с вивальди такие же проблемы
Vivaldi 1.14. Полностью удалил конфиг. Запустил. Вроде запоминает размер окна.
Посмотрел Preferences. Похож на оперовский. Есть параметры размеров окна.
Наверно зависит от конкретной версии, конкретного ХРОМ-подобного браузера.
Захотят разрабы - будет сохранять размер окна, не захотят - не будет.

Оффлайн ivanich352012

  • Автор темы
  • Участник
  • *
  • Сообщений: 141
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #12 : 02 Март 2018, 12:42:51 »
andytux, интересно. Поковыряюсь у себя.

Пользователь добавил сообщение 03 Март 2018, 06:36:13:
andytux, таки да.Вытащил из бакупа домашнего коталога от ноября прошлого года тот файл,заменил и все стало как прежде, кроме визуальных закладок на экспресс-панели.Но их легко восстановить из истории посещений,пароли тоже никуда не делись.Поскольку в конфиге перед возникновением проблемы я не ковырялся,получается вопрос к разрабам что-ли?
« Последнее редактирование: 03 Март 2018, 06:36:13 от ivanich352012 »

Оффлайн Александр 01

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #13 : 14 Апрель 2018, 19:12:12 »
Также столкнулся с этим.
Идём в конфигурацию Оперы /home/aleksandr/.config/opera
открываем файл "Preferences" текстовым редактором Brackets, находим строчку "maximized": false
исправляем на "maximized": true ,сохраняем.
Все эти манипуляции делаем при закрытой Опера. :)
https://forums.opera.com/topic/5476/opera-not-starting-maximized/6
Если "maximized" нет,возможно устанавливали Опера 52 с нуля, удаляем всё, включая папку Опера в .config
скачиваем Опера 40, устанавливаем, редактируем "Preferences"
обновляемся до новой версии, Опера будет стартовать максимизированной.(Опера 64 бит, Ubuntu16.04)
« Последнее редактирование: 29 Апрель 2018, 15:55:48 от Александр 01 »

Оффлайн x230

  • Любитель
  • *
  • Сообщений: 63
  • Георгий
    • Просмотр профиля
Re: Opera стала открыватся в окне
« Ответ #14 : 18 Август 2018, 11:14:07 »
opera --start-maximized %U
i3-3210 / 4GB / VGA на борту / HDD 160ГБ / Artix (s6) / 5.8.* / KDE 5.75/Plasma 5.20.0 / SlimJet
N5000 / 4GB / VGA на борту / SSD 256ГБ / Xubuntu 20.04.1 / 5.4.* / Xfce 4.14.2 / Firefox

 

Страница сгенерирована за 0.275 секунд. Запросов: 24.