Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Shutdown ubuntu 17.10 desktop по power button без входа в систему  (Прочитано 388 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GoodLeo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Здравствуйте, уважаемые гуру!

Прошу помочь.

Установлена ubuntu 17.10 desktop, которая используется как файл-сервер.
Соответственно, типичный сценарий: утром вкл по нажатию кнопки питания, вечером выкл по нажатию кнопки питания, без входа в учётные записи.

Но, у меня, при нажатии кнопки питания для выключения, если я не логинился, происходит переход в спящий режим.

В настройках пользователя в электропитании стоит, что при нажатии кнопки питания - выключать. И он выключает, если я залогинился и экран не заблокирован.

Но как настроить, чтобы без логина он выключался, а не в сон уходил?

Раньше была ветка:
https://forum.ubuntu.ru/index.php?topic=190240.0

И на 12-ой убунте у меня всё получилось.

Но на 17.10, описанные в ветке рецепты не помогают.

Заранее спасибо!

p.s. я не большой спец. по убунте, скриптам и т.п., но прошарил весь интернет уже несколько часов и действующего рецепта не нашел. :-\

Оффлайн Morisson

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 3185
    • Просмотр профиля
Нужно ковырять настройки gdm

Так попробуйте
gsettings set org.gnome.settings-daemon.plugins.power power-button-action 'your_action'Подробнее тут
Acer E5-571G; Intel Corei5; GPU: IntelHD 4400 + Nvidia 820M; SSD 250 Гб + HDD 500 Гб; RAM 12 Гб, UEFI без загрузчика.
Arch Linux; WM: Xmonad ;ядро: linux-zen

Оффлайн ALiEN175

  • Старожил
  • *
  • Сообщений: 1971
  • X-9000SC
    • Просмотр профиля
gnome? логина в сессию не было же?

Вроде туточки настроить можно:
/etc/systemd/logind.conf
HandlePowerKey=poweroff
17.10 нет под рукой, точно не смогу проверить
M5A78L-M LX3 : AMD FX-4330 : 16 Gb RAM : AMD Radeon R7 260x
Samsung N150 : Intel Atom N450 : 2 Gb RAM : Intel GMA 3150

Оффлайн GoodLeo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Оба метода не работают :(

То, что указал Morisson, насколько я понимаю, работает после логина.
По крайней мере изменение этой настройки отображается в "стандартной консоли" параметров электропитания, после входа.

В logind.conf тоже поменял, причем прописал, на всякий случай:
HandlePowerKey=poweroff
HandleSuspendKey=poweroff
HandleHibernateKey=poweroff
HandleLidSwitch=poweroff

Но, результат один :(.

Вроде в БИОС мамки (ASUS A68HM Plus) нет нигде опций на эту тему.
Уже на неё грешил.

Оффлайн Morisson

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 3185
    • Просмотр профиля
GoodLeo, по ссылке видимо не читали. Там написано, как зайти в сессию под пользователем gdm и все поменять

Вроде туточки настроить можно:
/etc/systemd/logind.conf
Gnome переопределяет настройки logind.conf. Они в сессии gnome  не работают.
Acer E5-571G; Intel Corei5; GPU: IntelHD 4400 + Nvidia 820M; SSD 250 Гб + HDD 500 Гб; RAM 12 Гб, UEFI без загрузчика.
Arch Linux; WM: Xmonad ;ядро: linux-zen

Оффлайн GoodLeo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Читал по ссылке.

Вы имеете ввиду раздел:
3.5.4   Enable root login in GDM
?

Думаете если под рутом войти и настроить - поможет?

Оффлайн Morisson

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 3185
    • Просмотр профиля
Не под рутом, а под логином gdm


>DConf configuration
Acer E5-571G; Intel Corei5; GPU: IntelHD 4400 + Nvidia 820M; SSD 250 Гб + HDD 500 Гб; RAM 12 Гб, UEFI без загрузчика.
Arch Linux; WM: Xmonad ;ядро: linux-zen

Оффлайн GoodLeo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Решено! :)
Спасибо, Morisson!

И так, что нужно сделать:

1.Активировать gdm логин:
Создать файл /etc/dconf/profile/gdm
В него вставить:

user-db:user
system-db:gdm
file-db:/usr/share/gdm/greeter-dconf-defaults

2. Залогиниться под gdm, набрав в консоли:
machinectl shell gdm@

machinectl, скорее всего, система предложит поставить.

3.Установить нужное действие на кнопку питание, введя в консоли:
gsettings set org.gnome.settings-daemon.plugins.power power-button-action 'interactive'

Всё.

Действия shutdown нет.
Действие hibernate у меня не сработало. Нажимаешь, ничего не происходит.

По interactive выводится окно с вариантами отключения и через 60 секунд происходит shutdown
Меня это, в принципе, устраивает.
Получается, что по умолчанию стоит suspend.

p.s.2 дня, на сраную кнопку. Твою мать!

Оффлайн Morisson

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 3185
    • Просмотр профиля
GoodLeo, в новом гноме есть кнопка выключить) Обнови хотя бы до 3.26
Acer E5-571G; Intel Corei5; GPU: IntelHD 4400 + Nvidia 820M; SSD 250 Гб + HDD 500 Гб; RAM 12 Гб, UEFI без загрузчика.
Arch Linux; WM: Xmonad ;ядро: linux-zen

Оффлайн GoodLeo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
У меня версия гнома 3.26.2

 

Страница сгенерирована за 0.067 секунд. Запросов: 24.