Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Kompas 3D wine 3.0  (Прочитано 366 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн odinokiyklaus

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Kompas 3D wine 3.0
« : 28 Апрель 2018, 14:47:13 »
Всё. Установил Kompas-3D v16 x32!

(Нажмите, чтобы показать/скрыть)

Установка:
Использовать последний актуальный winetricks,ю скачанный отсюда  https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks

Wine-stable (3.0) (на Wine-staging 3.6 dotnet4.0 отказывается устанавливаться)
dpkg --add-architecture i386
aptitude install --with-recommends wine-stable:i386
rm -rf ~/.cache/wine
rm -rf ~/.cache/winetricks

Параметры в .bashrc:
export LANGUAGE=ru_RU.UTF-8
export WINEARCH=win32
export PATH=/opt/wine-stable/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

env  WINEPREFIX="/home/robert/KOMPAS-3D" winecfg
env  WINEPREFIX="/home/robert/KOMPAS-3D" winetricks -q corefonts unifont vcrun2012 dotnet46 riched30 richtx32

А далее всё как обычно - через winetricks

env  WINEPREFIX="/home/robert/KOMPAS-3D" winetricks

запускаете uninstall, устанавливаете программу KOMPAS-3D, и правите через winecfg шрифты.
Лично я в winecfg устанавливаю разрешение экрана =125 т/дюйм вместо 96, и во вкладке "Вид и интеграция->Элемент" для всех шрифтов выбираю Calibri жирный 12.

Всем удачи!

P.S. Обратите внимание в строке экспорта переменных директория вайна стоит вначале.
export PATH=/opt/wine-stable/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
Если переместить эту строку в конец, то в случае, если у вас будет установлена старая стабильная версия вайна 1.8.7 (иногда она ставится по умолчанию в виде зависимости), то при запуске в консоле команды
env  WINEPREFIX="/home/robert/KOMPAS-3D" winecfg

вы получите то, что ваш компас будет сконфигурирован под вайн 1.8.7, а не как ни под последнюю стабильную версию вайна 3.0 и подобного рода сообщения:
Your version of wine 1.8.7 is no longer supported upstream. You should upgrade to 2.x" "
« Последнее редактирование: 30 Апрель 2018, 22:57:35 от odinokiyklaus »

 

Страница сгенерирована за 0.074 секунд. Запросов: 24.