Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Не загружается после установки драйверов Nvidia  (Прочитано 7568 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн favt

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
Доброго всем.
16.04.5 / GForce 430
После очередного обновления перестала грузиться, или в экран логина падает, или просто зависает при запуске.
Шаманил, читал (видать где-то недочитал), удаляю agt-get purge nvidia* - все заводится с nouveau, но с ним не работает ни ускорение ни прочее. Как только ставлю (из официальных репов) nvidia-304/340/.../387/390 все перепробовал - одна и та же картина, или не грузится, или экран логона.
Задолбался, взял, начистую поставил 16.04.5, сразу посл установки update/upgrade и установка nvidia-304/340/390 (пробовал все 3), и НЕ ГРУЗИТСЯ!!!
Чистая система с нуля, из оф репов с дровами не грузится??!!!
Кто подкинет идею - буду признателен.
П.С. понимаю что без логов нет разговора. Куда рыть - не пойму. Смотреть syslog? Там то, что драйвер конфликтует с nouveau (в blaclist все есть).


Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 2782
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 20.10
    • Просмотр профиля
Кто подкинет идею - буду признателен.
Идея будет самая простая - установить 18.04.1, у меня на ней 340-вый работает замечательно, про другие ничего не скажу, не знаю.
Я странен, а не странен кто ж? (С)

Оффлайн favt

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
Кто подкинет идею - буду признателен.
Идея будет самая простая - установить 18.04.1, у меня на ней 340-вый работает замечательно, про другие ничего не скажу, не знаю.
П.С.
- "Ребята, помогите, у меня на BMW выскакивает ошибка двигателя, и машина не хочет заводиться".
- "А что думать? У меня Мерс, ездит отлично, про другие авто сказать не могу"

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 2782
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 20.10
    • Просмотр профиля
favt, нет - не тот случай.
Я странен, а не странен кто ж? (С)

Оффлайн favt

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
Кхе, поставил 18.04.01. После установки проприетарных, та же самая картина.
При этом после загрузки на экране в зависшем состоянии артефакты дикие (буквы прыгают и пр.).
У меня закралось подозрение что видяха приказала долго жить. Правда вот пишу на том же компе и на ней же из под винды (2-я ОС), в ней как работала, так и нормально работает. Может linux при загрузке какие-то тесты и прочее пытается прогнать, вот и вылетает по ошибке или прочему. А винда и nouveau в этот режим её не гонят.
На всякий, кусок из syslog:
(Нажмите, чтобы показать/скрыть)

Оффлайн sergey109

  • Активист
  • *
  • Сообщений: 581
    • Просмотр профиля
 При загрузке зайдите в меню груб и допишите nomodeset
Хотя-бы по этому примеру:
https://help.ubuntu.ru/wiki/ubuntu_12.04_%D0%BF%D1%80%D0%BE%D0%B1%D0%BB%D0%B5%D0%BC%D1%8B_%D1%82%D0%B2%D0%B8%D0%BA%D0%B8
 В случае удачной загрузки:
Цитировать
sudo touch /etc/modprobe.d/blacklist.conf
sudo echo 'blacklist nouveau' >> /etc/modprobe.d/blacklist.conf
PS
 При установке проп. драйверов это должно было сделано автоматически, но почему-то не сложилось.
У вас щимится загрузиться nouveau вместе с проп. драйвером nvidia.

2. В случае удачной загрузки
Цитировать
sudo nano /etc/default/grub
- допишите nomodeset после quiet splash
Цитировать
sudo update-grub
https://www.dell.com/support/article/ua/ru/uabsdt1/sln306327/manual-nomodeset-kernal-boot-line-option-for-linux-booting?lang=en
« Последнее редактирование: 13 Август 2018, 17:25:15 от sergey109 »

Оффлайн favt

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
nomodeset не помогает (пробовал раньше). При установке в blacklist он есть.
Буду копать дальше, есть подозрение на память (?!) + попробую старый 14.04 + xorg-edgers

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Буду копать дальше, есть подозрение на память
Есть подозрение, что есть какие-то заминки в ядре с какой-то версии с отдельным набором графических карт N-Vidia. В частности, здесь трудности при установке проприетарного драйвера (обновление с 17.10 на 18.04). Карта GeForce 550M. Вот еще пример. Человек с нуля пытался ставить Ubuntu 18.04, в итоге кроме как с noacpi никак больше не загрузиться - черный экран. Карта GeForce GTX 1070 Mobile. Обе "заминки" в линейке с самыми новыми ядрами. В Вашем случае, раз уж 16.04.5, то ядро стало быть тоже не старое. Я бы попробовал вернуться к истокам: в 16.04.4 все у Вас работало? Она пришла с 4.13. Раз пошли эксперименты со сменой версий, то терять уже нечего: попробуйте принудительным образом установить Ubuntu 16 с ядром 4.13 (можно поставить 16.04.5 и в него засунуть ядро 4.13, с которым позже загрузиться, и снести (опционально) все прочие версии, а текущую версию ядра заморозить) и накатить проприетарные драйвера. Велика вероятность, что заведется.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн favt

  • Автор темы
  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
Ну что ж, отпишусь. 16.04.01 с ядром 4.4 - не завелся, аналогичные проблемы.
14.04.05 - тоже ядро 4.4, но без проблем взлетает. В обоих nvidia-340 из оф.реп.
Из подозрений:
1. или в оф.репах начиная с 16.04 ставится что-то кривое (nvidia-setting, nvidia-..., prime, или еще что-то), в то же время для 14.04 новые версии кривого пакета не устанавливаются, они просто не собраны под 14.04 (Проверить по версиям, что устанавливается в одном и втором случаях пока не хочу, появится время - может заморочусь).
2. Всё же есть подозрение что проблема железная, но проявляется только при каких-то хитрых режимах, начиная с 16.04.

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 2782
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 20.10
    • Просмотр профиля
2. Всё же есть подозрение что проблема железная, но проявляется только при каких-то хитрых режимах, начиная с 16.04.
favt, если выше вы не слукавил, про винду:
У меня закралось подозрение что видяха приказала долго жить. Правда вот пишу на том же компе и на ней же из под винды (2-я ОС), в ней как работала, так и нормально работает.
то, думается, железную проблему можно исключить.
Я странен, а не странен кто ж? (С)

Оффлайн Wink007

  • Новичок
  • *
  • Сообщений: 49
    • Просмотр профиля
привет, аналогичная проблема на 18.04.1, менял на 16.04, все те же грабли, пока перешел на nouveau, ты не нашел решение с дровами nvidia?

Оффлайн cubasich

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
И так ребята всем привет! Столкнулся с такой же проблемой при установке ubuntu  версии 18.04  а также если обновится выше или устанавливать Ubuntu 19.10+ такая же беда просит ввести пароль (хотя в настройках установлено вход автоматически) и после чего вешается но не полностью верхняя пнель вроде даже подгружается и что то моргает! Или же просто не принимает пароль и в цикле все время его спрашивает! Так вот победил я его!!!!! Короче:
1.Запускаем Ubuntu в режиме рекавери(в grub выбираем recovery mode). Загрузится окно выбираем root это командная строка
в которой просят ввести логин и пароль. Вводим свой логин и пароль.
2.Удаляем все драйвера Nvidia или у кого чё другое смотрим как удалить на форуме:
 sudo apt purge nvidia* - удалит драйвер
 sudo apt autoremove - удалит весь трипер оставшийся от драйвера
3.Загружаемся в Ubuntu в обычном режиме(должна загрузится, если нет попробуйте выполнить ещё команду sudo apt install -f)
4.Качаем с официального сайта Nvidia (ну или у кого чё другое качаем там) файл с драйвером для вашей видеокарты для Linux на сайте есть функция подбора драйвера он с расширением run(он будет по умолчанию в Загрузках  после закачки для тех кто не в курсе). Сразу предупреждаю переименуйте его как нить что ли в   1.run проще будет.
5.Запускаем Ubuntu в режиме командной строки (смотрим пункт 1)
6.Переходим в командной строке в Загрузки и убеждаеся что файл на месте(команда ls)
7.Пишем команду:
-sudo sh 1.run - начнётся установка со всем соглайшайтесь(у кого проблемы с английским ни чем не могу помочь гугл в помощь).
-Далее после того как закончится установка пишем sudo apt install nvidia-settings
-И в конце sudo apt install nvidia-xconfig он напишет там что типо всё добавил в иксы и бла бла бла точнее в конфиг файл и после чего команда reboot и радуйтесь жизни должно с 19.10 работать!!!! У меня GTX 1660 Ti поднялась на 440 драйвере(ядро 5.3.0 - 46) хотя он даже не предлагается в утилите доп драйверов! Будут вопросы пишите на мыло!!! Всем удачи!
« Последнее редактирование: 26 Апрель 2020, 19:34:21 от cubasich »

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 2782
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 20.10
    • Просмотр профиля
Столкнулся с такой же проблемой при установке ubuntu  версии 18.04...
cubasich, третьего дня уже появилась 20.04. Зачем жить в прошлом, т.е. 18.04, а?
Я странен, а не странен кто ж? (С)

Оффлайн cubasich

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Да потому что 18-я Ubuntu не выделывалась! Тут я решил обновится и забыл что выше версии с дровами чё то не дружат и встрял! И вот победил для тех у кого такая трабла что бы могли запустить видюху! Не факт что 20 Ubuntu не выдаст тоже самое! И вообще у меня не хочет обновлять 19 до 20 говорит что типа нет новых версий и обновлений для компа!

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 2782
  • Kubuntu 12.04, 16.04, 18.04, 20.04, 20.10
    • Просмотр профиля
И вообще у меня не хочет обновлять 19 до 20 говорит что типа нет новых версий и обновлений для компа!
Обновись вручную:
sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak
sudo sed -i 's/eoan/focal/g' /etc/apt/sources.list
sudo apt update
sudo apt dist-upgrade
Я странен, а не странен кто ж? (С)

 

Страница сгенерирована за 0.112 секунд. Запросов: 24.