Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: несоответствие версий пакетов в Ubuntu-18.04  (Прочитано 721 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Peter_I

  • Автор темы
  • Старожил
  • *
  • Сообщений: 2112
    • Просмотр профиля
Здравствуйте!

У меня в Ubuntu-18.04 не устанавливается mplayer, т.к. ему нужна libdirectfb-1.7-7, а она не устанавливается,
т.к ей нужна libgles2, а она не устанавливается, т.к. ей нужна libglvnd0 более старой версии, чем уже имеющаяся
в системе. У меня локальный репозитарий, ранее полученный командой
/usr/bin/debmirror -a amd64 -d bionic,bionic-security,bionic-updates,bionic-backports \
-s main,restricted,multiverse,universe --method=http --nosource --progress \
-h ru.archive.ubuntu.com /home/mirror64/ubuntu
и я его только что обновил. "apt-get -f install" делал, ничего не произошло.
Я что-то упустил или в чём дело?
Пётр.

Оффлайн Peter_I

  • Автор темы
  • Старожил
  • *
  • Сообщений: 2112
    • Просмотр профиля
Re: несоответствие версий пакетов в Ubuntu-18.04
« Ответ #1 : 10 Август 2018, 18:43:52 »
В последние дни я предпринял несколько шагов, но всё же что-то упустил.
Я извлёк все deb-пакеты из репозитария, созданного debmirror и поместил их в 4 каталога,
чтобы reprepro было полегче. Всего пакетов было 63602.
Затем в каждом каталоге запустил reprepro includedeb *.deb. При этом были сотни сообщений, что подключаемый пакет
чуть старше текущего и поэтому игнорируется. Создался репозитарий. Затем дал команду "reprepro -v update".
Скачалось 54446 пакетов, удалилось 54439 пакетов и 54443 пакета были удалены и забыты, как говорится
в выводе reprepro. В созданном каталоге содержится 61132 пакета.
Но самого mplayer в нём нет, хотя есть два пакета с его принадлежностями, а в репозитарии от debmirror он был.
Т.е. команда update почему-то не синхронизировала мой локальный репозитарий с текущим.
Вот мой conf/distributions
(Нажмите, чтобы показать/скрыть)
и мой conf/updates
(Нажмите, чтобы показать/скрыть)
Скажите,пожалуйста, если кто знает, чего в них не хватает или где ошибка?
Эти файлы взяты из моего локального же репозитария для Ubuntu-16.04, в неём mplayer был.

Пользователь добавил сообщение 11 Август 2018, 12:03:21:
У меня что-то не так с настройками, т.к. mplayer в репозитарии есть, но apt-get не может его установить, пишет
(Нажмите, чтобы показать/скрыть)
Команда "apt-cache search mplayer" тоже его не находит.
Команда "apt list" выводит 1656 пакетов, хотя их 61132.
Вот вывод команды "apt-get update":
(Нажмите, чтобы показать/скрыть)
То, что репозитарий неподписанный, неважно, просто требуется лишний раз нажимать"y".
В Ubuntu-16.04 репозитарий, созданный с этими же conf/distributions и conf/updates, успешно работал,
я только заменил "xenial" на "bionic".
Так что же у меня не так?
« Последнее редактирование: 11 Август 2018, 12:03:21 от Peter_I »
Пётр.

Оффлайн Peter_I

  • Автор темы
  • Старожил
  • *
  • Сообщений: 2112
    • Просмотр профиля
Re: несоответствие версий пакетов в Ubuntu-18.04
« Ответ #2 : 11 Август 2018, 22:02:29 »
Я дополнительно создал /etc/apt/apt.conf, в котором явно разрешил использование неподписанных репозитариев,
но это не помогло, apt не находит mplayer.
Пётр.

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6780
    • Просмотр профиля
Re: несоответствие версий пакетов в Ubuntu-18.04
« Ответ #3 : 11 Август 2018, 23:20:23 »
Peter_I, а вам точно нужен этот mplayer? Я "сто лет" не пользовался, но, насколько помню, mplayer - это программа даже без GUI, но обычно нужна если ставить smplayer в KDE4. Сейчас в Kubuntu 18.04 базовым является VLC, а в GNOME тоже свой собственный просмоторщик видео. В mplayer необходимости нет. Так он вам и правда нужен?

Оффлайн www777

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2733
    • Просмотр профиля
Re: несоответствие версий пакетов в Ubuntu-18.04
« Ответ #4 : 11 Август 2018, 23:29:16 »
https://mpv.io - лучше чем mplayer (подробнее на сайте). А насчёт репозитория, тот кто ломал, тому и видней как исправлять ;)
« Последнее редактирование: 11 Август 2018, 23:38:11 от www777 »

Оффлайн Peter_I

  • Автор темы
  • Старожил
  • *
  • Сообщений: 2112
    • Просмотр профиля
Re: несоответствие версий пакетов в Ubuntu-18.04
« Ответ #5 : 11 Август 2018, 23:42:36 »
Мне нужно, чтобы репозитарий подключился, чтобы выполнился "apt-get update" и подключились все пакеты, а не 1156.
Должна же быть какая-то причина, странно, если никто не сталкивался. Или это только у меня?
А mplayer я часто запускаю. У меня xubuntu.

Пользователь добавил сообщение 11 Август 2018, 23:44:38:
www777, так сам репозитарий вроде бы в порядке, с reprepro проблем нет, есть с apt.

Пользователь добавил сообщение 12 Август 2018, 10:22:42:
Я нашёл у себя ошибку, после исправления которой apt-get подключил все пакеты и установил mplayer.
Ошибка была в /etc/apt/apt.conf, причём в Ubuntu-16.04 я этот файл не создавал.
Сейчас правильный выглядит так:
Acquire {
AllowInsecureRepositories "true";
};
а был такой:
APT {
Acquire::AllowInsecureRepositories "true";
};
Мне помог пример в /usr/share/doc/apt/examples.
« Последнее редактирование: 12 Август 2018, 10:22:42 от Peter_I »
Пётр.

 

Страница сгенерирована за 0.173 секунд. Запросов: 24.