Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Wi-Fi то есть то слетает  (Прочитано 687 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн flint73

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Wi-Fi то есть то слетает
« : 14 Декабрь 2018, 10:11:02 »
Ноут Lenovo ThinkPad t470
04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)

Дважды ставил Ubuntu за последние 2 дня. Сеть wi-fi то есть, то нет. wi-fi точки разные. Т.е. сети в принципе не видно среди устройств справа вверху. блютуз например виден.
Первый раз когда установил Ubuntu, вначеле сети небыло, на следующий день появилась возможно после доустановки обновлений Ubuntu. Через некоторое время пропало.
Заново переустанавливал систему и винду и Ubuntu по другим причинам. При инсталляции Ubuntu сразу увидела сеть и она целый день присутствовала. Затем устанавливал пакеты питона по инструкциям из сети. Вроде ни чего больше не трогал. Догружал пакеты для русского файрфокса (почему то второй раз поставилась английская версия), настраивал регион и язык. Вот после перезагрузки опять вайфай отвалился. Не дома не подключается ни на работе.

На этом же компе стоит винда 10, тоже пару дней. Вот с ней таких проблем за это время не наблюдалось.

Я новичок и понятия не имею как переставлять драйвера или что то там. Связь с интернетом сейчас реализую через usb подключения телефона в режиме 3G модем.

ТС не появлялся на Форуме более трех месяцев по состоянию на 12/02/2020 (последняя явка: 04/04/2019). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 12 Февраль 2020, 23:47:09 от zg_nico »

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Wi-Fi то есть то слетает
« Ответ #1 : 14 Декабрь 2018, 12:57:40 »
flint73, прошу показать выводы команд:iwconfig $(nmcli d status | grep wifi | awk '{print $1}')
nmcli d status
lshw -C network
dmesg | egrep -i "(error|fail|warning)"
cat /etc/issue.net; uname -r
Для получения вывода открываем терминал (Ctrl+Alt+T), вставляем в него команду (выделить мышкой соответствующую строчку текста в браузере, скопировать, вставить в окно терминала), нажимаем Enter, ответ терминала выделяем (текстом, - принтскринить картинки не нужно!), и вставляем на форум в сообщение, обрамив тегами:
[code]ответ_терминала_вставить_сюда[/code]
(Нажмите, чтобы показать/скрыть)
Пока по Вашему описанию похоже, что сильно занижена чувствительность адаптера. Возможно, некорректное firmware или еще что-то подобное.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн flint73

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Wi-Fi то есть то слетает
« Ответ #2 : 14 Декабрь 2018, 14:03:25 »
iwconfig $(nmcli d status | grep wifi | awk '{print $1}')
lo        no wireless extensions.

enp0s20f0u2  no wireless extensions.

enp0s31f6  no wireless extensions.

nmcli d status
DEVICE       TYPE      STATE          CONNECTION             
enp0s20f0u2  ethernet  подключено     Проводное соединение 2
enp0s31f6    ethernet  недоступен     --                     
lo           loopback  не настроенно  --

lshw -C network
ПРЕДУПРЕЖДЕНИЕ: эту программу нужно запускать от имени суперпользователя.
  *-network UNCLAIMED       
       описание: Network controller
       продукт: Wireless 8260
       производитель: Intel Corporation
       физический ID: 0
       сведения о шине: pci@0000:04:00.0
       версия: 3a
       разрядность: 64 bits
       частота: 33MHz
       возможности: cap_list
       конфигурация: latency=0
       ресурсы: память:ec100000-ec101fff
  *-network
       описание: Ethernet interface
       продукт: Ethernet Connection I219-LM
       производитель: Intel Corporation
       физический ID: 1f.6
       сведения о шине: pci@0000:00:1f.6
       логическое имя: enp0s31f6
       версия: 21
       серийный №: 54:e1:ad:f9:b8:ae
       capacity: 1Gbit/s
       разрядность: 32 bits
       частота: 33MHz
       возможности: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       конфигурация: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.13-4 latency=0 link=no multicast=yes port=twisted pair
       ресурсы: IRQ:124 память:ec200000-ec21ffff
  *-network
       описание: Ethernet interface
       физический ID: 2
       логическое имя: enp0s20f0u2
       серийный №: 46:e2:36:4a:b2:cb
       возможности: ethernet physical
       конфигурация: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.94 link=yes multicast=yes
ПРЕДУПРЕЖДЕНИЕ: выходная информация может быть неполной или неточной. Следует запустить эту программу от имени суперпользователя.

dmesg | egrep -i "(error|fail|warning)"
[    0.138027] acpi PNP0A08:00: _OSC failed (AE_SUPPORT); disabling ASPM
[    1.163446] RAS: Correctable Errors collector initialized.
[    2.677147] EXT4-fs (nvme0n1p5): re-mounted. Opts: errors=remount-ro
[    2.876449] random: 7 urandom warning(s) missed due to ratelimiting
[    3.076397] uvcvideo: Failed to initialize entity for entity 6
[    3.076398] uvcvideo: Failed to register entites (-22).
[    5.276445] iwlwifi: probe of 0000:04:00.0 failed with error -110
[   12.768697] pci 0000:05:00.0: BAR 13: failed to assign [io  size 0x2000]
[   12.768700] pci 0000:05:00.0: BAR 13: failed to assign [io  size 0x2000]
[   12.768706] pci 0000:06:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[   12.768709] pci 0000:06:01.0: BAR 13: failed to assign [io  size 0x1000]
[   12.768712] pci 0000:06:02.0: BAR 13: failed to assign [io  size 0x1000]
[   12.768716] pci 0000:06:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[   12.768719] pci 0000:06:02.0: BAR 13: failed to assign [io  size 0x1000]
[   12.768722] pci 0000:06:01.0: BAR 13: failed to assign [io  size 0x1000]
[   33.088561] xhci_hcd 0000:3d:00.0: Host halt failed, -19
[   33.088564] xhci_hcd 0000:3d:00.0: Host not accessible, reset failed.
[   33.604776] pcieport 0000:05:00.0: BAR 13: failed to assign [io  size 0x2000]
[   33.604780] pcieport 0000:05:00.0: BAR 13: failed to assign [io  size 0x2000]
[   33.604787] pcieport 0000:06:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[   33.604789] pcieport 0000:06:01.0: BAR 13: failed to assign [io  size 0x1000]
[   33.604792] pcieport 0000:06:02.0: BAR 13: failed to assign [io  size 0x1000]
[   33.604797] pcieport 0000:06:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[   33.604800] pcieport 0000:06:02.0: BAR 13: failed to assign [io  size 0x1000]
[   33.604803] pcieport 0000:06:01.0: BAR 13: failed to assign [io  size 0x1000]
[   38.181162] pcieport 0000:05:00.0: BAR 13: failed to assign [io  size 0x2000]
[   38.181166] pcieport 0000:05:00.0: BAR 13: failed to assign [io  size 0x2000]
[   38.181172] pcieport 0000:06:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[   38.181175] pcieport 0000:06:01.0: BAR 13: failed to assign [io  size 0x1000]
[   38.181178] pcieport 0000:06:02.0: BAR 13: failed to assign [io  size 0x1000]
[   38.181183] pcieport 0000:06:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[   38.181186] pcieport 0000:06:02.0: BAR 13: failed to assign [io  size 0x1000]
[   38.181189] pcieport 0000:06:01.0: BAR 13: failed to assign [io  size 0x1000]
[   78.412770] xhci_hcd 0000:3d:00.0: Host halt failed, -19
[   78.412772] xhci_hcd 0000:3d:00.0: Host not accessible, reset failed.
[   78.976448] pcieport 0000:05:00.0: BAR 13: failed to assign [io  size 0x2000]
[   78.976459] pcieport 0000:05:00.0: BAR 13: failed to assign [io  size 0x2000]
[   78.976476] pcieport 0000:06:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[   78.976485] pcieport 0000:06:01.0: BAR 13: failed to assign [io  size 0x1000]
[   78.976494] pcieport 0000:06:02.0: BAR 13: failed to assign [io  size 0x1000]
[   78.976506] pcieport 0000:06:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[   78.976515] pcieport 0000:06:02.0: BAR 13: failed to assign [io  size 0x1000]
[   78.976524] pcieport 0000:06:01.0: BAR 13: failed to assign [io  size 0x1000]
[14522.520758] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=471166 end=471167) time 143 us, min 1073, max 1079, scanline start 1071, end 1080

cat /etc/issue.net; uname -r
Ubuntu 18.04.1 LTS
4.15.0-42-generic

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Wi-Fi то есть то слетает
« Ответ #3 : 14 Декабрь 2018, 15:59:26 »
Из ubuntu после загрузки попробуйте выполнить: sudo modprobe -r iwlwifi && sudo modprobe iwlwifiТакже интересен вывод: rfkill list
dpkg -s linux-firmware
Исходя из того, что у Вас дуалбут, в купе с тем, что dmesg завален ошибками, я бы попробовал во-первых отключить полностью windows 10 (запретить ей вместо отключения гибернации, сны и тому подобное), во-вторых, проверить состояние опции secureboot в BIOS (его нужно disabled).
 
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн flint73

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Wi-Fi то есть то слетает
« Ответ #4 : 14 Декабрь 2018, 17:20:43 »
Убил в винде все гибернации и сны.
SecureBoot было и ранее Disabled
Загрузил Ubuntu - внешний модем был подключен и не обратил внимания, показывался ли на панели справа вверху wi-fi, но кажется нет.
Запустил команду sudo modprobe -r iwlwifi && sudo modprobe iwlwifi
И всё заработало!!!!!!!!!
Не знаю, навсегда ли? Как я догадываюсь, что то пересобралось? Что это было?

Привожу так же результаты выполнения команд:
rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: tpacpi_bluetooth_sw: Bluetooth
Soft blocked: no
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

dpkg -s linux-firmware
Package: linux-firmware
Status: install ok installed
Priority: optional
Section: misc
Installed-Size: 271127
Maintainer: Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
Architecture: all
Multi-Arch: foreign
Version: 1.173.2
Replaces: atmel-firmware, linux-firmware-snapdragon (<= 1.2-0ubuntu1), linux-restricted-common
Provides: atmel-firmware
Breaks: linux-firmware-snapdragon (<= 1.2-0ubuntu1)
Conflicts: atmel-firmware
Description: Firmware for Linux kernel drivers
 This package provides firmware used by Linux kernel drivers.

Пользователь добавил сообщение 14 Декабрь 2018, 22:08:14:
Домой пришел, опять Wi-fi пропал. Опять активировал волшебной командой.

sudo modprobe -r iwlwifi && sudo modprobe iwlwifi
« Последнее редактирование: 14 Декабрь 2018, 22:08:14 от flint73 »

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Wi-Fi то есть то слетает
« Ответ #5 : 15 Декабрь 2018, 02:51:21 »
Опять активировал волшебной командой.
"Волшебная" команда перезапускает модуль ядра. Он у Вас почему-то "сыпется", причем похоже что сразу после старта системы (хотя в последнем я на момент не уверен)... Вопрос на миллион: много ли подключено потребителей к шине USB? Внешние жесткие диски, мультимедийные мышки и тому подобное? Ноутбук подключен к сети питания во время загрузки? Если при подключенном внешнем питании у Вас с момента старта есть wifi, а без внешнего питания нет wifi - по-видимому, проблема аппаратная, и заключена она в том, что шина питания USB просто не расчитана на нагрузку, которую она на данный момент тянет. Либо включать меньше потребителей, либо одно из двух, как говорил Шеф из Братьев-Пилотов. Если wifi отваливается всякий раз, попробуйте загрузиться с одним из параметром ядра:
iwlwifi.bt_coex_active=0
iwlwifi.power_save=Y
iwlwifi.power_save=N
iwldvm.force_cam=N

Про загрузку с параметром ядра (в качестве примера писал про nomodeset) достаточно подробно уже описал здесь, повторяться не вижу смысла. По описанной там методике, вместо nomodeset прописывая один из параметров в списке выше (в первый раз iwlwifi.bt_coex_active=0, во второй iwlwifi.power_save=Y и т.д.) попробуйте все из перечисленных. Надеюсь, что при каком-нибудь у Вас wifi запустится при запуске системы. Если запустился - проверьте еще один раз загрузку с этим же самым параметром. Если снова работает - то в виде решения можно этот параметр прописать будет по-дефолту в grub2 к параметрам ядра, применяемым по-умолчанию. Объясню как это делать, но прежде нужно чтобы Вы определили какой именно параметр помогает, и написали мне его. Тогда поясню что делать дальше.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

impaleoops

  • Гость
Re: Wi-Fi то есть то слетает
« Ответ #6 : 17 Декабрь 2018, 02:52:49 »
Привет ребят.Присоединяюсь к теме. тоже бывает вайфай скачет.А скачет,когда либо кто-то на кабеле тянет,либо когда дверь закрываю между компом и роутером.Для меня очевидно,что дальность и сила сигнала, да и логи вроде что-то подобное пишут.Как увеличить мощность ?Возможно ли на моей железке?
x@x:~$ iwconfig $(nmcli d status | grep wifi | awk '{print $1}')
wlx0014d16bd2a5  IEEE 802.11bgn  ESSID:"Gate"  Nickname:"rtl_wifi"
          Mode:Managed  Frequency:2.417 GHz  Access Point: 98:DE:D0:91:6A:56   
          Bit Rate:150 Mb/s   Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=94/100  Signal level=58/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

x@x:~$ nmcli d status
DEVICE           TYPE      STATE          CONNECTION
wlx0014d16bd2a5  wifi      подключено     Gate 1     
enp2s0           ethernet  недоступен     --         
lo               loopback  не настроенно  --         
x@x:~$ lshw -C network
ПРЕДУПРЕЖДЕНИЕ: эту программу нужно запускать от имени суперпользователя.
  *-network                 
       описание: Ethernet interface
       продукт: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       производитель: Realtek Semiconductor Co., Ltd.
       физический ID: 0
       сведения о шине: pci@0000:02:00.0
       логическое имя: enp2s0
       версия: 02
       серийный №: e0:cb:4e:62:01:85
       размер: 10Mbit/s
       capacity: 1Gbit/s
       разрядность: 64 bits
       частота: 33MHz
       возможности: bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       конфигурация: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       ресурсы: IRQ:17 ioport:d800(размер=256) память:feaff000-feafffff память:fbef0000-fbefffff память:feac0000-feadffff
  *-network
       описание: Беспроводной интерфейс
       физический ID: 1
       сведения о шине: usb@2:6
       логическое имя: wlx0014d16bd2a5
       серийный №: 00:14:d1:6b:d2:a5
       возможности: ethernet physical wireless
       конфигурация: broadcast=yes driver=r8712u ip=10.10.10.102 multicast=yes wireless=IEEE 802.11bgn
ПРЕДУПРЕЖДЕНИЕ: выходная информация может быть неполной или неточной. Следует запустить эту программу от имени суперпользователя.
x@x:~$ dmesg | egrep -i "(error|fail|warning)"
[    0.073022] acpi PNP0A08:00: _OSC failed (AE_NOT_FOUND); disabling ASPM
[    1.062255] RAS: Correctable Errors collector initialized.
[    1.855910] ACPI Warning: SystemIO range 0x0000000000000400-0x000000000000041F [b]conflicts with OpRegion[/b] 0x0000000000000400-0x000000000000040F (\SMRG) (20170831/utaddress-247)
[    1.942459] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    8.059525] random: 7 urandom warning(s) missed due to ratelimiting
[   19.818264] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   29.663225] ACPI Warning: [b]SystemIO range[/b] 0x0000000000000828-0x000000000000082F conflicts with OpRegion 0x0000000000000800-0x000000000000084F (\PMRG) (20170831/utaddress-247)
[   29.663236] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x000000000000053F (\GPS0) (20170831/utaddress-247)
[   29.663240] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000053F (\GPS0) (20170831/utaddress-247)
[   91.081394] [drm:nv_drm_gem_fence_attach_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to lookup gem object for fence attach: 0x00000004
[   91.186480] [drm:nv_drm_gem_fence_attach_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to lookup gem object for fence attach: 0x00000004
[   91.186584] [drm:nv_drm_gem_fence_attach_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to lookup gem object for fence attach: 0x00000004
[   91.186674] [drm:nv_drm_gem_fence_attach_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to lookup gem object for fence attach: 0x00000004
[   91.187241] [drm:nv_drm_gem_fence_attach_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to lookup gem object for fence attach: 0x00000004
[   91.187329] [drm:nv_drm_gem_fence_attach_ioctl [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to lookup gem object for fence attach: 0x00000004
x@x:~$ cat /etc/issue.net; uname -r
Ubuntu 18.04.1 LTS
4.15.0-42-generic
« Последнее редактирование: 17 Декабрь 2018, 02:54:28 от impaleoops »

Оффлайн flint73

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Wi-Fi то есть то слетает
« Ответ #7 : 17 Декабрь 2018, 12:54:20 »
Если wifi отваливается всякий раз
Благодарю за развёрнутый ответ.
Дополнительных подключенных устройств нет вообще. Чаще всего подключаю с питанием от розитке. Сегодня без блока питания со средним уровнем сигнала без проблем сразу же при загрузке WI-Fi подключился без каких либо танцев с бубнами. Имеет место глюк, который я если что могу лечить через перезапуск модуля ядра.
Посмотрим, будет ли проявляться в дальнейшем.

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Wi-Fi то есть то слетает
« Ответ #8 : 17 Декабрь 2018, 13:17:47 »
Посмотрим, будет ли проявляться в дальнейшем.
Вот не люблю такие неисправности... То проявляется, то не проявляется. Ок, подсказывайте. Желаю Вам, чтоб больше не проявлялось ;)
impaleoops,
(Нажмите, чтобы показать/скрыть)
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

 

Страница сгенерирована за 0.273 секунд. Запросов: 22.