Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: После неудачного обновления пакетов невозможно ничего установить  (Прочитано 486 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Steelclad

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Добрый день.
Установлена Ubuntu 18.04

Был установлен пакет mono-complete. Сегодня прилетело обновление mono и кучи всего, но не хватило места на /boot и обновление не отработало до конца.
Я перенес /boot на основной раздел, теперь место есть, но теперь ничего не обновляется и не устанавливается(не связано с переносом /boot).

sudo apt install -f и sudo apt autoremove пробывал, все они заканчиваются этой ошибкой.

Причем если даже пытаться установить совсем другой пакет, не связанный с mono, то эта ошибка возникает.
Возможно, где-то "прилип" какой-то скрипт, который при обновлении не выполнился и теперь он пытается выполниться всегда.
Уже все изрыл, гугль измучал, не пойму как решить.


Возникают ошибки:
Настраивается пакет mono-gac (5.18.0.225-0xamarin1+ubuntu1804b1) …
* Installing 1 assembly from libglade2.0-cil into Mono
Stacktrace:

/proc/self/maps:
408c0000-408e0000 rwxp 00000000 00:00 0
40d86000-40d96000 rwxp 00000000 00:00 0
5585b9373000-5585b97bc000 r-xp 00000000 08:06 529674                     /usr/bin/mono-sgen
5585b99bb000-5585b99c2000 r--p 00448000 08:06 529674                     /usr/bin/mono-sgen
5585b99c2000-5585b99c7000 rw-p 0044f000 08:06 529674                     /usr/bin/mono-sgen
5585b99c7000-5585b9a58000 rw-p 00000000 00:00 0
5585bba2c000-5585bbc99000 rw-p 00000000 00:00 0                          [heap]
7f92cc000000-7f92cc021000 rw-p 00000000 00:00 0
7f92cc021000-7f92d0000000 ---p 00000000 00:00 0
7f92d0600000-7f92d0700000 rw-p 00000000 00:00 0
7f92d07c1000-7f92d0d7d000 r-xp 00000000 08:06 787004                     /usr/lib/mono/aot-cache/amd64/mscorlib.dll.so
7f92d0d7d000-7f92d0f7c000 ---p 005bc000 08:06 787004                     /usr/lib/mono/aot-cache/amd64/mscorlib.dll.so
7f92d0f7c000-7f92d0f7d000 r--p 005bb000 08:06 787004                     /usr/lib/mono/aot-cache/amd64/mscorlib.dll.so
7f92d0f7d000-7f92d0f7e000 rw-p 005bc000 08:06 787004                     /usr/lib/mono/aot-cache/amd64/mscorlib.dll.so
7f92d0f7e000-7f92d0fa8000 rw-p 00000000 00:00 0
7f92d0fa8000-7f92d13ff000 r--p 00000000 08:06 529541                     /usr/lib/mono/4.5/mscorlib.dll
7f92d13ff000-7f92d23ff000 rw-p 00000000 00:00 0
7f92d23ff000-7f92d2400000 ---p 00000000 00:00 0
7f92d2400000-7f92d3000000 rw-p 00000000 00:00 0
7f92d3091000-7f92d30de000 r--p 00000000 08:06 655588                     /usr/lib/mono/gac/Mono.Security/4.0.0.0__0738eb9f132ed756/Mono.Security.dll
7f92d30de000-7f92d30df000 ---p 00000000 00:00 0
7f92d30df000-7f92d30e0000 rw-p 00000000 00:00 0
7f92d30e0000-7f92d30e8000 ---p 00000000 00:00 0
7f92d30e8000-7f92d3313000 rw-p 00000000 00:00 0
7f92d3313000-7f92d3723000 r--p 00000000 08:06 525494                     /usr/lib/locale/locale-archive
Memory around native instruction pointer (0x7f92d08e48cf):
0x7f92d08e48bf  20 48 09 d6 41 0f b6 53 05 48 c1 e2 28 48 09 f2   H..A..S.H..(H..
0x7f92d08e48cf  66 41 0f 38 32 4b 06 66 0f 6f 05 72 75 49 00 66  fA.82K.f.o.ruI.f
0x7f92d08e48df  0f 38 00 c8 66 48 0f 7e c8 66 48 0f 3a 16 ce 01  .8..fH.~.fH.:...
0x7f92d08e48ef  48 09 c6 48 09 d6 41 0f b6 c2 41 0f b6 53 09 48  H..H..A...A..S.H

Native stacktrace:

/usr/bin/mono(+0x129f8d) [0x5585b949cf8d]
/usr/bin/mono(+0x12a295) [0x5585b949d295]
/usr/bin/mono(+0xbfd2f) [0x5585b9432d2f]
/usr/bin/mono(+0x414e8) [0x5585b93b44e8]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x12890) [0x7f92d3d3e890]
/usr/lib/mono/aot-cache/amd64/mscorlib.dll.so(+0x1238cf) [0x7f92d08e48cf]



Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5034
  • Все по палатам!
    • Просмотр профиля
Steelclad, Попробуй  посмотреть, что обновлялось (в логах), когда закончилось место на диске. А потом переустановить эти пакеты
 sudo apt-get install *** --reinstall
Извините, я все еще учусь

Оффлайн Steelclad

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Тут не особо понятно, что именно пошло не так и на каком месте.
обновлялось вот, что

Upgrade: libmono-system-numerics4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmonosgen-2.0-dev:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-serviceprocess4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-relaxng4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmonoboehm-2.0-1:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-llvm-tools:amd64 (3.6.0+mono201805011452-0xamarin1+ubuntu1804b1, 6.0+mono20180728010642-0xamarin12+ubuntu1804b1), libmono-system-windows4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-reactive-observable-aliases0.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-oracle4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-razor2.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-runtime-serialization-formatters-soap4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-xml4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libnvidia-compute-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libnvidia-compute-415:i386 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-system-configuration-install4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libnvidia-encode-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libnvidia-encode-415:i386 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-system-componentmodel-dataannotations4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), gnome-software-plugin-snap:amd64 (3.28.1-0ubuntu4.18.04.4, 3.28.1-0ubuntu4.18.04.8), nvidia-kernel-common-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-corlib4.5-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-io-compression4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), xserver-xorg-video-nvidia-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libnvidia-gl-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libnvidia-gl-415:i386 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-system-ldap4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-reactive-debugger2.2-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-i18n-other4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-drawing4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-management4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-routing4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-utils:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libnvidia-fbc1-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libnvidia-fbc1-415:i386 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-system-reflection-context4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-codecontracts4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libnvidia-decode-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libnvidia-decode-415:i386 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), mono-csharp-shell:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-http-selfhost4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-applicationservices4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-tasklets4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-reactive-platformservices2.2-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), gnome-software:amd64 (3.28.1-0ubuntu4.18.04.4, 3.28.1-0ubuntu4.18.04.8), libmono-rabbitmq4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-servicemodel-activation4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-microsoft-build-framework4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-enterpriseservices4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-data-services-client4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-workflow-runtime4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-reactive-providers2.2-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libnvidia-cfg1-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-system-data4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-workflow-componentmodel4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-net-http4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-dmcs:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-ldap4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-messaging4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-xml-serialization4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-mvc3.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-llvm-support:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-microsoft-csharp4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-windowsbase4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-microsoft-build-engine4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-peapi4.0a-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-simd4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-4.0-gac:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-dynamic4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-data-tds4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-http4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-json4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), nvidia-utils-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-system-net-http-formatting4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-i18n-mideast4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-io-compression-filesystem4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-smdiagnostics0.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-servicemodel-web4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), ca-certificates-mono:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), nvidia-dkms-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-system-runtime4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-profiler:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-xbuild:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-cscompmgd0.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-microsoft-build4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libxnvctrl0:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-system-servicemodel-internals0.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-debugger-soft4.0a-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-configuration4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-net4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-data-services4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-runtime-common:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-servicemodel-discovery4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-data-linq4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-reactive-interfaces2.2-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-reactive-runtime-remoting2.2-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-servicemodel4.0a-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-webpages-deployment2.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-componentmodel-composition4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-parallel4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), ubuntu-software:amd64 (3.28.1-0ubuntu4.18.04.4, 3.28.1-0ubuntu4.18.04.8), libmono-system-xaml4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-cil-dev:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-design4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-runtime-serialization4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-xbuild-tasks4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-deployment4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), nvidia-compute-utils-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), mono-4.0-service:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-security4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-management4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-messaging4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-runtime-sgen:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-xml-linq4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-devel:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-threading-tasks-dataflow4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), monodoc-base:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libnvidia-ifr1-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libnvidia-ifr1-415:i386 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), nvidia-driver-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmonosgen-2.0-1:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-services4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-reactive-windows-forms2.2-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-data-datasetextensions4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-db2-1.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-2.0-1:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-webmatrix-data4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-json-microsoft4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-dynamicdata4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-transactions4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-identitymodel4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-i18n-rare4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-numerics-vectors4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-servicemodel-routing4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-gac:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-custommarshalers4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-btls-interface4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-drawing-design4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-windows-forms-datavisualization4.0a-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-2.0-dev:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-posix4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), unattended-upgrades:amd64 (1.1ubuntu1.18.04.6, 1.1ubuntu1.18.04.8), libmono-system-web-abstractions4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-security4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-workflow-activities4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-net-http-webrequest4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-reactive-experimental2.2-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-webpages2.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-reactive-linq2.2-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-jay:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-extensions-design4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-microsoft-visualc10.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-microsoft-build-tasks-v4.0-4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libnvidia-common-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-system-core4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-reactive-core2.2-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-http-webhost4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-mobile4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-regularexpressions4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), monodoc-manual:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-mcs:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-csharp4.0c-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-webbrowser4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-compilerservices-symbolwriter4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-roslyn:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-microsoft-build-utilities-v4.0-4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), gnome-software-common:amd64 (3.28.1-0ubuntu4.18.04.4, 3.28.1-0ubuntu4.18.04.8), mono-complete:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-i18n-cjk4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-webpages-razor2.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-windows-forms4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-identitymodel-selectors4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-microsoft-web-infrastructure1.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-i18n4.0-all:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-data-entity4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-ldap-protocols4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), mono-runtime:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-cecil-private-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-sqlite4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-runtime-durableinstancing4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-reactive-windows-threading2.2-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-messaging-rabbitmq4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-accessibility4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), nvidia-kernel-source-415:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-cairo4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-i18n4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-web-extensions4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-i18n-west4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), nvidia-settings:amd64 (415.23-0ubuntu0~gpu18.04.1, 415.25-0ubuntu0~gpu18.04.1), libmono-system-web-http4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-sharpzip4.84-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1), libmono-system-runtime-caching4.0-cil:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-12-22  18:56:06

Попытка поправить выдавала:


Start-Date: 2018-12-22  19:08:42
Commandline: apt-get install -f
Requested-By: anama (1000)
Upgrade: ca-certificates-mono:amd64 (5.16.0.220-0xamarin4+ubuntu1804b1, 5.18.0.225-0xamarin1+ubuntu1804b1)

Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-12-22  19:10:53



Пробую переустановить весь пакет

sudo apt-get install mono-complete --reinstall
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 mono-complete : Зависит: mono-devel (= 5.18.0.225-0xamarin1+ubuntu1804b1) но он не будет установлен
                 Зависит: mono-csharp-shell (= 5.18.0.225-0xamarin1+ubuntu1804b1) но он не будет установлен
                 Зависит: mono-4.0-service (= 5.18.0.225-0xamarin1+ubuntu1804b1) но он не будет установлен
                 Зависит: monodoc-base (= 5.18.0.225-0xamarin1+ubuntu1804b1) но он не будет установлен
                 Зависит: monodoc-manual (= 5.18.0.225-0xamarin1+ubuntu1804b1) но он не будет установлен
                 Зависит: referenceassemblies-pcl но он не будет установлен
                 Зависит: ca-certificates-mono (= 5.18.0.225-0xamarin1+ubuntu1804b1) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).




далее как рекомендовано делаю sudo apt --fix-broken install, и после скачивания зависимостей необходимых, все опять заканчивается той же ошибкой
« Последнее редактирование: 23 Декабрь 2018, 00:31:02 от Steelclad »

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Steelclad, версия ОС? Реп моно добавляли?
apt policy mono-complete

?

Оффлайн Steelclad

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
ubuntu 18.04


Репозиторий добавлял, как у них в инструкции указано:
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb https://download.mono-project.com/repo/ubuntu stable-bionic main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update

apt policy mono-complete  выводит
mono-complete:
  Установлен: 5.18.0.225-0xamarin1+ubuntu1804b1
  Кандидат:   5.18.0.225-0xamarin1+ubuntu1804b1
  Таблица версий:
 *** 5.18.0.225-0xamarin1+ubuntu1804b1 500
        500 https://download.mono-project.com/repo/ubuntu stable-bionic/main amd64 Packages
        100 /var/lib/dpkg/status
     4.6.2.7+dfsg-1ubuntu1 500
        500 http://ru.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

« Последнее редактирование: 23 Декабрь 2018, 11:41:51 от Steelclad »

Оффлайн Steelclad

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Может быть можно как-то удалить запланированную настройку пакета? Чтобы пор установке или обновлении других приложений не падала ошибка?

 

Страница сгенерирована за 0.262 секунд. Запросов: 24.