Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Ошибка при обновлении linux-generic  (Прочитано 301 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Konstantyin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Ошибка при обновлении linux-generic
« : 12 Январь 2019, 21:22:27 »
Вот, собственно:
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-headers-generic (= 4.4.0.141.147); however:
  Version of linux-headers-generic on system is 4.4.0.139.145.

sudo apt-get dist-upgrade
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 linux-image-generic : Depends: linux-image-4.4.0-141-generic but it is not installed
                       Depends: linux-image-extra-4.4.0-141-generic but it is not installed
                       Recommends: thermald but it is not installed
E: Unmet dependencies. Try using -f.

Основные рекомендации, которые надо выполнить при подобных проблемах, я сделал - но не помогло.

Оффлайн Konstantyin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Ошибка при обновлении linux-generic
« Ответ #1 : 12 Январь 2019, 22:08:18 »
Ubuntu Linux server 16.04.4

[b]sudo apt-get autoremove[/b]
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 linux-image-generic : Depends: linux-image-4.4.0-141-generic but it is not installed
                       Depends: linux-image-extra-4.4.0-141-generic but it is not installed
                       Recommends: thermald but it is not installed
E: Unmet dependencies. Try using -f.

[b]sudo dpkg --force-all -P linux-generic[/b]
dpkg: warning: ignoring request to remove linux-generic which isn't installed

[b]dpkg --configure -a[/b]
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-4.4.0-141-generic; however:
  Package linux-image-4.4.0-141-generic is not installed.
 linux-image-generic depends on linux-image-extra-4.4.0-141-generic; however:
  Package linux-image-extra-4.4.0-141-generic is not installed.

dpkg: error processing package linux-image-generic (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-generic

[b]sudo apt-get -f install[/b]
Reading package lists...
Building dependency tree...
Reading state information...
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-116 linux-headers-4.4.0-116-generic
  linux-headers-4.4.0-119 linux-headers-4.4.0-119-generic
  linux-headers-4.4.0-124 linux-headers-4.4.0-124-generic
  linux-headers-4.4.0-127 linux-headers-4.4.0-127-generic
  linux-headers-4.4.0-134 linux-headers-4.4.0-134-generic
  linux-headers-4.4.0-135 linux-headers-4.4.0-135-generic
  linux-headers-4.4.0-137 linux-headers-4.4.0-137-generic
  linux-image-4.4.0-116-generic linux-image-4.4.0-119-generic
  linux-image-4.4.0-124-generic linux-image-4.4.0-127-generic
  linux-image-4.4.0-134-generic linux-image-4.4.0-135-generic
  linux-image-4.4.0-137-generic linux-image-extra-4.4.0-116-generic
  linux-image-extra-4.4.0-119-generic linux-image-extra-4.4.0-124-generic
  linux-image-extra-4.4.0-127-generic linux-image-extra-4.4.0-134-generic
  linux-image-extra-4.4.0-135-generic linux-image-extra-4.4.0-137-generic
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  linux-headers-4.4.0-141-generic linux-image-4.4.0-141-generic
  linux-image-extra-4.4.0-141-generic
Suggested packages:
  fdutils linux-doc-4.4.0 | linux-source-4.4.0 linux-tools
The following NEW packages will be installed:
  linux-image-4.4.0-141-generic linux-image-extra-4.4.0-141-generic
The following packages will be upgraded:
  linux-headers-4.4.0-141-generic
1 upgraded, 2 newly installed, 0 to remove and 38 not upgraded.
2 not fully installed or removed.
Need to get 59.5 MB of archives.
After this operation, 232 MB of additional disk space will be used.
Do you want to continue? [Y/n] Abort.

[b]sudo apt autoremove[/b]

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 linux-image-generic : Depends: linux-image-4.4.0-141-generic but it is not installed
                       Depends: linux-image-extra-4.4.0-141-generic but it is not installed
                       Recommends: thermald but it is not installed
E: Unmet dependencies. Try using -f.

[b]dpkg --configure -a[/b]
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-4.4.0-141-generic; however:
  Package linux-image-4.4.0-141-generic is not installed.
 linux-image-generic depends on linux-image-extra-4.4.0-141-generic; however:
  Package linux-image-extra-4.4.0-141-generic is not installed.

dpkg: error processing package linux-image-generic (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-generic

Цитировать
Правила форума
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тегов [spoiler]...[/spoiler] или [code]...[/code], либо прикреплять к сообщению в виде отдельного файла. Длинные гиперссылки следует оформлять при помощи тега [url=]...[/url]

  --Aleksandru
« Последнее редактирование: 12 Январь 2019, 22:18:21 от Aleksandru »

Оффлайн zg_nico

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 1592
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Ошибка при обновлении linux-generic
« Ответ #2 : 13 Январь 2019, 08:52:11 »
Konstantyin,
sudo apt-get -f install
Reading package lists...
Building dependency tree...
Reading state information...
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
...
The following additional packages will be installed:
  linux-headers-4.4.0-141-generic linux-image-4.4.0-141-generic
  linux-image-extra-4.4.0-141-generic
Suggested packages:
  fdutils linux-doc-4.4.0 | linux-source-4.4.0 linux-tools
The following NEW packages will be installed:
  linux-image-4.4.0-141-generic linux-image-extra-4.4.0-141-generic
The following packages will be upgraded:
  linux-headers-4.4.0-141-generic
1 upgraded, 2 newly installed, 0 to remove and 38 not upgraded.
2 not fully installed or removed.
Need to get 59.5 MB of archives.
After this operation, 232 MB of additional disk space will be used.
Do you want to continue? [Y/n] Abort.
Ну и? Вы что потом нажали Y или n? Где сама ошибка-то? Или у Вас ошибки не было? Терминал предложил сделать выбор - хотите Вы устанавливать или нет, Вы закрыли его окно, и на этом успокоились?
Подключите интернет и выполните в терминале последовательно, по одной команде за раз:
sudo apt update
sudo apt -f install -y
sudo apt autoremove
sudo apt autoclean
sudo apt clean
Если что пойдет не так - выводы команд в студию.
« Последнее редактирование: 13 Январь 2019, 08:55:40 от zg_nico »
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн Konstantyin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Ошибка при обновлении linux-generic
« Ответ #3 : 13 Январь 2019, 11:27:48 »
Спасибо, не правильно пользовался командой "sudo apt -f install" без "-y".
Думал она работает в интерактивном режиме.

Оффлайн zg_nico

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 1592
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Ошибка при обновлении linux-generic
« Ответ #4 : 13 Январь 2019, 11:37:36 »
Думал она работает в интерактивном режиме
Правильно и думали. Команда отработала, все проверила, и задала простой вопрос: продолжать или нет. В ее понимании от Вас предполагался ответ Y если продолжать, или N если остановить работу. Вы либо N нажали, либо прервали выполнение программы путем закрытия окна данного терминала/нажатия комбинации клавиш CTRL+C в нем. Вот команда и не отработала. Указание ключа -y в данном случае заведомо дает ответ Y на запрос программы apt. Как-то так. Терминал - очень удобная штука. И очень информативная. Просто читайте внимательней что именно он Вам пишет - и никаких затруднений в работе испытывать не будете ;)
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

 

Страница сгенерирована за 0.058 секунд. Запросов: 24.