Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: проблемы с подлючением USB-устройства  (Прочитано 608 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jurganov

  • Автор темы
  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
подключаю фотоаппарат

Цитировать
$ lsusb | grep Canon

Bus 010 Device 076: ID 04a9:319a Canon, Inc. EOS 7D

но в dmesg | grep usb

Цитировать
[ 8858.071926] usb 2-4: new high-speed USB device number 5 using ehci-pci
[ 8858.233836] usb 2-4: New USB device found, idVendor=04a9, idProduct=319a
[ 8858.233841] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 8858.233843] usb 2-4: Product: Canon Digital Camera
[ 8858.233846] usb 2-4: Manufacturer: Canon Inc.
[ 8918.667889] usb 2-4: USB disconnect, device number 5

означает ли это, что камера не подключена?

если подключена, то как пробросить её на wine

Оффлайн zg_nico

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1526
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #1 : 13 Январь 2019, 11:28:16 »
jurganov, подключите камеру и покажите вывод dmesg | tail -n 20И поясните пожалуйста что означает
как пробросить её на wine
Вам нужно чтобы приложения wine камеру видели? То есть, если я правильно понимаю, в linux-приложениях (нативных) камера видна и работать с ней получается? Если так - то конкретизируйте, с какой программой пытаетесь работать, и какая не видит камеру.
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6353
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #2 : 13 Январь 2019, 16:11:40 »
означает ли это, что камера не подключена?
если подключена
Если речь о том, что бы увидеть и перекачать фото с камеры на компьрютер, то что вам мешает открыть файловый менеджер (стандартно в Ubuntu это Nautilus - аналог виндовоаго Проводника) и узанть, подключена камера или нет? В боковой панели Наутилуса камера отобразится либо как флэшка определённого объёма, либо как камера Canon.
как пробросить её на wine
А надо ли? Возможно имеется ввиду какая-либо программа для настройки/прошивки фотоаппарата, но если речь просто о том, что бы получить снимки с камеры, то просто скопируйте их через стандартный файловый менеджер в нужную папку, а потом запустите программу-обработчик из Wine и работайте со снимками в этой папке сколько хотите.

Оффлайн jurganov

  • Автор темы
  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #3 : 13 Январь 2019, 19:00:31 »
dmesg | tail -n 20
dmesg | tail -n 20
[   22.895259] i2c i2c-3: Failed! (01)
[   22.895290] i2c i2c-3: Failed! (01)
[   22.895320] i2c i2c-3: Failed! (01)
[   22.895350] i2c i2c-3: Failed! (01)
[   22.895380] i2c i2c-3: Failed! (01)
[   22.895411] i2c i2c-3: Failed! (01)
[   22.895441] i2c i2c-3: Failed! (01)
[   26.510589] usb 10-1.3: reset high-speed USB device number 5 using xhci_hcd
[   27.719416] scsi 11:0:0:0: CD-ROM            CDEmu    Virt. CD/DVD-ROM 1.10 PQ: 0 ANSI: 0
[   27.720277] sr 11:0:0:0: [sr0] scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[   27.720492] sr 11:0:0:0: Attached scsi CD-ROM sr0
[   27.720605] sr 11:0:0:0: Attached scsi generic sg5 type 5
[11198.753130] perf: interrupt took too long (2512 > 2500), lowering kernel.perf_event_max_sample_rate to 79500
[13150.305230] usb 10-1.3: reset high-speed USB device number 5 using xhci_hcd
[44288.406955] usb 2-4: new high-speed USB device number 2 using ehci-pci
[44288.565195] usb 2-4: New USB device found, idVendor=04a9, idProduct=319a
[44288.565200] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[44288.565202] usb 2-4: Product: Canon Digital Camera
[44288.565204] usb 2-4: Manufacturer: Canon Inc.
[44352.734932] usb 2-4: USB disconnect, device number 2


Пользователь добавил сообщение 13 Январь 2019, 19:06:35:
Если речь о том, что бы увидеть и перекачать фото с камеры на компьрютер, то что вам мешает открыть файловый менеджер (стандартно в Ubuntu это Nautilus - аналог виндовоаго Проводника) и узанть, подключена камера или нет? В боковой панели Наутилуса камера отобразится либо как флэшка определённого объёма, либо как камера Canon.
речь идет не об этом. Я пользуюсь картридером для этого. без всяких проблем.
речь идет о управлении камерой с компа. изменением выдержки, диафрагмы и прочего iso с получением превью. Хоте вместо экранчика камеры превью иметь на мониторе в большем размере. 
Если знаете нативные программы для таких целей, буду рад опробовать.
а пока я лишь читал про Darktable... увязать камеру с ней оказалось жутким геморроем с компилляцией... а в результате всё управление свелось к тому, что нажимаешь кнопку на фотике, и фотка прыг! и на компе.. самое никчемное действие...


Пользователь добавил сообщение 13 Январь 2019, 19:17:59:
Вам нужно чтобы приложения wine камеру видели? То есть, если я правильно понимаю, в linux-приложениях (нативных) камера видна и работать с ней получается? Если так - то конкретизируйте, с какой программой пытаетесь работать, и какая не видит камеру.
программа DSLR Remote Pro
я не знаю других программ, которые позволяют с компа менять настройки фотика - выдержку, диафрагму, ББ, iso...

darktable видит камеру после жуткого геморроя с установкой с использованием gphoto2. причем видит через раз. да зря время потратил. функционал никчемный
« Последнее редактирование: 13 Январь 2019, 19:17:59 от jurganov »

Оффлайн zg_nico

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1526
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #4 : 13 Январь 2019, 19:26:50 »
DSLR Remote Pro
Тогда сожалею, но нет у меня возможности Вам помочь, - нет опыта в использовании камер вообще, и их стыковки с linux в частности. Как устройство камера у Вас работает... Могу предложить лишь поискать иные альтернативы помимо той, что Вы уже опробовали ранее. Простите
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн jurganov

  • Автор темы
  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #5 : 13 Январь 2019, 19:38:41 »
увы... gphoto как раз тот инструмент через который рабоает darktable
да и тот перестал видеть камеру...
Цитировать
env LANG=C gphoto2 --auto-detect
я с трудом поставил профиль... http://rusdarktable.ru/add-preset-kameras-darktable/ и снова камера не видится...
Попробю поновой, хотя дарктаейбл мне и не нужен...
Надо пробросить usb на wine

Оффлайн zg_nico

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1526
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #6 : 13 Январь 2019, 22:00:42 »
jurganov, с пробросом USB на wine есть проблема: вероятно программе требуются специфичные полномочия для работы с камерой через usb-порт. Запуск от суперпользователя в данном случае не вариант, - сразу оговорюсь. Поэтому ситуация, насколько я понимаю, тупиковая. Либо нативные программы, либо никак...
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6353
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #7 : 13 Январь 2019, 22:16:00 »
jurganov, правильно заданный вопрос - половина правильного ответа. Теперь всё ясно. Использовал я когда-то такую программу. Прямо сейчас у меня возможности проверить нет, но, по-идее, она делает то, что вам нужно:
http://zenway.ru/page/entangle

Пользователь добавил сообщение 13 Январь 2019, 22:16:37:
Либо нативные программы
Их есть у нас.
В Kubuntu программа Entangle находится в штатных репозиториях и устанавливается через Менеджер приложений. В Ubuntu, думаю, так же.
« Последнее редактирование: 13 Январь 2019, 22:20:16 от maks05 »

Оффлайн jurganov

  • Автор темы
  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #8 : 15 Январь 2019, 08:58:20 »
jurganov, правильно заданный вопрос - половина правильного ответа. Теперь всё ясно. Использовал я когда-то такую программу. Прямо сейчас у меня возможности проверить нет, но, по-идее, она делает то, что вам нужно:
http://zenway.ru/page/entangle
Увы, управлять значениями с данной программы не получается. Есть только отображение установленного на камере, но менять не дает
Решил уставновить плагины, но они к последним версиям программы. скачал сорцы. Компиляция там через мезон. Но мезон не может найти
Цитировать
meson.build:38:0: ERROR: Native dependency 'gobject-introspection-1.0' not found
хотя на самом деле стоит версия 1.56-1-1, а в требованиях gobject_introspection_min_version = '>= 1.54.0'

Плюнул на это мезоновское дело

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6353
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #9 : 15 Январь 2019, 19:35:12 »
Увы, управлять значениями с данной программы не получается. Есть только отображение установленного на камере, но менять не дает
Странно, почему у вас не работает. У меня всё работает. Ну, почти всё. Там, на самом деле, множество параметров можно менять. Я проверил только основные: выдержку, диафрагму, светочувствительность и баланс белого. Всё отлично работает. Но вот если в настройках программы попытаться поменять так называемый "стиль" (есть таковая сборная настройка у Canon), то камера отказывается снимать ссылаясь на невозможность сфокусироваться. Таки да, она честно пытается, крутит линзами, в результате физически не строит фокус и сообщает об это пользователю на экране компьютера. Стоит перейти на стиль Standard или вообще отключить управление стилями, как камера начинает снимать, вполне адекватно фокусируясь.

Превью снимка до съёмки у меня не показывает. Но это логично, так как в моём фотоаппарате нет live View.

Canon EOS 400D, объектив Сanon 50mm, 1.8; подключение по USB2 через USB-разветвитель с питанием от розетки 220В; Kubuntu 18.04, Entangle 0.7.2.
По-идее Canon 7D тоже должен поддерживаться.

Оффлайн jurganov

  • Автор темы
  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #10 : 16 Январь 2019, 12:11:24 »
Странно, почему у вас не работает. У меня всё работает. Ну, почти всё. Там, на самом деле, множество параметров можно менять.
О!!! в очередной раз заработало!!
При запуске программа заявила, что камера смонтированна в файловой системе и предложила отмонтировать, однако теперь не работает спуск. кнопки в программе неактивны.

Дома же (откуда я и задавл вопрос) программа камеру не видит (( подсоединяю тем же кабелем в задние слоты usb
на работе же и в морду втыкаю, коннектится

PS
сменил параметры в настройках программы - перестало менять. вернул обратно - не меняет.

жму спуск - пишет entagle unable to capture image: canon EOS full-press failed (0x2019 PTP Device Busy)
запустился с терминала.
в терминале
Цитировать
$ entangle
Gtk-Message: 16:06:36.456: Failed to load module "appmenu-gtk-module"
Gtk-Message: 16:06:36.456: Failed to load module "canberra-gtk-module"
меняет, дает жать спуск, но снова то же сообщение.

гляжу в терминале -
(Нажмите, чтобы показать/скрыть)
удалил плагины (они для версии 2.0)
нужны плагины. Где их взять

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6353
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #11 : 17 Январь 2019, 11:37:31 »
(0x2019 PTP Device Busy)
Какая-то проблема с соединением. На фотоаппарате есть настройка, принудительно позволяющая задать ему именно PTP соединение?
$ entangle
Gtk-Message: 16:06:36.456: Failed to load module "appmenu-gtk-module"
Gtk-Message: 16:06:36.456: Failed to load module "canberra-gtk-module"
А какая у вас версия Ubuntu и какое рабочее окружение?
Как вариант (переустановка данных модулей):
sudo apt install --reinstall appmenu-gtk-module
sudo apt install --reinstall canberra-gtk-module
Хотя странно. Во-первых, на моей Kubuntu 18.04 Gtk-прогаммы работают, но appmenu-gtk-module не установлен, а canberra-gtk-module вообще нет в списке устанавливаемых пакетов. И Entangle работает.
Во-вторых, круто, что есть версия 2.0 на оф. сайте. (https://entangle-photo.org/). Но в самой программе в меню Help указано, что камеры Canon 7D и Canon 7D MarkII поддерживаются в версии 0.7.2 (и про доп. плагины там ничего не сказано). А версия 0.7.2 есть в штатном репозитории Ubuntu: то есть, должна устанавливаться и работать без особых проблем.
Поэтому вопрос: какая у вас версия Entangle и как вы её устанавливали? Почему считаете, что фотоаппарат заработает только с плагинами?
« Последнее редактирование: 19 Январь 2019, 14:03:14 от maks05 »

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6353
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #12 : 19 Январь 2019, 14:01:47 »
Сегодня через штатный репозиторий в 18.04 обновился Entangle до версии 2.0. Работоспособность пока не проверял, но сам факт обновления радует.
Поэтому, jurganov, повторю свой вопрос: какая у вас версия Ubuntu? Обновите систему - обновится Entangle и поставите обратно нужные вам плагины (вы писали, что они как раз для версии 2.0).

Проверил: печалька. Похоже, проблема в самой версии 2.0. Я попробовал менять более десятка параметров и все они нормально работают, кроме двух главных - программа не позволяет менять выдержку и диафрагму. Данные застыли на f2,8 и 1/40с. Зато заработали "стили". Так же заметил нюансы:
1) Режим "P" ("Программный") - настройки программы f2,8 и 1/40с, а у снимка - как определит камера.
2) Режим "Tv" (приоритет выдержки) - камера выставляет указанную программой 1/40с, а диафрагму определяет самостоятельно (как и должно быть)
3) Режим "Av" (приоритет диафрагмы) - камера выставляет указанную программой 2,8, а выдержку определяет самостоятельно (как и должно быть)
« Последнее редактирование: 19 Январь 2019, 21:57:17 от maks05 »

Оффлайн jurganov

  • Автор темы
  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
Re: проблемы с подлючением USB-устройства
« Ответ #13 : 20 Январь 2019, 18:05:32 »
Сегодня через штатный репозиторий в 18.04 обновился Entangle до версии 2.0. Работоспособность пока не проверял, но сам факт обновления радует.
Поэтому, jurganov, повторю свой вопрос: какая у вас версия Ubuntu? Обновите систему - обновится Entangle и поставите обратно нужные вам плагины (вы писали, что они как раз для версии 2.0).

Проверил: печалька. Похоже, проблема в самой версии 2.0. Я попробовал менять более десятка параметров и все они нормально работают, кроме двух главных - программа не позволяет менять выдержку и диафрагму. Данные застыли на f2,8 и 1/40с. Зато заработали "стили". Так же заметил нюансы:
1) Режим "P" ("Программный") - настройки программы f2,8 и 1/40с, а у снимка - как определит камера.
2) Режим "Tv" (приоритет выдержки) - камера выставляет указанную программой 1/40с, а диафрагму определяет самостоятельно (как и должно быть)
3) Режим "Av" (приоритет диафрагмы) - камера выставляет указанную программой 2,8, а выдержку определяет самостоятельно (как и должно быть)
выяснил почему дома програ не видит камеру. Дома именно 2.0 ))
я же снимаю исключительно на мануале, "программный"  даже не знаю, что это.
Tv предполагает ,что выдержку я должен выставить КОРОЧЕ, чем фокусное. если фокусное 60мм, то выдержка короче чем 1/60 должна быть. иначе шевеленка просто от рук

Пользователь добавил сообщение 20 Январь 2019, 18:08:22:
А какая у вас версия Ubuntu и какое рабочее окружение?

матунту - ubuntu 18.04.1 + mate
Цитировать
Kernel: 4.15.0-44-generic x86_64 bits: 64
           Desktop: MATE 1.20.1  Distro: Ubuntu 18.04.1 LTS

Пользователь добавил сообщение 20 Январь 2019, 18:24:19:
(0x2019 PTP Device Busy)
Какая-то проблема с соединением. На фотоаппарате есть настройка, принудительно позволяющая задать ему именно PTP соединение?
$ entangle
Gtk-Message: 16:06:36.456: Failed to load module "appmenu-gtk-module"
Gtk-Message: 16:06:36.456: Failed to load module "canberra-gtk-module"
А какая у вас версия Ubuntu и какое рабочее окружение?
Как вариант (переустановка данных модулей):
sudo apt install --reinstall appmenu-gtk-module
sudo apt install --reinstall canberra-gtk-module
Хотя странно. Во-первых, на моей Kubuntu 18.04 Gtk-прогаммы работают, но appmenu-gtk-module не установлен, а canberra-gtk-module вообще нет в списке устанавливаемых пакетов. И Entangle работает.
как я понял - эти модули - как раз те самые плагины
« Последнее редактирование: 20 Январь 2019, 18:24:19 от jurganov »

 

Страница сгенерирована за 0.063 секунд. Запросов: 24.