Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Kubuntu 18.04 LST x64 не ставится пакет python3-dev  (Прочитано 1131 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alextolmy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
https://kubuntu.org/getkubuntu/ - скачивал от сюда Kubuntu 18.04 LST x64

Проблема такая ставлю пакет python3-dev, получаю сообщение об ошибке:

sudo apt install python3-dev

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 python3-dev : Зависит: python3 (= 3.6.5-3) но 3.6.7-1~18.04 будет установлен
               Зависит: libpython3-dev (= 3.6.5-3) но он не будет установлен
               Зависит: python3.6-dev (>= 3.6.5-2~) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.



sudo aptitude install python3-dev
Следующие НОВЫЕ пакеты будут установлены:       
  dh-python{a} libexpat1-dev{a} libpython3-dev{a} libpython3.6-dev{ab} python3-dev{b} python3.6-dev{ab}
0 пакетов обновлено, 6 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 3 219 kБ архивов. После распаковки 18,0 MБ будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 python3-dev : Зависит: python3 (= 3.6.5-3) но установлен 3.6.7-1~18.04
 libpython3.6-dev : Зависит: libpython3.6-stdlib (= 3.6.5-3) но установлен 3.6.7-1~18.04
                    Зависит: libpython3.6 (= 3.6.5-3) но установлен 3.6.7-1~18.04
 python3.6-dev : Зависит: python3.6 (= 3.6.5-3) но установлен 3.6.7-1~18.04
                 Зависит: libpython3.6 (= 3.6.5-3) но установлен 3.6.7-1~18.04
Следующие действия разрешат зависимости:

     Оставить для следующих пакетов их текущие версии:
1)     libpython3-dev [Не установлен]                 
2)     libpython3.6-dev [Не установлен]               
3)     python3-dev [Не установлен]                   
4)     python3.6-dev [Не установлен]                 

sudo cat /etc/apt/sources.list
(Нажмите, чтобы показать/скрыть)

Если нужна какая то доплнительная информация, предоставлю.

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #1 : 27 Январь 2019, 18:48:29 »
ставлю пакет python3-dev
Так а python3.6-dev чем-то конкретным не устраивает, или что?
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн alextolmy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #2 : 27 Январь 2019, 18:55:08 »
zg_nico,
sudo aptitude install python3.6-dev
Следующие НОВЫЕ пакеты будут установлены:       
  libexpat1-dev{a} libpython3.6-dev{ab} python3.6-dev{b}
0 пакетов обновлено, 3 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 3 122 kБ архивов. После распаковки 17,5 MБ будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 libpython3.6-dev : Зависит: libpython3.6-stdlib (= 3.6.5-3) но установлен 3.6.7-1~18.04
                    Зависит: libpython3.6 (= 3.6.5-3) но установлен 3.6.7-1~18.04
 python3.6-dev : Зависит: python3.6 (= 3.6.5-3) но установлен 3.6.7-1~18.04
                 Зависит: libpython3.6 (= 3.6.5-3) но установлен 3.6.7-1~18.04
Следующие действия разрешат зависимости:

     Оставить для следующих пакетов их текущие версии:
1)     libpython3.6-dev [Не установлен]               
2)     python3.6-dev [Не установлен] 
 

Мне нужно собрать пакеты pdftotext, pycurl, но при установке через pip он ругается на
  src/pycurl.h:4:10: fatal error: Python.h: Нет такого файла или каталога
   #include <Python.h>

« Последнее редактирование: 27 Январь 2019, 18:57:42 от alextolmy »

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #3 : 27 Январь 2019, 19:38:42 »
sudo aptitude install
Я извиняюсь за серость, но aptitude?!
Для установки python3.6-dev по логике Вам следует сейчас во-первых дать машине интернет, во-вторых дать терминалу команды:
sudo apt update && sudo apt install -f
sudo apt install python3.6-dev -y
Что до Ваших изысканий в сторону пакетов pdftotext и pycurl, то рискну предположить, что достаточно было бы sudo apt install poppler-utils python-pycurlи нет нужды возиться с исходниками...
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн alextolmy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #4 : 27 Январь 2019, 19:53:25 »
sudo aptitude install
Я извиняюсь за серость, но aptitude?!
Для установки python3.6-dev по логике Вам следует сейчас во-первых дать машине интернет, во-вторых дать терминалу команды:
sudo apt update && sudo apt install -f
sudo apt install python3.6-dev -y
Что до Ваших изысканий в сторону пакетов pdftotext и pycurl, то рискну предположить, что достаточно было бы sudo apt install poppler-utils python-pycurlи нет нужды возиться с исходниками...

Я извиняюсь за серость, но aptitude?!
уже не знал что делать... apt использовал с начала.
Ну это не снимает вопроса почему не могу поставить python3.6-dev or python3-dev


Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #5 : 27 Январь 2019, 20:00:28 »
это не снимает вопроса почему не могу поставить python3.6-dev
Вы выполнили команды sudo apt update && sudo apt install -f
sudo apt install python3.6-dev -y
Возникли ошибки и пакет python3.6-dev не установился? Выхлоп терминала в студию!
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

Оффлайн alextolmy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #6 : 27 Январь 2019, 20:10:17 »
sudo apt install python3.6-dev -y

sudo apt update && sudo apt install -f                                                                                             
Сущ:1 http://ru.archive.ubuntu.com/ubuntu bionic InRelease
Сущ:2 http://ru.archive.ubuntu.com/ubuntu bionic-updates InRelease                                                                                                                         
Игн:3 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                               
Пол:4 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]                                                                                                                 
Сущ:5 http://ru.archive.ubuntu.com/ubuntu bionic-backports InRelease                                                                                                                       
Сущ:6 http://linux.teamviewer.com/deb stable InRelease                                                                                                                                     
Сущ:7 http://dl.google.com/linux/chrome/deb stable Release                                                                                                                                 
Сущ:8 https://repo.skype.com/deb stable InRelease                                                                                                                                           
Сущ:10 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease                                               
Получено 88,7 kB за 3с (35,0 kB/s)                                     
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Все пакеты имеют последние версии.
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

sudo apt install python3.6-dev -y                                                                                                             
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 python3.6-dev : Зависит: python3.6 (= 3.6.5-3) но 3.6.7-1~18.04 будет установлен
                 Зависит: libpython3.6-dev (= 3.6.5-3) но он не будет установлен
                 Зависит: libpython3.6 (= 3.6.5-3) но 3.6.7-1~18.04 будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

я так делал уже, не помогает то же самое.

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #7 : 27 Январь 2019, 20:37:48 »
apt policy libpython3.6 python3.6?


grep -v '^#\|^$' /etc/apt/sources.list{,.d/*.list}
?




Оффлайн alextolmy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #8 : 28 Январь 2019, 05:10:07 »
apt policy libpython3.6 python3.6?


grep -v '^#\|^$' /etc/apt/sources.list{,.d/*.list}
?

sudo apt policy libpython3.6 python3.6                                                                                                                                                       
libpython3.6:
  Установлен: 3.6.7-1~18.04
  Кандидат:   3.6.7-1~18.04
  Таблица версий:
 *** 3.6.7-1~18.04 100
        100 /var/lib/dpkg/status
     3.6.5-3 500
        500 http://ru.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
python3.6:
  Установлен: 3.6.7-1~18.04
  Кандидат:   3.6.7-1~18.04
  Таблица версий:
 *** 3.6.7-1~18.04 100
        100 /var/lib/dpkg/status
     3.6.5-3 500
        500 http://ru.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

grep -v '^#\|^$' /etc/apt/sources.list{,.d/*.list}                                                                                                                                           

/etc/apt/sources.list:deb http://ru.archive.ubuntu.com/ubuntu/ bionic main restricted
/etc/apt/sources.list:deb http://ru.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
/etc/apt/sources.list:deb http://ru.archive.ubuntu.com/ubuntu/ bionic universe
/etc/apt/sources.list:deb http://ru.archive.ubuntu.com/ubuntu/ bionic-updates universe
/etc/apt/sources.list:deb http://ru.archive.ubuntu.com/ubuntu/ bionic multiverse
/etc/apt/sources.list:deb http://ru.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
/etc/apt/sources.list:deb http://ru.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu bionic-security main restricted
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu bionic-security universe
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu bionic-security multiverse
/etc/apt/sources.list.d/google-chrome.list:deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/skype-stable.list:deb [arch=amd64] https://repo.skype.com/deb stable main
/etc/apt/sources.list.d/slack.list:deb https://packagecloud.io/slacktechnologies/slack/debian/ jessie main
/etc/apt/sources.list.d/teamviewer.list:deb http://linux.teamviewer.com/deb stable main
 

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 3937
    • Просмотр профиля
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #9 : 28 Январь 2019, 05:39:03 »
Цитировать
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
alextolmy, пока вы это не исправите, вы не сможете установить ничего.

Оффлайн alextolmy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #10 : 28 Январь 2019, 05:51:06 »
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #9 : Сегодня в 05:39:03 »
Цит

А как это исправить ? я уже гуглил на эту тему все рекомендации делал, таких пакетов я не нашел !
и тут еще с dpkg -- configure (что то такое точно не помню)

sudo apt install -f
sudo apt autoremove


Вот что я еще нашел мб в этом проблема в установленных пакетах

libpython3-stdlib/now 3.6.7-1~18.04 amd64 [установлен, локальный]
libpython3.6/now 3.6.7-1~18.04 amd64 [установлен, локальный]
libpython3.6-minimal/now 3.6.7-1~18.04 amd64 [установлен, локальный]
libpython3.6-stdlib/now 3.6.7-1~18.04 amd64 [установлен, локальный]

по цепочке я прихожу к тому что из за libpython3-stdlib или libpython3.6-stdlib пакета я не могу установить

ТС, как видно по состоянию на 13/02/2020 потерял интерес к созданной им теме (пометка Решено в теме отсутствует, тема оставлена не закрытой, сообщений в теме давно не было). Тема стародавняя (последнее сообщение в топике: 29/01/2019; последнее сообщение от ТС в топике: 28/01/2019). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 13 Февраль 2020, 00:05:26 от zg_nico »

Оффлайн zg_nico

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 3511
  • Nil mortalibus arduum est
    • Просмотр профиля
Re: Kubuntu 18.04 LST x64 не ставится пакет python3-dev
« Ответ #11 : 29 Январь 2019, 09:24:15 »
alextolmy, вы сам python не из исходников каких-нибудь ставили часом?
alextolmy, попробуйте удалить текущие пакеты, удалить все установленное автоматом, перечитать репозитории, как вариант:sudo apt update
sudo apt purge libpython3-dev python3-dev
sudo apt purge libpython3.6-dev python3.6-dev
sudo apt autoremove
sudo apt update
После описанного проверьте выхлопы (и покажите их здесь):sudo apt install -f
dpkg --get-selections | grep -i hold
Далее попробуйте установить что пытались с самого начала: sudo apt install python3-devВыхлоп опять-таки интересен
« Последнее редактирование: 29 Январь 2019, 09:36:46 от zg_nico »
Thunderobot G150-D2: Intel SkyLake Core i7-6700HQ 2.60GHz, 8Gb DDR4 2133 MHz, Intel HD530, NVidia GeForce GTX 960M 2Gb.  Ubuntu 16.04 64x [Unity], KUbuntu 18.04 64x.

 

Страница сгенерирована за 0.229 секунд. Запросов: 22.