Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Установка Apache версии 2.2 и 2.4 в одной системе. Возможно ?  (Прочитано 241 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ZERG13

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Добрый день.

Кто нибудь пробывал установить Apache 2.2 и 2.4 рядом ?
Просьба не начинать писать зачем? нафига и т.д. Интересует конкретно, есть ли возможность и пробывал ли кто.



OS: Ubuntu 18.04.1 LTS (GNU/Linux 4.15.0-44-generic x86_64)
« Последнее редактирование: 31 Январь 2019, 13:02:01 от ZERG13 »

Оффлайн Heider

  • Старожил
  • *
  • Сообщений: 1163
    • Просмотр профиля
Можно, конечно. Но придется помучиться. У них же демон будет одинаково называться и файлы конфигов, и сокет. Если это все разделить, то должно работать.

Ну, еще можно устанавливать и запускать каждый в своем чруте, как вариант.

Оффлайн ZERG13

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Можно, конечно. Но придется помучиться. У них же демон будет одинаково называться и файлы конфигов, и сокет. Если это все разделить, то должно работать.

Ну, еще можно устанавливать и запускать каждый в своем чруте, как вариант.

Инструкцию не подкинете ?  :)

Оффлайн Heider

  • Старожил
  • *
  • Сообщений: 1163
    • Просмотр профиля
Инструкцию не подкинете ? 
Я не вижу никакой пользы от такой инструкции, ни для кого. Или разбирайтесь сами, или скажите, зачем это нужно.

Оффлайн ZERG13

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Инструкцию не подкинете ?
Я не вижу никакой пользы от такой инструкции, ни для кого. Или разбирайтесь сами, или скажите, зачем это нужно.

Есть платформа 1С 8.3.6.2332 она поддерживает только апач 2.2. В то же время установлены самые свежие платформы, которые уже работают на апаче 2.4. Конечно, можно все платформы держать на апаче 2.2, но если прилетит платформа, в которой 1с перестанет осуществлять поддержу версии 2.2. Вот и хочется, поднять оба варианта, а когда перестанем использовать старую платформу 1с, выпилить апач 2.2 и оставить только 2.4

Оффлайн Heider

  • Старожил
  • *
  • Сообщений: 1163
    • Просмотр профиля
Поверьте, для Вас будет гораздо проще, быстрее и дешевле разделить сервера. Либо аппаратно, либо виртуально, или можно даже так:
chroot+debootstrap - почти виртуалка



Пользователь добавил сообщение 31 Январь 2019, 13:45:24:
Вот неплохая статейка поближе к теме.
« Последнее редактирование: 31 Январь 2019, 13:45:24 от Heider »

Оффлайн citu

  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
установить Apache 2.2 и 2.4 рядом ?
docker?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26253
    • Просмотр профиля
Есть платформа 1С 8.3.6.2332 она поддерживает только апач 2.2.
Бред же ж.
Что именно там поддерживает "апач 2.2"?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн ZERG13

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Есть платформа 1С 8.3.6.2332 она поддерживает только апач 2.2.
Бред же ж.
Что именно там поддерживает "апач 2.2"?

В платформе 8.3.6.2332 есть только wsap22.so, а для апача 2.4 нужен wsap24.so

 

Страница сгенерирована за 0.063 секунд. Запросов: 24.